aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authorroam <roam@FreeBSD.org>2001-08-28 01:17:17 +0800
committerroam <roam@FreeBSD.org>2001-08-28 01:17:17 +0800
commita8dc9eeda7687000eb319eec4577e1d3036b2cdd (patch)
tree8ffcf33d4ca8e7413c476604f81362a2e9a92524 /sysutils
parent7b7f6b79c9e85785fb2ad7956139baa084d17a0f (diff)
downloadfreebsd-ports-gnome-a8dc9eeda7687000eb319eec4577e1d3036b2cdd.tar.gz
freebsd-ports-gnome-a8dc9eeda7687000eb319eec4577e1d3036b2cdd.tar.zst
freebsd-ports-gnome-a8dc9eeda7687000eb319eec4577e1d3036b2cdd.zip
Add penv-1.0pre2.
penv - 'program environment' or 'ports environment' - is a simple utility that executes a given command after setting some environment variables corresponding to the current directory. This makes it much easier to keep persistent environment settings for building the same ports over and over again. For example, the following series of commands: $ echo cp1251 > /var/db/penv/databases/mysql323-server/WITH_CHARSET $ echo all > /var/db/penv/databases/mysql323-server/WITH_XCHARSET ..allows a simple way to build the MySQL-3.23 server with the same character set configuration every time by doing: [root@ringworld:/usr/ports/databases/mysql323-server]# penv make For more information, see the penv.1 manual page and the sample configuration file in the penv distribution.
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/penv/Makefile47
-rw-r--r--sysutils/penv/distinfo1
-rw-r--r--sysutils/penv/pkg-comment1
-rw-r--r--sysutils/penv/pkg-descr5
-rw-r--r--sysutils/penv/pkg-plist6
6 files changed, 61 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index 88bbff9ed4bb..4cb9d7e5fb98 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -114,6 +114,7 @@
SUBDIR += p5-Unix-Syslog
SUBDIR += paicc
SUBDIR += pdumpfs
+ SUBDIR += penv
SUBDIR += perf
SUBDIR += personality
SUBDIR += pib
diff --git a/sysutils/penv/Makefile b/sysutils/penv/Makefile
new file mode 100644
index 000000000000..d6e6919330e7
--- /dev/null
+++ b/sysutils/penv/Makefile
@@ -0,0 +1,47 @@
+# New ports collection makefile for: penv
+# Date created: 5 August 2001
+# Whom: roam@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= penv
+PORTVERSION= 1.0.b2
+CATEGORIES= sysutils
+MASTER_SITES= http://devel.ringlet.net/sysutils/penv/
+DISTNAME= ${PORTNAME}-${PORTVERSION:S/.b/pre/}
+
+MAINTAINER= roam@FreeBSD.org
+
+RUN_DEPENDS= envdir:${PORTSDIR}/sysutils/daemontools
+
+MAN1= penv.1
+MANCOMPRESSED= yes
+
+CFLAGS_COMPAT= -DHAVE_STRLCPY -DHAVE_FGETLN
+MAKE_ENV+= CFLAGS_COMPAT="${CFLAGS_COMPAT}"
+
+.if !defined(NO_RELEASE)
+MAKE_ENV+= RELEASE=yes
+.endif
+
+DBDIR?= /var/db/${PORTNAME}
+
+PREFIXCONF= penv.1 penv.conf.default
+DBCONF= pathnames.h penv.1 penv.conf.default
+
+post-patch:
+ ${PERL} -pi.pfx -e "s,/usr/local,${PREFIX},g" \
+ ${PREFIXCONF:S,^,${WRKSRC}/,}
+ ${PERL} -pi.dbdir -e "s,/var/db/penv,${DBDIR},g" \
+ ${DBCONF:S,^,${WRKSRC}/,}
+
+post-install:
+ ${MKDIR} ${PREFIX}/etc
+ ${INSTALL_DATA} ${WRKSRC}/penv.conf.default ${PREFIX}/etc
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}/html
+ ${INSTALL_DATA} ${WRKSRC}/doc/html/* ${DOCSDIR}/html
+.endif
+
+.include <bsd.port.mk>
diff --git a/sysutils/penv/distinfo b/sysutils/penv/distinfo
new file mode 100644
index 000000000000..84494d0d974b
--- /dev/null
+++ b/sysutils/penv/distinfo
@@ -0,0 +1 @@
+MD5 (penv-1.0pre2.tar.gz) = fa90ea7b97b88b25a36d339c7544c2db
diff --git a/sysutils/penv/pkg-comment b/sysutils/penv/pkg-comment
new file mode 100644
index 000000000000..7ccead9f79ec
--- /dev/null
+++ b/sysutils/penv/pkg-comment
@@ -0,0 +1 @@
+Set the environment accoring to the current working directory
diff --git a/sysutils/penv/pkg-descr b/sysutils/penv/pkg-descr
new file mode 100644
index 000000000000..cf043c599bfb
--- /dev/null
+++ b/sysutils/penv/pkg-descr
@@ -0,0 +1,5 @@
+Penv runs a specified command after setting an execution environment
+corresponding to the current working directory.
+
+WWW: http://devel.ringlet.net/sysutils/penv/
+Author: Peter Pentchev <roam@ringlet.net>
diff --git a/sysutils/penv/pkg-plist b/sysutils/penv/pkg-plist
new file mode 100644
index 000000000000..dc3da73171ae
--- /dev/null
+++ b/sysutils/penv/pkg-plist
@@ -0,0 +1,6 @@
+bin/penv
+etc/penv.conf.default
+%%PORTDOCS%%share/doc/penv/html/created.with.vim.gif
+%%PORTDOCS%%share/doc/penv/html/index.html
+%%PORTDOCS%%@dirrm share/doc/penv/html
+%%PORTDOCS%%@dirrm share/doc/penv