aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authorleeym <leeym@FreeBSD.org>2004-09-01 22:59:58 +0800
committerleeym <leeym@FreeBSD.org>2004-09-01 22:59:58 +0800
commitb1b4f8dcee155a17910f794f43fdda523d37c4a9 (patch)
tree594235a6e1250af450170e41ade9fb1769429651 /sysutils
parent78a9dae7f500660bd8f45720f6380475bbf83f14 (diff)
downloadfreebsd-ports-gnome-b1b4f8dcee155a17910f794f43fdda523d37c4a9.tar.gz
freebsd-ports-gnome-b1b4f8dcee155a17910f794f43fdda523d37c4a9.tar.zst
freebsd-ports-gnome-b1b4f8dcee155a17910f794f43fdda523d37c4a9.zip
- add USE_GETOPT_LONG=yes and related patch
- add USE_LIBTOOL_VER=15 and remove *.la from pkg-plist - disable NLS support if WITHOUT_NLS=yes is defined - bump PORTREVISION
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/progsreiserfs/Makefile29
-rw-r--r--sysutils/progsreiserfs/files/extrapatch-progsreiserfs::libmisc::Makefile.in37
-rw-r--r--sysutils/progsreiserfs/pkg-plist2
3 files changed, 58 insertions, 10 deletions
diff --git a/sysutils/progsreiserfs/Makefile b/sysutils/progsreiserfs/Makefile
index 1a00576ebdca..53d6d785263c 100644
--- a/sysutils/progsreiserfs/Makefile
+++ b/sysutils/progsreiserfs/Makefile
@@ -7,6 +7,7 @@
PORTNAME= progsreiserfs
PORTVERSION= 0.3.1.r8
+PORTREVISION= 1
CATEGORIES= sysutils
MASTER_SITES= http://www.cgsecurity.org/
DISTNAME= ${PORTNAME}-${PORTVERSION:S/.r/-rc/}
@@ -14,22 +15,34 @@ DISTNAME= ${PORTNAME}-${PORTVERSION:S/.r/-rc/}
MAINTAINER= ports@FreeBSD.org
COMMENT= Utilities and library to manipulate ReiserFS partitions
-LIB_DEPENDS= gnugetopt.1:${PORTSDIR}/devel/libgnugetopt
-
GNU_CONFIGURE= yes
-USE_GETTEXT= yes
-USE_INC_LIBTOOL_VER= 15
+USE_GETOPT_LONG=yes
+USE_LIBTOOL_VER=15
INSTALLS_SHLIB= yes
USE_REINPLACE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-CONFIGURE_ENV= CPPFLAGS="-I${PREFIX}/include" LDFLAGS="-L${PREFIX}/lib -lgnugetopt"
CONFIGURE_ARGS= --disable-debug
+.if defined(WITHOUT_NLS)
+CONFIGURE_ARGS+=--disable-nls
+.else
+USE_GETTEXT= yes
+.endif
+
MAN8= cpfs.reiserfs.8 mkfs.reiserfs.8 reiserfs.8 \
resizefs.reiserfs.8 tunefs.reiserfs.8
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500041
+CFLAGS+= -Dgetopt_long_only=getopt_long
+EXTRA_PATCHES= ${FILESDIR}/extrapatch-progsreiserfs::libmisc::Makefile.in
+.endif
+
post-patch:
- ${REINPLACE_CMD} -e 's|sys/int_types.h|inttypes.h|' ${WRKSRC}/libreiserfs/tools.c
- ${REINPLACE_CMD} -e 's|sys/int_types.h|inttypes.h|' ${WRKSRC}/include/reiserfs/*
+ @${REINPLACE_CMD} -e 's|^LIBTOOL=.*|LIBTOOL=${LIBTOOL}|g' \
+ ${WRKSRC}/${CONFIGURE_SCRIPT}
+ @${REINPLACE_CMD} -e 's|sys/int_types.h|inttypes.h|' \
+ ${WRKSRC}/libreiserfs/tools.c ${WRKSRC}/include/reiserfs/*
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/sysutils/progsreiserfs/files/extrapatch-progsreiserfs::libmisc::Makefile.in b/sysutils/progsreiserfs/files/extrapatch-progsreiserfs::libmisc::Makefile.in
new file mode 100644
index 000000000000..cf1a04460f8f
--- /dev/null
+++ b/sysutils/progsreiserfs/files/extrapatch-progsreiserfs::libmisc::Makefile.in
@@ -0,0 +1,37 @@
+--- progsreiserfs/libmisc/Makefile.in.orig Wed Sep 1 12:29:59 2004
++++ progsreiserfs/libmisc/Makefile.in Wed Sep 1 12:30:29 2004
+@@ -110,7 +110,7 @@
+ install_sh = @install_sh@
+
+ noinst_LTLIBRARIES = libmisc.la
+-libmisc_la_SOURCES = tools.c getopt.c getopt1.c
++libmisc_la_SOURCES = tools.c getopt.c
+
+ INCLUDES = -I$(top_srcdir)/include @INTLINCS@
+ subdir = progsreiserfs/libmisc
+@@ -121,7 +121,7 @@
+
+ libmisc_la_LDFLAGS =
+ libmisc_la_LIBADD =
+-am_libmisc_la_OBJECTS = tools.lo getopt.lo getopt1.lo
++am_libmisc_la_OBJECTS = tools.lo getopt.lo
+ libmisc_la_OBJECTS = $(am_libmisc_la_OBJECTS)
+
+ DEFS = @DEFS@
+@@ -130,7 +130,7 @@
+ LDFLAGS = @LDFLAGS@
+ LIBS = @LIBS@
+ depcomp = $(SHELL) $(top_srcdir)/depcomp
+-@AMDEP_TRUE@DEP_FILES = $(DEPDIR)/getopt.Plo $(DEPDIR)/getopt1.Plo \
++@AMDEP_TRUE@DEP_FILES = $(DEPDIR)/getopt.Plo \
+ @AMDEP_TRUE@ $(DEPDIR)/tools.Plo
+ COMPILE = $(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) \
+ $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS)
+@@ -177,7 +177,6 @@
+ -rm -f *.tab.c
+
+ @AMDEP_TRUE@@am__include@ @am__quote@$(DEPDIR)/getopt.Plo@am__quote@
+-@AMDEP_TRUE@@am__include@ @am__quote@$(DEPDIR)/getopt1.Plo@am__quote@
+ @AMDEP_TRUE@@am__include@ @am__quote@$(DEPDIR)/tools.Plo@am__quote@
+
+ distclean-depend:
diff --git a/sysutils/progsreiserfs/pkg-plist b/sysutils/progsreiserfs/pkg-plist
index a0b7fe6ea132..244f87c20926 100644
--- a/sysutils/progsreiserfs/pkg-plist
+++ b/sysutils/progsreiserfs/pkg-plist
@@ -22,12 +22,10 @@ include/reiserfs/tree.h
lib/libdal-0.3.so
lib/libdal-0.3.so.0
lib/libdal.a
-lib/libdal.la
lib/libdal.so
lib/libreiserfs-0.3.so
lib/libreiserfs-0.3.so.0
lib/libreiserfs.a
-lib/libreiserfs.la
lib/libreiserfs.so
sbin/cpfs.reiserfs
sbin/fsck.reiserfs