aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2012-07-28 01:06:03 +0800
committerbapt <bapt@FreeBSD.org>2012-07-28 01:06:03 +0800
commitb8e9b069fbb56d01330def155a8f8d99ce61c3df (patch)
tree2ea57431dddea5c41b886f8f681dcebd0c224aae /sysutils
parentdaf6bdb08349003e1f1fd517f5e06e0d2957b71b (diff)
downloadfreebsd-ports-gnome-b8e9b069fbb56d01330def155a8f8d99ce61c3df.tar.gz
freebsd-ports-gnome-b8e9b069fbb56d01330def155a8f8d99ce61c3df.tar.zst
freebsd-ports-gnome-b8e9b069fbb56d01330def155a8f8d99ce61c3df.zip
Add some explicit USE_PKGCONFIG=build
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/eiciel/Makefile1
-rw-r--r--sysutils/fusefs-gnome-vfs/Makefile1
-rw-r--r--sysutils/gkleds2/Makefile1
-rw-r--r--sysutils/graveman/Makefile1
-rw-r--r--sysutils/pyrenamer/Makefile1
-rw-r--r--sysutils/quicksynergy/Makefile1
-rw-r--r--sysutils/sensors-applet/Makefile1
-rw-r--r--sysutils/serpentine/Makefile4
-rw-r--r--sysutils/wmfire/Makefile1
9 files changed, 10 insertions, 2 deletions
diff --git a/sysutils/eiciel/Makefile b/sysutils/eiciel/Makefile
index 891775dab000..4a67649a9226 100644
--- a/sysutils/eiciel/Makefile
+++ b/sysutils/eiciel/Makefile
@@ -23,6 +23,7 @@ USE_GNOME= gnomehack gnomeprefix intlhack nautilus2 libgnomeui
USE_GMAKE= yes
USE_AUTOTOOLS= libtool
+USE_PKGCONFIG= build
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
CONFIGURE_ARGS= --with-nautilus-extensions-dir=${PREFIX}/lib/nautilus/extensions-2.0
diff --git a/sysutils/fusefs-gnome-vfs/Makefile b/sysutils/fusefs-gnome-vfs/Makefile
index 5ff4b86f46b8..9b9f525c5082 100644
--- a/sysutils/fusefs-gnome-vfs/Makefile
+++ b/sysutils/fusefs-gnome-vfs/Makefile
@@ -22,6 +22,7 @@ RPORTNAME= gnome-vfs-fuse
WRKSRC= ${WRKDIR}/${RPORTNAME}
USE_GNOME= gnomevfs2
USE_GMAKE= yes
+USE_PKGCONFIG= yes
PLIST_FILES= bin/gnomevfs-mount
PORTDOCS= README
diff --git a/sysutils/gkleds2/Makefile b/sysutils/gkleds2/Makefile
index 9eba2eca197b..5bb430003228 100644
--- a/sysutils/gkleds2/Makefile
+++ b/sysutils/gkleds2/Makefile
@@ -22,6 +22,7 @@ USE_XORG= x11 xtst
USE_GNOME= gtk20
USE_GMAKE= yes
USE_AUTOTOOLS= libtool
+USE_PKGCONFIG= build
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
diff --git a/sysutils/graveman/Makefile b/sysutils/graveman/Makefile
index 92a5f8e95049..2b3003653ef7 100644
--- a/sysutils/graveman/Makefile
+++ b/sysutils/graveman/Makefile
@@ -22,6 +22,7 @@ USE_GMAKE= yes
USE_GETTEXT= yes
GNU_CONFIGURE= yes
USE_CDRTOOLS= yes
+USE_PKGCONFIG= build
USE_GNOME= libglade2 intlhack gnomehack gnomeprefix
CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
CPPFLAGS+= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
diff --git a/sysutils/pyrenamer/Makefile b/sysutils/pyrenamer/Makefile
index 8df6efdf9566..90775d19a9fa 100644
--- a/sysutils/pyrenamer/Makefile
+++ b/sysutils/pyrenamer/Makefile
@@ -19,6 +19,7 @@ USE_GNOME= gconf2 gnomehack pygtk2
USE_PYTHON= yes
USE_GETTEXT= yes
USE_GMAKE= yes
+USE_PKGCONFIG= build
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
diff --git a/sysutils/quicksynergy/Makefile b/sysutils/quicksynergy/Makefile
index 0152213b5f0d..4c048a95c07a 100644
--- a/sysutils/quicksynergy/Makefile
+++ b/sysutils/quicksynergy/Makefile
@@ -19,6 +19,7 @@ BUILD_DEPENDS= synergys:${PORTSDIR}/sysutils/synergy
GNU_CONFIGURE= yes
USE_ICONV= yes
USE_GETTEXT= yes
+USE_PKGCONFIG= yes
USE_GNOME= gnomehack gnomeprefix libglade2
CPPFLAGS+= -I${LOCALBASE}/include
diff --git a/sysutils/sensors-applet/Makefile b/sysutils/sensors-applet/Makefile
index 9ad3fe4a6a30..4a426c95d933 100644
--- a/sysutils/sensors-applet/Makefile
+++ b/sysutils/sensors-applet/Makefile
@@ -18,6 +18,7 @@ RUN_DEPENDS= mbmon:${PORTSDIR}/sysutils/mbmon \
smartctl:${PORTSDIR}/sysutils/smartmontools
USE_GNOME= gnomehack gnomeprefix intlhack gnomepanel libgnomeui
+USE_PKGCONFIG= build
GNU_CONFIGURE= yes
USE_GMAKE= yes
DEFINES= -DMBMON_EXECUTABLE=\\\"${LOCALBASE}/bin/mbmon\\\" \
diff --git a/sysutils/serpentine/Makefile b/sysutils/serpentine/Makefile
index 869ddcf4da68..0ed5d94e0ebe 100644
--- a/sysutils/serpentine/Makefile
+++ b/sysutils/serpentine/Makefile
@@ -21,8 +21,8 @@ USE_BZIP2= yes
GNU_CONFIGURE= yes
USE_GNOME= pygnomedesktop intlhack
USE_GMAKE= yes
+USE_PKGCONFIG= build
USE_GSTREAMER= core gnomevfs python
USE_PYTHON= 2.4+
-.include <bsd.port.pre.mk>
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/sysutils/wmfire/Makefile b/sysutils/wmfire/Makefile
index 6c67fcc1e5ba..2f2d1de46c78 100644
--- a/sysutils/wmfire/Makefile
+++ b/sysutils/wmfire/Makefile
@@ -17,6 +17,7 @@ COMMENT= Window Maker dock app showing load average as a flame
LIB_DEPENDS= gtop-2.0.7:${PORTSDIR}/devel/libgtop
USE_GNOME= gtk20
+USE_PKGCONFIG= build
GNU_CONFIGURE= yes
USE_CSTD= gnu89
CPPFLAGS+= -I${LOCALBASE}/include