aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2008-06-13 10:08:24 +0800
committeredwin <edwin@FreeBSD.org>2008-06-13 10:08:24 +0800
commitc14c9cc6ae5483f0f75af00c7bd15cbb3265da23 (patch)
tree2c53c4f1da4de1129830f95c75662fc6e6a70ae4 /sysutils
parent47e9efeb6e839cbd793c348a422cb8b5722aa9e5 (diff)
downloadfreebsd-ports-gnome-c14c9cc6ae5483f0f75af00c7bd15cbb3265da23.tar.gz
freebsd-ports-gnome-c14c9cc6ae5483f0f75af00c7bd15cbb3265da23.tar.zst
freebsd-ports-gnome-c14c9cc6ae5483f0f75af00c7bd15cbb3265da23.zip
[NEW PORT] sysutils/jtopen: a Java library to access OS/400 or i5/OS system
JTOpen is the open source version of the IBM Toolbox for Java licensed program product. The IBM Toolbox for Java is a library of Java classes supporting the client/server and internet programming models to a system running OS/400 or i5/OS. The classes can be used by Java applets, servlets, and applications to easily access OS/400 and i5/OS data and resources. The Toolbox does not require additional client support over and above what is provided by the Java Virtual Machine and TCP/IP. WWW: http://jt400.sourceforge.net/ PR: ports/124534 Submitted by: Marcin Cieslak <saper@system.pl>
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/jtopen/Makefile43
-rw-r--r--sysutils/jtopen/distinfo3
-rw-r--r--sysutils/jtopen/pkg-descr11
-rw-r--r--sysutils/jtopen/pkg-plist15
5 files changed, 73 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index 153fb0071a10..67c5ed340ab6 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -343,6 +343,7 @@
SUBDIR += jkill
SUBDIR += jps
SUBDIR += jtop
+ SUBDIR += jtopen
SUBDIR += k3b
SUBDIR += k8temp
SUBDIR += kcpuload
diff --git a/sysutils/jtopen/Makefile b/sysutils/jtopen/Makefile
new file mode 100644
index 000000000000..88ea2b57c237
--- /dev/null
+++ b/sysutils/jtopen/Makefile
@@ -0,0 +1,43 @@
+# New ports collection makefile for: jtopen
+# Date created: 2008-06-13
+# Whom: Marcin Cieslak <saper@SYSTEM.PL>
+#
+# $FreeBSD$
+#
+
+PORTNAME= jtopen
+PORTVERSION= 6.2
+CATEGORIES= sysutils java
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= jt400
+DISTNAME= ${PORTNAME}_${PORTVERSION:S/./_/}
+
+MAINTAINER= saper@SYSTEM.PL
+COMMENT= JTOpen is a Java library to access OS/400 or i5/OS system
+
+USE_ZIP= yes
+NO_WRKSUBDIR= yes
+USE_JAVA= 1.4+
+
+NO_BUILD= yes
+
+JAR_FILES= composer.jar jt400.jar jt400Proxy.jar jt400Servlet.jar jui400.jar \
+ outputwriters.jar reportwriter.jar tes.jar uitools.jar util400.jar
+DOC_FILES= changes.html license.html readme.html
+
+.include <bsd.port.pre.mk>
+
+do-install:
+.for i in ${JAR_FILES}
+ ${INSTALL_DATA} ${WRKSRC}/lib/${i} ${JAVAJARDIR}
+.endfor
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+.for d in ${DOC_FILES}
+ ${INSTALL_MAN} ${WRKSRC}/${d} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/sysutils/jtopen/distinfo b/sysutils/jtopen/distinfo
new file mode 100644
index 000000000000..243a1b1e11c6
--- /dev/null
+++ b/sysutils/jtopen/distinfo
@@ -0,0 +1,3 @@
+MD5 (jtopen_6_2.zip) = f70ab6eec82ab5463279d9d35c4e2535
+SHA256 (jtopen_6_2.zip) = e644849712a88bde444ee6298730507421562698394bd3a4657c56747a13e55e
+SIZE (jtopen_6_2.zip) = 12089384
diff --git a/sysutils/jtopen/pkg-descr b/sysutils/jtopen/pkg-descr
new file mode 100644
index 000000000000..47d4518361b9
--- /dev/null
+++ b/sysutils/jtopen/pkg-descr
@@ -0,0 +1,11 @@
+JTOpen is the open source version of the IBM Toolbox for Java
+licensed program product. The IBM Toolbox for Java is a library
+of Java classes supporting the client/server and internet programming
+models to a system running OS/400 or i5/OS. The classes can be used
+by Java applets, servlets, and applications to easily access OS/400
+and i5/OS data and resources.
+
+The Toolbox does not require additional client support over and
+above what is provided by the Java Virtual Machine and TCP/IP.
+
+WWW: http://jt400.sourceforge.net/
diff --git a/sysutils/jtopen/pkg-plist b/sysutils/jtopen/pkg-plist
new file mode 100644
index 000000000000..02e3404646c4
--- /dev/null
+++ b/sysutils/jtopen/pkg-plist
@@ -0,0 +1,15 @@
+@comment $FreeBSD$
+%%JAVAJARDIR%%/composer.jar
+%%JAVAJARDIR%%/jt400.jar
+%%JAVAJARDIR%%/jt400Proxy.jar
+%%JAVAJARDIR%%/jt400Servlet.jar
+%%JAVAJARDIR%%/jui400.jar
+%%JAVAJARDIR%%/outputwriters.jar
+%%JAVAJARDIR%%/reportwriter.jar
+%%JAVAJARDIR%%/tes.jar
+%%JAVAJARDIR%%/uitools.jar
+%%JAVAJARDIR%%/util400.jar
+%%PORTDOCS%%%%DOCSDIR%%/changes.html
+%%PORTDOCS%%%%DOCSDIR%%/license.html
+%%PORTDOCS%%%%DOCSDIR%%/readme.html
+%%PORTDOCS%%@dirrm %%DOCSDIR%%