aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2014-05-09 05:58:30 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2014-05-09 05:58:30 +0800
commitc4be745e31702984b4caf866b22d42d3a41b2c4a (patch)
tree6c75ddabc58ef8c5a275ed3cf882a368839eef7b /sysutils
parentec34affc2e1e594ad95d3ead2a493317f2d2e419 (diff)
downloadfreebsd-ports-gnome-c4be745e31702984b4caf866b22d42d3a41b2c4a.tar.gz
freebsd-ports-gnome-c4be745e31702984b4caf866b22d42d3a41b2c4a.tar.zst
freebsd-ports-gnome-c4be745e31702984b4caf866b22d42d3a41b2c4a.zip
- Switch to USES=libtool
- Strip library
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/fusefs-ntfs/Makefile9
-rw-r--r--sysutils/fusefs-ntfs/files/patch-configure9
-rw-r--r--sysutils/fusefs-ntfs/pkg-plist4
3 files changed, 7 insertions, 15 deletions
diff --git a/sysutils/fusefs-ntfs/Makefile b/sysutils/fusefs-ntfs/Makefile
index 1d5326b5d856..ac8559b35cb4 100644
--- a/sysutils/fusefs-ntfs/Makefile
+++ b/sysutils/fusefs-ntfs/Makefile
@@ -17,9 +17,9 @@ LICENSE= GPLv2
CONFLICTS_BUILD= bonobo-1.*
CONFLICTS_INSTALL= ntfsprogs-*
-USES= fuse pkgconfig iconv
+USES= fuse pkgconfig iconv libtool
USE_LDCONFIG= yes
-USE_AUTOTOOLS= libtool
+GNU_CONFIGURE= yes
CONFIGURE_ARGS= --exec-prefix=${PREFIX} --disable-mount-helper \
--disable-mtab --with-fuse=external --disable-ldconfig
CPPFLAGS+= -I${WRKSRC}/include/ntfs-3g/ -I${LOCALBASE}/include
@@ -50,10 +50,11 @@ post-patch:
${WRKSRC}/libntfs-3g/object_id.c \
${WRKSRC}/libntfs-3g/reparse.c \
${WRKSRC}/libntfs-3g/security.c
- @${REINPLACE_CMD} -e 's|\($$(AM_CFLAGS)\) \(-I$$(top_srcdir)/include/ntfs-3g\)|\2 \1|' \
- ${WRKSRC}/libntfs-3g/Makefile.in
+ @${REINPLACE_CMD} -e 's|\($$(AM_CFLAGS)\) \(-I$$(top_srcdir)/include/ntfs-3g\)|\2 \1|; \
+ /install-exec-hook:/,/^$$/ s|^@.*||' ${WRKSRC}/libntfs-3g/Makefile.in
post-install:
${INSTALL_DATA} ${FILESDIR}/README.FreeBSD ${STAGEDIR}${DOCSDIR}/
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libntfs-3g.so
.include <bsd.port.post.mk>
diff --git a/sysutils/fusefs-ntfs/files/patch-configure b/sysutils/fusefs-ntfs/files/patch-configure
index 6a0604738a84..39fec4d7e2dc 100644
--- a/sysutils/fusefs-ntfs/files/patch-configure
+++ b/sysutils/fusefs-ntfs/files/patch-configure
@@ -9,15 +9,6 @@
*) enable_mount_helper="no" ;;
esac
-@@ -7991,7 +7991,7 @@
- LIBTOOL_DEPS="$ltmain"
-
- # Always use our own libtool.
--LIBTOOL='$(SHELL) $(top_builddir)/libtool'
-+LIBTOOL='$(SHELL) /usr/local/bin/libtool'
-
-
-
@@ -9527,7 +9527,7 @@
hardcode_shlibpath_var=no
;;
diff --git a/sysutils/fusefs-ntfs/pkg-plist b/sysutils/fusefs-ntfs/pkg-plist
index 29152ef9fe4d..d5e2f91740b5 100644
--- a/sysutils/fusefs-ntfs/pkg-plist
+++ b/sysutils/fusefs-ntfs/pkg-plist
@@ -46,9 +46,9 @@ include/ntfs-3g/unistr.h
include/ntfs-3g/volume.h
include/ntfs-3g/xattrs.h
lib/libntfs-3g.a
-lib/libntfs-3g.la
lib/libntfs-3g.so
lib/libntfs-3g.so.85
+lib/libntfs-3g.so.85.0.0
libdata/pkgconfig/libntfs-3g.pc
man/man8/mkntfs.8.gz
man/man8/ntfs-3g.8.gz
@@ -75,5 +75,5 @@ sbin/ntfsresize
sbin/ntfsundelete
%%PORTDOCS%%%%DOCSDIR%%/README
%%PORTDOCS%%%%DOCSDIR%%/README.FreeBSD
-%%PORTDOCS%%@dirrm %%DOCSDIR%%
@dirrm include/ntfs-3g
+%%PORTDOCS%%@dirrmtry %%DOCSDIR%%