aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authorgirgen <girgen@FreeBSD.org>2005-01-31 08:35:55 +0800
committergirgen <girgen@FreeBSD.org>2005-01-31 08:35:55 +0800
commitca9d0e2291f677879c1b36a416eb2ad271850cbc (patch)
tree339f4530a6f0b38252173ddc8ba47c21226501d3 /sysutils
parentcbe074a01a678ad3149123153f48962b4b035576 (diff)
downloadfreebsd-ports-gnome-ca9d0e2291f677879c1b36a416eb2ad271850cbc.tar.gz
freebsd-ports-gnome-ca9d0e2291f677879c1b36a416eb2ad271850cbc.tar.zst
freebsd-ports-gnome-ca9d0e2291f677879c1b36a416eb2ad271850cbc.zip
Split the postgresql ports into a server and a client part.
All ports depending on postgresql shall use the USE_PGSQL=yes knob defined in Mk/bsd.ports.mk. Bumping portrevisions where needed. PR: 75344 Approved by: portmgr@ (kris), ade & sean (mentors)
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/bacula-server/Makefile10
-rw-r--r--sysutils/msyslog/Makefile3
2 files changed, 6 insertions, 7 deletions
diff --git a/sysutils/bacula-server/Makefile b/sysutils/bacula-server/Makefile
index e0a82a38eacd..0bbb38cc72cd 100644
--- a/sysutils/bacula-server/Makefile
+++ b/sysutils/bacula-server/Makefile
@@ -56,7 +56,7 @@ OPTIONS+= WXCONSOLE "Build with wxGTK based GUI console" off
OPTIONS+= GNOMECONSOLE "Build with GNOME based GUI console" off
.else
OPTIONS= MYSQL "Use MySQL database instead of SqLite" off
-OPTIONS+= POSTGRESQL7 "Use PostgreSQL 7.X database instead of SqLite" off
+OPTIONS+= POSTGRESQL "Use PostgreSQL database instead of SqLite" off
OPTIONS+= MTX "Install mtx for control of autochanger devices" off
.endif
@@ -107,9 +107,9 @@ CONFFILES= sd dir
CONFIGURE_ARGS+= --with-mysql=yes
USE_MYSQL= yes
DBTYPE= mysql
-.elif defined(WITH_POSTGRESQL7)
+.elif defined(WITH_POSTGRESQL)
+USE_PGSQL= yes
CONFIGURE_ARGS+= --with-postgresql=yes
-LIB_DEPENDS+= pq:${PORTSDIR}/databases/postgresql7
DBTYPE= postgresql
.else
CONFIGURE_ARGS+= --with-sqlite=yes
@@ -136,9 +136,9 @@ pre-everything::
@${ECHO_MSG} " WITH_WXCONSOLE=yes if you only want a wxGTK based GUI console."
@${ECHO_MSG} " WITH_GNOMECONSOLE=yes if you only want a GNOME based GUI console."
@${ECHO_MSG} " WITH_MTX=yes if you want to use mtx instead of chio for autochanger control."
-.if !defined(WITH_MYSQL) && !defined(WITH_POSTGRESQL7)
+.if !defined(WITH_MYSQL) && !defined(WITH_POSTGRESQL)
@${ECHO_MSG} " WITH_MYSQL=yes if you want MySQL instead of SqLite as the database."
- @${ECHO_MSG} " WITH_POSTGRESQL7=yes if you want PostgreSQL 7.X instead of SqLite as the database."
+ @${ECHO_MSG} " WITH_POSTGRESQL=yes if you want PostgreSQL instead of SqLite as the database."
@${ECHO_MSG} ""
@${ECHO_MSG} "The default DB is SQLite!"
.endif
diff --git a/sysutils/msyslog/Makefile b/sysutils/msyslog/Makefile
index 4766fa2aadd6..b2d366c74480 100644
--- a/sysutils/msyslog/Makefile
+++ b/sysutils/msyslog/Makefile
@@ -21,8 +21,7 @@ COMMENT= Flexible and easy to integrate syslog daemon
LIB_DEPENDS+= mysqlclient.10:${PORTSDIR}/databases/mysql323-client
.endif
.if defined(WITH_PGSQL)
-POSTGRESQL_PORT?= databases/postgresql7
-LIB_DEPENDS+= pq.3:${PORTSDIR}/${POSTGRESQL_PORT}
+USE_PGSQL= yes
.endif
GNU_CONFIGURE= yes