aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2014-05-10 08:27:45 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2014-05-10 08:27:45 +0800
commitcc7b875d4ca0ac768375f28f2dc2a549ac846ad9 (patch)
treeb99ddacbd6ab6384b9619f9c1d1de45c1f0b9c00 /sysutils
parentc0c8302dd44222d06487e0aecee7154b210edaf3 (diff)
downloadfreebsd-ports-gnome-cc7b875d4ca0ac768375f28f2dc2a549ac846ad9.tar.gz
freebsd-ports-gnome-cc7b875d4ca0ac768375f28f2dc2a549ac846ad9.tar.zst
freebsd-ports-gnome-cc7b875d4ca0ac768375f28f2dc2a549ac846ad9.zip
- Support staging
- Strip binary
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/utcount/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/sysutils/utcount/Makefile b/sysutils/utcount/Makefile
index 37fa6cbb1250..297454a6f42b 100644
--- a/sysutils/utcount/Makefile
+++ b/sysutils/utcount/Makefile
@@ -9,5 +9,11 @@ MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Users Traffic Count
-NO_STAGE= yes
+MAKE_ARGS= PREFIX="${STAGEDIR}${PREFIX}" \
+ INSTALL_PROG="${INSTALL_SCRIPT}" \
+ INSTALL_CONF="${INSTALL_DATA}"
+
+post-build:
+ ${STRIP_CMD} ${WRKSRC}/bin/count_client
+
.include <bsd.port.mk>