aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authorjbeich <jbeich@FreeBSD.org>2015-04-28 23:42:44 +0800
committerjbeich <jbeich@FreeBSD.org>2015-04-28 23:42:44 +0800
commitcd0ffce17b9e16b09816ca8415c40a45910fe95b (patch)
tree1fb9c6c4bf2e215d57a5205f5a34cd681859d0e3 /sysutils
parentd30f10eec48c71bf92f85ae597f5b231bc7e2be6 (diff)
downloadfreebsd-ports-gnome-cd0ffce17b9e16b09816ca8415c40a45910fe95b.tar.gz
freebsd-ports-gnome-cd0ffce17b9e16b09816ca8415c40a45910fe95b.tar.zst
freebsd-ports-gnome-cd0ffce17b9e16b09816ca8415c40a45910fe95b.zip
- Update to 3.0.9
ChangeLog (trimmed): - Add check if extract command failed
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/rinse/Makefile6
-rw-r--r--sysutils/rinse/distinfo4
-rw-r--r--sysutils/rinse/files/patch-bin__rinse2
3 files changed, 5 insertions, 7 deletions
diff --git a/sysutils/rinse/Makefile b/sysutils/rinse/Makefile
index b5b8f193af53..de9d7318d359 100644
--- a/sysutils/rinse/Makefile
+++ b/sysutils/rinse/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= rinse
-PORTVERSION= 3.0.6
+PORTVERSION= 3.0.9
CATEGORIES= sysutils
MASTER_SITES= DEBIAN
DISTNAME= ${PORTNAME}_${DISTVERSION}
@@ -14,11 +14,9 @@ LICENSE= ARTPERL10
RUN_DEPENDS= p5-Term-Size>0:${PORTSDIR}/devel/p5-Term-Size \
p5-libwww>0:${PORTSDIR}/www/p5-libwww
-PORTSCOUT= skipv:3.0.7 # only debian/control changed
-
NO_ARCH= yes
NO_BUILD= yes
-USES= perl5 shebangfix
+USES= perl5 shebangfix tar:xz
USE_PERL5= run
SHEBANG_FILES= bin/* tests/*
MAKE_ARGS= PREFIX="${STAGEDIR}${PREFIX}" VERSION=${DISTVERSION}
diff --git a/sysutils/rinse/distinfo b/sysutils/rinse/distinfo
index 615858c5f7fb..2a4b15d433e4 100644
--- a/sysutils/rinse/distinfo
+++ b/sysutils/rinse/distinfo
@@ -1,2 +1,2 @@
-SHA256 (rinse_3.0.6.tar.gz) = a4821ec18720168bade8aa336bde110fd265b65dc04ad76069de8ad68bd626a1
-SIZE (rinse_3.0.6.tar.gz) = 30068
+SHA256 (rinse_3.0.9.tar.xz) = 05dd734bfe6dea321596acc9e898eeadd535a0ceb3ea7004aa70372843c326ad
+SIZE (rinse_3.0.9.tar.xz) = 25940
diff --git a/sysutils/rinse/files/patch-bin__rinse b/sysutils/rinse/files/patch-bin__rinse
index bba68c925370..c69341515cf3 100644
--- a/sysutils/rinse/files/patch-bin__rinse
+++ b/sysutils/rinse/files/patch-bin__rinse
@@ -22,7 +22,7 @@
# Run the unpacking command.
#
my $cmd =
-- "rpm2cpio $file | (cd $CONFIG{'directory'} ; cpio --extract --make-directories --no-absolute-filenames --preserve-modification-time) 2>/dev/null >/dev/null";
+- "rpm2cpio $file | (cd $CONFIG{'directory'} ; cpio --extract --extract-over-symlinks --make-directories --no-absolute-filenames --preserve-modification-time) 2>/dev/null >/dev/null";
+ "bsdtar xPf $file --chroot -C $CONFIG{'directory'}";
if ( $file =~ /(fedora|centos|redhat|mandriva)-release-/ ) {
my $rpmname = basename($file);