aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2008-06-19 07:47:29 +0800
committermiwi <miwi@FreeBSD.org>2008-06-19 07:47:29 +0800
commitd79981c8072f39d9a3ad05933b7f0586ae9317a8 (patch)
treee84648b34889de12ca0d21918e3152d6b85ba64d /sysutils
parent9bbb2d5a5e6cb0153ff7f3cbf36e27a1dcc92f8c (diff)
downloadfreebsd-ports-gnome-d79981c8072f39d9a3ad05933b7f0586ae9317a8.tar.gz
freebsd-ports-gnome-d79981c8072f39d9a3ad05933b7f0586ae9317a8.tar.zst
freebsd-ports-gnome-d79981c8072f39d9a3ad05933b7f0586ae9317a8.zip
- Update to 1.40.11
- Use assembly bitops, a new patch (provided by upstream maintainer Ted Ts'o to OpenBSD porter Frantisek Holop) fixes the related crashes. PR: 124715 Submitted by: Matthias Andree <matthias.andree@gmx.de> (maintainer)
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/e2fsprogs/Makefile9
-rw-r--r--sysutils/e2fsprogs/distinfo6
-rw-r--r--sysutils/e2fsprogs/files/patch-lib_ext2fs_bitmaps.c16
3 files changed, 22 insertions, 9 deletions
diff --git a/sysutils/e2fsprogs/Makefile b/sysutils/e2fsprogs/Makefile
index 08e1750252a8..d1010271d497 100644
--- a/sysutils/e2fsprogs/Makefile
+++ b/sysutils/e2fsprogs/Makefile
@@ -6,8 +6,8 @@
#
PORTNAME= e2fsprogs
-PORTVERSION= 1.40.10
-PORTREVISION?= 1
+PORTVERSION= 1.40.11
+PORTREVISION?= 0
CATEGORIES?= sysutils
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_EXTENDED}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -22,11 +22,8 @@ CONFIGURE_ARGS+=--disable-fsck --disable-e2initrd-helper \
--with-cc='${CC}' --with-linker='${LD}' \
--with-ccopts='${CFLAGS}' \
--with-root-prefix='${PREFIX}'
-# for unknown reasons, the assembly bitops cause SIGSEGV.
-# _EXT2_USE_C_VERSIONS_ uses C bitops, these appear to work fine.
CONFIGURE_ENV+= CPPFLAGS='${CPPFLAGS} -I${WRKSRC}/lib \
- -I${LOCALBASE}/include -D_EXT2_USE_C_VERSIONS_'
-
+ -I${LOCALBASE}/include'
MAKE_ARGS+= LDFLAGS='${LDFLAGS} -L${LOCALBASE}/lib'
OPTIONS= NLS "Enable national language support" on
diff --git a/sysutils/e2fsprogs/distinfo b/sysutils/e2fsprogs/distinfo
index d4c2dd544af2..07eeea3ce722 100644
--- a/sysutils/e2fsprogs/distinfo
+++ b/sysutils/e2fsprogs/distinfo
@@ -1,3 +1,3 @@
-MD5 (e2fsprogs-1.40.10.tar.gz) = 6174d70fb26858861f842f28486a8e83
-SHA256 (e2fsprogs-1.40.10.tar.gz) = 36071b91510d4101a35887b7c654962945c571e8285af9fa974a7a6265dfaabc
-SIZE (e2fsprogs-1.40.10.tar.gz) = 4092763
+MD5 (e2fsprogs-1.40.11.tar.gz) = 004cea70d724fdc7f1a952dffe4c9db8
+SHA256 (e2fsprogs-1.40.11.tar.gz) = 3eeb0c3513b3b251f5d51ec3413bc77e3a21cb8bc84a1979022a67fe733c897b
+SIZE (e2fsprogs-1.40.11.tar.gz) = 4116013
diff --git a/sysutils/e2fsprogs/files/patch-lib_ext2fs_bitmaps.c b/sysutils/e2fsprogs/files/patch-lib_ext2fs_bitmaps.c
new file mode 100644
index 000000000000..8dff9eda3796
--- /dev/null
+++ b/sysutils/e2fsprogs/files/patch-lib_ext2fs_bitmaps.c
@@ -0,0 +1,16 @@
+# To fix bitops related crash
+# patch provided by Ted Ts'o to Frantisek Holop (OpenBSD porter)
+
+diff --git a/lib/ext2fs/bitmaps.c b/lib/ext2fs/bitmaps.c
+index 696baad..843a75f 100644
+--- a/lib/ext2fs/bitmaps.c
++++ b/lib/ext2fs/bitmaps.c
+@@ -56,7 +56,7 @@ static errcode_t make_bitmap(__u32 start, __u32 end, __u32 real_end,
+ } else
+ bitmap->description = 0;
+
+- size = (size_t) (((bitmap->real_end - bitmap->start) / 8) + 1);
++ size = (size_t) (((bitmap->real_end - bitmap->start) / 8) + 2);
+ retval = ext2fs_get_mem(size, &bitmap->bitmap);
+ if (retval) {
+ ext2fs_free_mem(&bitmap->description);