aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2003-09-24 20:01:53 +0800
committeredwin <edwin@FreeBSD.org>2003-09-24 20:01:53 +0800
commitd8fd017848550ce97aae5820e1843dbf3dd6994b (patch)
tree811a622cf312234e77e146e52cbebc5a7efd09c4 /sysutils
parenta8fe0bbee530a192adedb72ca54b73e15c167b76 (diff)
downloadfreebsd-ports-gnome-d8fd017848550ce97aae5820e1843dbf3dd6994b.tar.gz
freebsd-ports-gnome-d8fd017848550ce97aae5820e1843dbf3dd6994b.tar.zst
freebsd-ports-gnome-d8fd017848550ce97aae5820e1843dbf3dd6994b.zip
Update port: sysutils/xfce4-battery-plugin
Update xfce4-battery-plugin to 0.2.0. PR: ports/56741 Submitted by: Thorsten Greiner <thorsten.greiner@web.de>
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/xfce4-battery-plugin/Makefile2
-rw-r--r--sysutils/xfce4-battery-plugin/distinfo2
-rw-r--r--sysutils/xfce4-battery-plugin/files/patch-configure6
-rw-r--r--sysutils/xfce4-battery-plugin/files/patch-panel-plugin::battmon.c63
4 files changed, 15 insertions, 58 deletions
diff --git a/sysutils/xfce4-battery-plugin/Makefile b/sysutils/xfce4-battery-plugin/Makefile
index 251d699c6fec..b6de1d429d45 100644
--- a/sysutils/xfce4-battery-plugin/Makefile
+++ b/sysutils/xfce4-battery-plugin/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= xfce4-battery-plugin
-PORTVERSION= 0.1.2
+PORTVERSION= 0.2.0
CATEGORIES= sysutils xfce
MASTER_SITES= http://download.berlios.de/xfce-goodies/
DIST_SUBDIR= xfce4
diff --git a/sysutils/xfce4-battery-plugin/distinfo b/sysutils/xfce4-battery-plugin/distinfo
index f920ea08f846..25cdcf25d0f4 100644
--- a/sysutils/xfce4-battery-plugin/distinfo
+++ b/sysutils/xfce4-battery-plugin/distinfo
@@ -1 +1 @@
-MD5 (xfce4/xfce4-battery-plugin-0.1.2.tar.gz) = 387ddb80deff5b9cbf5c5ac94dddbd8f
+MD5 (xfce4/xfce4-battery-plugin-0.2.0.tar.gz) = ad6cbb65b356342bf1b474b612beadf4
diff --git a/sysutils/xfce4-battery-plugin/files/patch-configure b/sysutils/xfce4-battery-plugin/files/patch-configure
index a1d6a0e2fed0..20507a42bf52 100644
--- a/sysutils/xfce4-battery-plugin/files/patch-configure
+++ b/sysutils/xfce4-battery-plugin/files/patch-configure
@@ -1,5 +1,5 @@
---- configure.orig Wed Jul 23 22:20:56 2003
-+++ configure Fri Aug 1 12:56:48 2003
+--- configure.orig Sat Aug 9 04:05:09 2003
++++ configure Fri Sep 12 23:28:29 2003
@@ -19273,7 +19273,8 @@
@@ -10,7 +10,7 @@
# Always use our own libtool.
LIBTOOL='$(SHELL) $(top_builddir)/libtool'
-@@ -19567,7 +19568,7 @@
+@@ -19651,7 +19652,7 @@
echo "$as_me:$LINENO: checking where to install panel plugins" >&5
echo $ECHO_N "checking where to install panel plugins... $ECHO_C" >&6
diff --git a/sysutils/xfce4-battery-plugin/files/patch-panel-plugin::battmon.c b/sysutils/xfce4-battery-plugin/files/patch-panel-plugin::battmon.c
index 036526de39cf..eb040a1e0f44 100644
--- a/sysutils/xfce4-battery-plugin/files/patch-panel-plugin::battmon.c
+++ b/sysutils/xfce4-battery-plugin/files/patch-panel-plugin::battmon.c
@@ -1,53 +1,10 @@
---- panel-plugin/battmon.c.orig Fri Jul 18 15:15:29 2003
-+++ panel-plugin/battmon.c Fri Aug 1 12:14:50 2003
-@@ -32,6 +32,10 @@
-
- #ifdef __FreeBSD__
- #include <machine/apm_bios.h>
-+#include <fcntl.h>
-+#ifndef APMDEVICE
-+#define APMDEVICE "/dev/apm"
-+#endif
- #elif __OpenBSD__
- #include <sys/param.h>
- #include <machine/apmvar.h>
-@@ -187,6 +191,9 @@
- #else
- struct apm_info apm;
- #endif
-+#if defined(__FreeBSD__) || defined(__OpenBSD__)
-+ int fd;
-+#endif
- int charge;
- int time_remaining;
- gboolean acline;
-@@ -217,8 +224,6 @@
- FreeBSD. Each time this functions is called (once every second)
- the APM device is opened, read from and then closed.
- */
-- int fd;
--
- battmon->method = BM_BROKEN;
- fd = open(APMDEVICE, O_RDONLY);
- if (fd == -1) return TRUE;
-@@ -232,12 +237,18 @@
- time_remaining = apm.ai_batt_time;
- time_remaining = time_remaining / 60; /* convert from seconds to minutes */
- charge = apm.ai_batt_life;
-+
-+ /*
-+ * Work around a bug in the FreeBSD ACPI APM emulation layer which will
-+ * sometimes return funny values for the battery life.
-+ */
-+ if(charge > 100) {
-+ charge = 100;
-+ }
- #elif __OpenBSD__
- /* Code for OpenBSD by Joe Ammond <jra@twinight.org>. Using the same
- procedure as for FreeBSD.
- */
-- int fd;
--
- battmon->method = BM_BROKEN;
- fd = open(APMDEVICE, O_RDONLY);
- if (fd == -1) return TRUE;
+--- panel-plugin/battmon.c.orig Fri Sep 12 23:38:01 2003
++++ panel-plugin/battmon.c Fri Sep 12 23:38:24 2003
+@@ -362,6 +362,7 @@
+
+
+ if(charge < 0) charge = 0;
++ if(charge > 100) charge = 100;
+ gtk_progress_bar_set_fraction(GTK_PROGRESS_BAR(battmon->battstatus), charge / 100.0);
+
+ if(battmon->options.display_label){