aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authormandree <mandree@FreeBSD.org>2013-05-23 05:33:24 +0800
committermandree <mandree@FreeBSD.org>2013-05-23 05:33:24 +0800
commite020999a691af24f2fcf4c3ba47c34080dcf439d (patch)
tree7cea0b3f1c63b4679974cef888d9ab5c085c404f /sysutils
parent8e5c9cdbcca9c3787f9a12366c85d3b90746bc96 (diff)
downloadfreebsd-ports-gnome-e020999a691af24f2fcf4c3ba47c34080dcf439d.tar.gz
freebsd-ports-gnome-e020999a691af24f2fcf4c3ba47c34080dcf439d.tar.zst
freebsd-ports-gnome-e020999a691af24f2fcf4c3ba47c34080dcf439d.zip
- Change USE_GCC=4.6 (explicit version) to USE_GCC=yes, [1].
- In order to get that working, beat compilation environment into shape for GCC 4.7/4.8 with two defines and one -include on CPPFLAGS. - Clean up CPPFLAGS/LDFLAGS handling, getting rid of CONFIGURE_ARGS hacks. - Correct two bugs in .if ${OSVERSION} < 90014 || !exists(clang++) to .if ${OSVERSION} < 900014 || !exists(/usr/bin/clang++) (where the OSVERSION lacked a 0 digit, and exists lacked the path, resulting in GCC being used even where clang++ was in base) Requested by: gerald [1]
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/replicant/Makefile16
1 files changed, 10 insertions, 6 deletions
diff --git a/sysutils/replicant/Makefile b/sysutils/replicant/Makefile
index b780ef10eab5..aa3498c63479 100644
--- a/sysutils/replicant/Makefile
+++ b/sysutils/replicant/Makefile
@@ -19,16 +19,20 @@ LIB_DEPENDS= busybee:${PORTSDIR}/devel/busybee \
ONLY_FOR_ARCHS= amd64
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
-CONFIGURE_ARGS= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib"
+# The -D-efines and -include beat the code into shape on GCC 4.7/4.8
+# GCC 4.6 from ports and 9.1's base clang are fine,
+# upstream bug report at <https://github.com/rescrv/po6/issues/5>
+# This hack causes harmless "warning: '__STDC_LIMIT_MACROS' macro redefined"
+CPPFLAGS+= -D__STDC_LIMIT_MACROS -Du_int32_t=uint32_t \
+ -include stdint.h -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
USES= pathfix pkgconfig
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 90014 || !exists(clang++)
-# newer GCC versions than 4.6 do not work; clang 3.1 seems fine;
-# bug report to upstream at: <https://github.com/rescrv/po6/issues/5>
-USE_GCC= 4.6
+.if ${OSVERSION} < 900014 || !exists(/usr/bin/clang++)
+# No clang++ installed, use GCC from ports:
+USE_GCC= yes
.else
CC= clang
CXX= clang++