aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2014-05-25 04:53:27 +0800
committersunpoet <sunpoet@FreeBSD.org>2014-05-25 04:53:27 +0800
commite144482f9c59a994cb01a79f770b067993a3e7b3 (patch)
treeba6fbe8f24e8237af376ca440a0fc5f87ded6ead /sysutils
parent5ec340154d14be292041ecc85ba8511ae5144537 (diff)
downloadfreebsd-ports-gnome-e144482f9c59a994cb01a79f770b067993a3e7b3.tar.gz
freebsd-ports-gnome-e144482f9c59a994cb01a79f770b067993a3e7b3.tar.zst
freebsd-ports-gnome-e144482f9c59a994cb01a79f770b067993a3e7b3.zip
- Convert to new options framework
- Use USES=gmake and USES=tar:bzip2 - Support STAGEDIR - While I'm here, simplify Makefile PR: ports/190165 Submitted by: Muhammad Moinur Rahman <5u623l20@gmail.com> (maintainer)
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/stow/Makefile24
-rw-r--r--sysutils/stow/pkg-plist6
2 files changed, 14 insertions, 16 deletions
diff --git a/sysutils/stow/Makefile b/sysutils/stow/Makefile
index 9408cdb87576..770e16c38850 100644
--- a/sysutils/stow/Makefile
+++ b/sysutils/stow/Makefile
@@ -3,6 +3,7 @@
PORTNAME= stow
PORTVERSION= 2.2.0
+PORTREVISION= 1
CATEGORIES= sysutils
MASTER_SITES= GNU
@@ -14,34 +15,25 @@ LICENSE_FILE= ${WRKSRC}/COPYING
TEST_DEPENDS= p5-Test-Output>0:${PORTSDIR}/devel/p5-Test-Output
-USE_BZIP2= yes
-USES= perl5
-USE_GMAKE= yes
+USES= gmake perl5 tar:bzip2
GNU_CONFIGURE= yes
CONFIGURE_ENV= ac_cv_path_PERL=${PERL}
INSTALL_TARGET= install-exec-am install-dist_pmstowDATA install-info-am \
install-man install-pmDATA
-MAN8= stow.8
+OPTIONS= DOCS
+
INFO= stow
PORTDOCS= *
-PLIST_FILES= bin/chkstow \
- bin/stow \
- %%SITE_PERL%%/Stow.pm \
- %%SITE_PERL%%/Stow/Util.pm
-PLIST_DIRS= %%SITE_PERL%%/Stow
-NO_STAGE= yes
post-install:
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
.for FILE in ChangeLog README
- ${INSTALL_DATA} ${WRKSRC}/${FILE} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${FILE} ${STAGEDIR}${DOCSDIR}
.endfor
.for FILE in ChangeLog.OLD manual-single.html manual.pdf version.texi
- ${INSTALL_DATA} ${WRKSRC}/doc/${FILE} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/doc/${FILE} ${STAGEDIR}${DOCSDIR}
.endfor
- @(cd ${WRKSRC}/doc && ${COPYTREE_SHARE} manual-split ${DOCSDIR})
-.endif
+ @(cd ${WRKSRC}/doc && ${COPYTREE_SHARE} manual-split ${STAGEDIR}${DOCSDIR})
.include <bsd.port.mk>
diff --git a/sysutils/stow/pkg-plist b/sysutils/stow/pkg-plist
new file mode 100644
index 000000000000..9f4f9f7f9028
--- /dev/null
+++ b/sysutils/stow/pkg-plist
@@ -0,0 +1,6 @@
+bin/chkstow
+bin/stow
+%%SITE_PERL%%/Stow.pm
+%%SITE_PERL%%/Stow/Util.pm
+man/man8/stow.8.gz
+@dirrm %%SITE_PERL%%/Stow