aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authorjkim <jkim@FreeBSD.org>2013-06-27 08:38:39 +0800
committerjkim <jkim@FreeBSD.org>2013-06-27 08:38:39 +0800
commite46936882c4f10a4156a7e96fd5a07eae335cb66 (patch)
tree35a098bcf956cb38449a165fca10035796a5a76f /sysutils
parent7ed2964b85779032ffab3c885c066fcec5c2cd25 (diff)
downloadfreebsd-ports-gnome-e46936882c4f10a4156a7e96fd5a07eae335cb66.tar.gz
freebsd-ports-gnome-e46936882c4f10a4156a7e96fd5a07eae335cb66.tar.zst
freebsd-ports-gnome-e46936882c4f10a4156a7e96fd5a07eae335cb66.zip
Attempt to it buildable on non-Intel platforms and fix build on current.
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/acpica-tools/Makefile2
-rw-r--r--sysutils/acpica-tools/files/patch-source__include__platform__acfreebsd.h33
2 files changed, 33 insertions, 2 deletions
diff --git a/sysutils/acpica-tools/Makefile b/sysutils/acpica-tools/Makefile
index a4ca60fdcdb4..e3957478b9cb 100644
--- a/sysutils/acpica-tools/Makefile
+++ b/sysutils/acpica-tools/Makefile
@@ -14,8 +14,6 @@ COMMENT= Tools from the ACPI Component Architecture (ACPICA) project
LICENSE= BSD
-ONLY_FOR_ARCHS= amd64 i386 ia64
-
USE_GMAKE= yes
MAKE_ARGS= HOST=_FreeBSD
WRKSRC_SUBDIR= generate/unix
diff --git a/sysutils/acpica-tools/files/patch-source__include__platform__acfreebsd.h b/sysutils/acpica-tools/files/patch-source__include__platform__acfreebsd.h
new file mode 100644
index 000000000000..97bbe8938e14
--- /dev/null
+++ b/sysutils/acpica-tools/files/patch-source__include__platform__acfreebsd.h
@@ -0,0 +1,33 @@
+--- ../../source/include/platform/acfreebsd.h.orig 2013-06-26 14:00:12.000000000 -0400
++++ ../../source/include/platform/acfreebsd.h 2013-06-26 20:30:30.000000000 -0400
+@@ -49,12 +49,21 @@
+
+ #include "acgcc.h"
+ #include <sys/types.h>
+-#include <machine/acpica_machdep.h>
++
++#ifdef __LP64__
++#define ACPI_MACHINE_WIDTH 64
++#else
++#define ACPI_MACHINE_WIDTH 32
++#endif
++
++#define COMPILER_DEPENDENT_INT64 int64_t
++#define COMPILER_DEPENDENT_UINT64 uint64_t
+
+ #define ACPI_UINTPTR_T uintptr_t
+
+ #define ACPI_USE_DO_WHILE_0
+ #define ACPI_USE_LOCAL_CACHE
++#define ACPI_USE_NATIVE_DIVIDE
+ #define ACPI_USE_SYSTEM_CLIBRARY
+
+ #ifdef _KERNEL
+@@ -63,6 +72,7 @@
+ #include <sys/param.h>
+ #include <sys/systm.h>
+ #include <sys/libkern.h>
++#include <machine/acpica_machdep.h>
+ #include <machine/stdarg.h>
+
+ #include "opt_acpi.h"