aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authormandree <mandree@FreeBSD.org>2014-05-23 05:56:52 +0800
committermandree <mandree@FreeBSD.org>2014-05-23 05:56:52 +0800
commite9c22496dd3f09ab8f3657fb2950f9e4b02dd251 (patch)
tree59fa963702c28f1e895dc1e1d530a7dd1515180c /sysutils
parentf7043d9ea8e224c8ff0399a34510efdea180aaf0 (diff)
downloadfreebsd-ports-gnome-e9c22496dd3f09ab8f3657fb2950f9e4b02dd251.tar.gz
freebsd-ports-gnome-e9c22496dd3f09ab8f3657fb2950f9e4b02dd251.tar.zst
freebsd-ports-gnome-e9c22496dd3f09ab8f3657fb2950f9e4b02dd251.zip
Fix location of .pc files for pkg-config [1].
Fix issue with parallel build, pre-build prof_err.h. Reported by: ak@, mat@ [1]
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/e2fsprogs/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/sysutils/e2fsprogs/Makefile b/sysutils/e2fsprogs/Makefile
index 54efbdf84daf..909490c3768c 100644
--- a/sysutils/e2fsprogs/Makefile
+++ b/sysutils/e2fsprogs/Makefile
@@ -21,7 +21,7 @@ CONFIGURE_ARGS+=--disable-fsck --disable-e2initrd-helper \
--enable-quota \
--with-root-prefix='${PREFIX}'
CPPFLAGS+= -I${WRKSRC}/lib -I${LOCALBASE}/include # -D_EXT2_USE_C_VERSIONS
-MAKE_ARGS+= LDFLAGS='${LDFLAGS} -L${LOCALBASE}/lib'
+MAKE_ARGS+= LDFLAGS='${LDFLAGS} -L${LOCALBASE}/lib' pkgconfigdir='${PREFIX}/libdata/pkgconfig'
MAKE_ENV+= CHECK_CMD=@true
.if !defined(MASTERDIR)
@@ -81,6 +81,11 @@ post-patch::
.endfor
.if ${MASTERDIR} == ${.CURDIR}
+pre-build:
+# fix up Makefile ordering for parallel builds
+ cd ${WRKSRC}/lib/et && ${DO_MAKE_BUILD} compile_et
+ cd ${WRKSRC}/e2fsck && ${DO_MAKE_BUILD} prof_err.h
+
post-build:
# Relink e2fsck statically - We need to make sure that tools for the root file
# system are statically linked against anything that is outside the root fs,