aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authortdb <tdb@FreeBSD.org>2014-05-13 04:14:01 +0800
committertdb <tdb@FreeBSD.org>2014-05-13 04:14:01 +0800
commiteb9286b66dbff580cb7c5e1e1239dc727551c5be (patch)
tree0e0fc0f7b94a07e612fc2f421f8d925e8906ca24 /sysutils
parent8579a81f77d2fbfa925c2c90e7f1d9c62f3d8a00 (diff)
downloadfreebsd-ports-gnome-eb9286b66dbff580cb7c5e1e1239dc727551c5be.tar.gz
freebsd-ports-gnome-eb9286b66dbff580cb7c5e1e1239dc727551c5be.tar.zst
freebsd-ports-gnome-eb9286b66dbff580cb7c5e1e1239dc727551c5be.zip
- Update to 0.9.2
- Stage support - Use new LIB_DEPENDS format - No longer needs to be setgid (libstatgrab on older FreeBSD needed it) - Fixes for libstatgrab 0.90
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/freecolor/Makefile20
-rw-r--r--sysutils/freecolor/distinfo4
-rw-r--r--sysutils/freecolor/files/patch-Makefile.in26
-rw-r--r--sysutils/freecolor/files/patch-configure27
-rw-r--r--sysutils/freecolor/files/patch-freecolor.c34
5 files changed, 67 insertions, 44 deletions
diff --git a/sysutils/freecolor/Makefile b/sysutils/freecolor/Makefile
index 1b8d66e112f6..b5357540b0fe 100644
--- a/sysutils/freecolor/Makefile
+++ b/sysutils/freecolor/Makefile
@@ -2,30 +2,20 @@
# $FreeBSD$
PORTNAME= freecolor
-PORTVERSION= 0.8.8
+PORTVERSION= 0.9.2
CATEGORIES= sysutils
MASTER_SITES= http://www.rkeene.org/files/oss/freecolor/
MAINTAINER= tdb@FreeBSD.org
COMMENT= Displays free memory as a bargraph
-LIB_DEPENDS= statgrab.8:${PORTSDIR}/devel/libstatgrab
+LIB_DEPENDS= libstatgrab.so:${PORTSDIR}/devel/libstatgrab
GNU_CONFIGURE= yes
MAKE_ENV+= INSTALL="${INSTALL}" INSTALL_PROGRAM="${INSTALL_PROGRAM}"
-PLIST_FILES= bin/freecolor
USES= pkgconfig
-.if !defined(WITHOUT_SETGID)
-BINGRP?= kmem
-BINMODE?= 2555
-.endif
-
-NO_STAGE= yes
-.include <bsd.port.pre.mk>
-
-.if ${ARCH} != "i386"
-BROKEN= Does not function correctly on !i386
-.endif
+PLIST_FILES= bin/freecolor man/man1/freecolor.1.gz
+USES= pkgconfig
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/sysutils/freecolor/distinfo b/sysutils/freecolor/distinfo
index 8f6f73391611..c98d9e5a6c14 100644
--- a/sysutils/freecolor/distinfo
+++ b/sysutils/freecolor/distinfo
@@ -1,2 +1,2 @@
-SHA256 (freecolor-0.8.8.tar.gz) = 7ad04c8bc5ebf590f7f5403bfdfc64ef8d7a15bdd24f8d80d81cee93cee18179
-SIZE (freecolor-0.8.8.tar.gz) = 38074
+SHA256 (freecolor-0.9.2.tar.gz) = 944936566395cd2e456bce59c6b5bdcb4c31601e9bc869daf507fd3114f5f0bf
+SIZE (freecolor-0.9.2.tar.gz) = 46684
diff --git a/sysutils/freecolor/files/patch-Makefile.in b/sysutils/freecolor/files/patch-Makefile.in
index 572e0ce8c697..6346e19d6e4f 100644
--- a/sysutils/freecolor/files/patch-Makefile.in
+++ b/sysutils/freecolor/files/patch-Makefile.in
@@ -1,21 +1,17 @@
---- ./Makefile.in.orig 2005-06-04 15:52:52.000000000 +0100
-+++ ./Makefile.in 2010-07-26 12:40:15.000000000 +0100
-@@ -2,7 +2,6 @@
- CFLAGS = -Wall @CFLAGS@ @DEFS@
- CPPFLAGS = @CPPFLAGS@ @DEFS@
- LDFLAGS = @LDFLAGS@ @LIBS@
--INSTALL = @INSTALL@
-
- prefix = @prefix@
- mandir = @mandir@
-@@ -19,9 +18,8 @@
- cp -i free `which free`
+--- ./Makefile.in.orig 2014-01-21 10:11:40.000000000 +0000
++++ ./Makefile.in 2014-05-10 02:49:19.171834039 +0100
+@@ -21,10 +21,10 @@
install:
-- strip free
- -$(INSTALL) -d $(bindir)
+ strip free
+- -$(INSTALL) -d $(bindir)
+- -$(INSTALL) -d $(mandir)/man1
- $(INSTALL) -m 755 free $(bindir)/freecolor
-+ $(INSTALL_PROGRAM) free $(bindir)/freecolor
+- $(INSTALL) -m 644 freecolor.1 $(mandir)/man1/freecolor.1
++ -$(INSTALL) -d $(DESTDIR)$(bindir)
++ -$(INSTALL) -d $(DESTDIR)$(mandir)/man1
++ $(INSTALL) -m 755 free $(DESTDIR)$(bindir)/freecolor
++ $(INSTALL) -m 644 freecolor.1 $(DESTDIR)$(mandir)/man1/freecolor.1
clean:
rm -f core free *~
diff --git a/sysutils/freecolor/files/patch-configure b/sysutils/freecolor/files/patch-configure
new file mode 100644
index 000000000000..e8c3ef45e981
--- /dev/null
+++ b/sysutils/freecolor/files/patch-configure
@@ -0,0 +1,27 @@
+--- ./configure.orig 2014-05-10 02:38:56.233878961 +0100
++++ ./configure 2014-05-10 02:40:14.188873049 +0100
+@@ -3504,8 +3504,8 @@
+ $as_echo "#define HAVE_LIBSTATGRAB 1" >>confdefs.h
+
+ LIBS="$LIBS $LIBSTATGRABFLAGS -lstatgrab"
+- { $as_echo "$as_me:${as_lineno-$LINENO}: checking for statgrab_drop_privileges in -lstatgrab" >&5
+-$as_echo_n "checking for statgrab_drop_privileges in -lstatgrab... " >&6; }
++ { $as_echo "$as_me:${as_lineno-$LINENO}: checking for sg_drop_privileges in -lstatgrab" >&5
++$as_echo_n "checking for sg_drop_privileges in -lstatgrab... " >&6; }
+ if ${ac_cv_lib_statgrab_statgrab_drop_privileges+:} false; then :
+ $as_echo_n "(cached) " >&6
+ else
+@@ -3520,11 +3520,11 @@
+ #ifdef __cplusplus
+ extern "C"
+ #endif
+-char statgrab_drop_privileges ();
++char sg_drop_privileges ();
+ int
+ main ()
+ {
+-return statgrab_drop_privileges ();
++return sg_drop_privileges ();
+ ;
+ return 0;
+ }
diff --git a/sysutils/freecolor/files/patch-freecolor.c b/sysutils/freecolor/files/patch-freecolor.c
index 39e0b209bd4b..f6c25defe624 100644
--- a/sysutils/freecolor/files/patch-freecolor.c
+++ b/sysutils/freecolor/files/patch-freecolor.c
@@ -1,12 +1,22 @@
---- ./freecolor.c.orig 2009-05-31 08:48:43.000000000 +0100
-+++ ./freecolor.c 2009-06-02 11:33:43.000000000 +0100
-@@ -62,9 +62,6 @@
- #include <unistd.h>
- #include <stdlib.h>
- #include <stdio.h>
--#ifndef NO_GETOPT
--#include <getopt.h>
--#endif
- #define BARLEN 35
- #define HEADERLEN 14
- #define VERSION "0.8.8"
+--- ./freecolor.c.orig 2014-05-10 02:40:47.870871838 +0100
++++ ./freecolor.c 2014-05-10 02:41:48.220865521 +0100
+@@ -148,7 +148,7 @@
+ if (init_called == 0) {
+ init_called = 1;
+
+- sg_init();
++ sg_init(0);
+
+ #ifdef HAVE_STATGRAB_DROP_PRIVILEGES
+ /* Drop setuid/setgid privileges. */
+@@ -159,8 +159,8 @@
+ #endif
+ }
+
+- mem_stats = sg_get_mem_stats();
+- swap_stats = sg_get_swap_stats();
++ mem_stats = sg_get_mem_stats(NULL);
++ swap_stats = sg_get_swap_stats(NULL);
+
+ if (mem_stats == NULL || swap_stats == NULL) {
+ return(-1);