aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authorolivierd <olivierd@FreeBSD.org>2013-10-16 02:36:02 +0800
committerolivierd <olivierd@FreeBSD.org>2013-10-16 02:36:02 +0800
commitf19c5c760df49abb4957926e7ef1fcbfe2cd7a6d (patch)
tree86377d0e922207e753983679587f0d16a831ac7d /sysutils
parentf39e3ee356569bf4f0787f907b75b1bef051e5aa (diff)
downloadfreebsd-ports-gnome-f19c5c760df49abb4957926e7ef1fcbfe2cd7a6d.tar.gz
freebsd-ports-gnome-f19c5c760df49abb4957926e7ef1fcbfe2cd7a6d.tar.zst
freebsd-ports-gnome-f19c5c760df49abb4957926e7ef1fcbfe2cd7a6d.zip
- Support STAGEDIR
While I'm here - Switch to USES= gmake - Convert to new LIB_DEPENDS format - Enhance COMMENT entry (misc/xfce4-wm-themes) - Adjust Xfce dependencies, and bump PORTREVISION (sysutils/xfce4-power-manager)
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/xfce4-power-manager/Makefile24
-rw-r--r--sysutils/xfce4-power-manager/pkg-descr3
-rw-r--r--sysutils/xfce4-power-manager/pkg-plist41
3 files changed, 14 insertions, 54 deletions
diff --git a/sysutils/xfce4-power-manager/Makefile b/sysutils/xfce4-power-manager/Makefile
index d531b4cf3d06..a69790ea70cc 100644
--- a/sysutils/xfce4-power-manager/Makefile
+++ b/sysutils/xfce4-power-manager/Makefile
@@ -3,33 +3,29 @@
PORTNAME= xfce4-power-manager
PORTVERSION= 1.2.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= sysutils xfce
MASTER_SITES= ${MASTER_SITE_XFCE}
MASTER_SITE_SUBDIR= src/xfce/${PORTNAME}/${PORTVERSION:R}
DIST_SUBDIR= xfce4
MAINTAINER= xfce@FreeBSD.org
-COMMENT= Xfce4 power manager
+COMMENT= Power manager for the Xfce Desktop
-LIB_DEPENDS= notify:${PORTSDIR}/devel/libnotify
+LIB_DEPENDS= libnotify.so:${PORTSDIR}/devel/libnotify \
+ libdbus-glib-1.so:${PORTSDIR}/devel/dbus-glib \
+ libpolkit-gobject-1.so:${PORTSDIR}/sysutils/polkit
GNU_CONFIGURE= yes
USE_BZIP2= yes
-USES= gettext pkgconfig
-USE_GMAKE= yes
-USE_GNOME= gtk20 intltool intlhack
-USE_XFCE= configenv libutil libgui panel
+USES= gettext pkgconfig gmake
+USE_GNOME= glib20 gtk20 intltool intlhack
+USE_XFCE= configenv libutil libmenu panel xfconf
INSTALLS_ICONS= yes
+USE_XORG= xrandr x11 xext
CONFIGURE_ARGS= --disable-network-manager \
--enable-polkit
-MAN1= xfce4-power-manager.1 xfce4-power-manager-settings.1
-
-NO_STAGE= yes
-post-patch:
- @${REINPLACE_CMD} -e 's|--libs "libxfce4panel-1.0"|& "libxfcegui4-1.0"|g; \
- s|--cflags "libxfce4panel-1.0"|& "libxfcegui4-1.0"|g' \
- ${WRKSRC}/configure
+NO_MTREE= yes
.include <bsd.port.mk>
diff --git a/sysutils/xfce4-power-manager/pkg-descr b/sysutils/xfce4-power-manager/pkg-descr
index 5a2152d9eb29..3509e9511222 100644
--- a/sysutils/xfce4-power-manager/pkg-descr
+++ b/sysutils/xfce4-power-manager/pkg-descr
@@ -1,3 +1,4 @@
-Written by Ali Abdallah, this is a power manager for the Xfce desktop.
+Xfce power manager manages the power sources on the computer and the
+devices that can be controlled to reduce their power consumption.
WWW: http://goodies.xfce.org/projects/applications/xfce4-power-manager
diff --git a/sysutils/xfce4-power-manager/pkg-plist b/sysutils/xfce4-power-manager/pkg-plist
index 561f7953eb72..d966c1c2da80 100644
--- a/sysutils/xfce4-power-manager/pkg-plist
+++ b/sysutils/xfce4-power-manager/pkg-plist
@@ -3,6 +3,8 @@ bin/xfce4-power-manager
bin/xfce4-power-manager-settings
etc/xdg/autostart/xfce4-power-manager.desktop
lib/xfce4/panel-plugins/xfce4-brightness-plugin
+man/man1/xfce4-power-manager.1.gz
+man/man1/xfce4-power-manager-settings.1.gz
sbin/xfpm-power-backlight-helper
share/applications/xfce4-power-manager-settings.desktop
share/icons/hicolor/128x128/devices/processor.png
@@ -289,8 +291,6 @@ share/xfce4/panel-plugins/xfce4-brightness-plugin.desktop
@dirrmtry share/xfce4
@dirrmtry share/polkit-1/actions
@dirrmtry share/polkit-1
-@dirrmtry share/locale/zh_TW/LC_MESSAGES
-@dirrmtry share/locale/zh_TW
@dirrmtry share/locale/ur_PK/LC_MESSAGES
@dirrmtry share/locale/ur_PK
@dirrmtry share/locale/ur/LC_MESSAGES
@@ -301,47 +301,10 @@ share/xfce4/panel-plugins/xfce4-brightness-plugin.desktop
@dirrmtry share/locale/te
@dirrmtry share/locale/si/LC_MESSAGES
@dirrmtry share/locale/si
-@dirrmtry share/locale/ro/LC_MESSAGES
-@dirrmtry share/locale/ro
-@dirrmtry share/locale/pl/LC_MESSAGES
-@dirrmtry share/locale/pl
-@dirrmtry share/locale/nn/LC_MESSAGES
-@dirrmtry share/locale/nn
-@dirrmtry share/locale/lt/LC_MESSAGES
-@dirrmtry share/locale/lt
-@dirrmtry share/locale/ko/LC_MESSAGES
-@dirrmtry share/locale/ko
@dirrmtry share/locale/kk/LC_MESSAGES
@dirrmtry share/locale/kk
-@dirrmtry share/locale/is/LC_MESSAGES
-@dirrmtry share/locale/is
-@dirrmtry share/locale/hr/LC_MESSAGES
-@dirrmtry share/locale/hr
-@dirrmtry share/locale/bg/LC_MESSAGES
-@dirrmtry share/locale/bg
@dirrmtry share/locale/ast/LC_MESSAGES
@dirrmtry share/locale/ast
-@dirrmtry share/locale/ar/LC_MESSAGES
-@dirrmtry share/locale/ar
-@dirrmtry share/icons/hicolor/scalable/status
-@dirrmtry share/icons/hicolor/scalable/actions
-@dirrmtry share/icons/hicolor/scalable
-@dirrmtry share/icons/hicolor/48x48/status
-@dirrmtry share/icons/hicolor/48x48/actions
-@dirrmtry share/icons/hicolor/48x48
-@dirrmtry share/icons/hicolor/24x24/status
-@dirrmtry share/icons/hicolor/24x24/actions
-@dirrmtry share/icons/hicolor/24x24
-@dirrmtry share/icons/hicolor/22x22/status
-@dirrmtry share/icons/hicolor/22x22/actions
-@dirrmtry share/icons/hicolor/22x22
-@dirrmtry share/icons/hicolor/16x16/status
-@dirrmtry share/icons/hicolor/16x16/actions
-@dirrmtry share/icons/hicolor/16x16
-@dirrmtry share/icons/hicolor/128x128/devices
-@dirrmtry share/icons/hicolor/128x128
-@dirrmtry share/icons/hicolor
-@dirrmtry share/icons
@dirrmtry share/applications
@dirrmtry lib/xfce4/panel-plugins
@dirrmtry lib/xfce4
9fc86acac6971505'>Bump PORTREVISION after open-mofit updatemakc2011-05-021-1/+1 * The FreeBSD KDE Team is pleased to announce April updates for KDEavilla2011-04-072-2/+19 * The FreeBSD KDE Team is pleased to announce KDE SC 4.6.1 and KDE PIMavilla2011-03-252-16/+9 * - Get Rid MD5 supportmiwi2011-03-195-5/+0 * - Remove unnecessary PKGNAMEPREFIX declarationsunpoet2011-01-094-4/+0 * - The KDE FreeBSD team is proud to announce the release of KDE 4.5.5fluffy2011-01-081-2/+2 * KDE FreeBSD team presents KDE SC 4.5.4.makc2010-12-031-2/+2 * KDE FreeBSD team presents KDE SC 4.5.3.makc2010-11-041-3/+2 * KDE FreeBSD team presents KDE SC 4.5.2.makc2010-10-061-3/+3 * Autotools update. Read ports/UPDATING 20100915 for details.ade2010-09-162-4/+2 * KDE FreeBSD team presents KDE SC 4.5.1.makc2010-09-032-74/+34 * Present KDE SC 4.4.5 for FreeBSD.makc2010-06-301-3/+3 * - Update to 2.01.stefan2010-06-284-16/+21 * Present KDE SC 4.4.4 for FreeBSD.makc2010-06-021-3/+3 * Bounce PORTREVISION for gettext-related ports. Have fun, ya'll.ade2010-05-312-2/+2 * Convert LDCONFIG_DIRS to USE_LDCONFIG for unmaintained ports.makc2010-05-241-2/+1 * - The FreeBSD KDE team is pleased to announce KDE SC 4.4.3 for FreeBSDfluffy2010-05-113-28/+11 * - update to 1.4.1dinoex2010-03-284-3/+4 * Presenting KDE 4.3.5 for FreeBSD. The official release notes for thismiwi2010-02-072-4/+3 * - update to jpeg-8dinoex2010-02-054-3/+4 * - Update to 0.7.0wen2010-01-104-50/+6 * - Update to 1.6.2wen2010-01-103-8/+6 * - SUB_FILES += pkg-messagepgollucci2010-01-082-9/+9 * - SUB_FILES += pkg-messagepgollucci2010-01-083-18/+18 * - Use SUB_FILES for pkg-messagepgollucci2010-01-072-3/+3 * The FreeBSD KDE is please to announce the release of KDE 4.3.4,miwi2009-12-021-3/+3 * The KDE FreeBSD team is proud to announce the release of KDE 4.3.3miwi2009-11-272-5/+5 * - Mark MAKE_JOBS_UNSAFEpav2009-11-201-0/+1 * The FreeBSD KDE is please to announce the release of KDE 4.3.1,tabthorpe2009-09-022-6/+6 * - Switch SourceForge ports to the new File Release System: categories startin...amdmi32009-08-224-7/+4 * Reset sbahra at his request due to lack of time to work on these ports.linimon2009-08-209-18/+6 * clean upmakc2009-08-081-4/+1 * The KDE FreeBSD team is proud to announce the release of KDE 4.3.0miwi2009-08-053-17/+93