aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authorjhale <jhale@FreeBSD.org>2014-03-29 06:24:15 +0800
committerjhale <jhale@FreeBSD.org>2014-03-29 06:24:15 +0800
commit00e03887df67e5792c9e1323ea19b56c5d0d8b2f (patch)
tree863f590c8a9912588433bb6e228076d128944f21 /sysutils
parente308b56a1e73b788c6ba5968f98dbf930c4f7769 (diff)
downloadfreebsd-ports-gnome-00e03887df67e5792c9e1323ea19b56c5d0d8b2f.tar.gz
freebsd-ports-gnome-00e03887df67e5792c9e1323ea19b56c5d0d8b2f.tar.zst
freebsd-ports-gnome-00e03887df67e5792c9e1323ea19b56c5d0d8b2f.zip
- New port: sysutils/dateutils
Dateutils are a collection of tools that revolve around manipulating dates and times on the command line. Commands included in the suite offer ways of converting dates between calendars, computing durations between dates, and finding dates in input streams. WWW: http://www.fresse.org/dateutils/ PR: ports/187663 (based on) Submitted by: Jesse <jessefrgsmith@yahoo.ca>
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/dateutils/Makefile26
-rw-r--r--sysutils/dateutils/distinfo2
-rw-r--r--sysutils/dateutils/files/patch-lib__Makefile.in16
-rw-r--r--sysutils/dateutils/files/patch-lib__tzraw.c20
-rw-r--r--sysutils/dateutils/files/patch-src__prchunk.c19
-rw-r--r--sysutils/dateutils/pkg-descr6
-rw-r--r--sysutils/dateutils/pkg-plist37
8 files changed, 127 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index 3b2ab732dc26..af810514e651 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -156,6 +156,7 @@
SUBDIR += daedalus
SUBDIR += daemontools
SUBDIR += dar
+ SUBDIR += dateutils
SUBDIR += dc3dd
SUBDIR += dcfldd
SUBDIR += dd_rescue
diff --git a/sysutils/dateutils/Makefile b/sysutils/dateutils/Makefile
new file mode 100644
index 000000000000..861006816758
--- /dev/null
+++ b/sysutils/dateutils/Makefile
@@ -0,0 +1,26 @@
+# $FreeBSD$
+
+PORTNAME= dateutils
+PORTVERSION= 0.2.7
+CATEGORIES= sysutils
+MASTER_SITES= https://bitbucket.org/hroptatyr/dateutils/downloads/
+
+MAINTAINER= jessefrgsmith@yahoo.ca
+COMMENT= Command line utilities for working with dates
+
+LICENSE= BSD3CLAUSE
+
+BUILD_DEPENDS= help2man:${PORTSDIR}/misc/help2man
+
+USES= tar:xz
+GNU_CONFIGURE= yes
+
+INFO= dateutils
+
+OPTIONS_DEFINE= DOCS
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|@libdir@/pkgconfig|$${prefix}/libdata/pkgconfig|g' \
+ ${WRKSRC}/Makefile.in
+
+.include <bsd.port.mk>
diff --git a/sysutils/dateutils/distinfo b/sysutils/dateutils/distinfo
new file mode 100644
index 000000000000..d0c3583d10ad
--- /dev/null
+++ b/sysutils/dateutils/distinfo
@@ -0,0 +1,2 @@
+SHA256 (dateutils-0.2.7.tar.xz) = f7d0c502d79dec4a604ebc30e7c44988d7095bd303137d1fa652720350337042
+SIZE (dateutils-0.2.7.tar.xz) = 490456
diff --git a/sysutils/dateutils/files/patch-lib__Makefile.in b/sysutils/dateutils/files/patch-lib__Makefile.in
new file mode 100644
index 000000000000..e64192b709a1
--- /dev/null
+++ b/sysutils/dateutils/files/patch-lib__Makefile.in
@@ -0,0 +1,16 @@
+--- ./lib/Makefile.in.orig 2014-03-27 23:56:38.000000000 -0400
++++ ./lib/Makefile.in 2014-03-27 23:57:13.000000000 -0400
+@@ -363,13 +363,6 @@
+ $(INSTALL_DATA) $$list2 "$(DESTDIR)$(libdir)" || exit $$?; }
+ @$(POST_INSTALL)
+ @list='$(lib_LIBRARIES)'; test -n "$(libdir)" || list=; \
+- for p in $$list; do \
+- if test -f $$p; then \
+- $(am__strip_dir) \
+- echo " ( cd '$(DESTDIR)$(libdir)' && $(RANLIB) $$f )"; \
+- ( cd "$(DESTDIR)$(libdir)" && $(RANLIB) $$f ) || exit $$?; \
+- else :; fi; \
+- done
+
+ uninstall-libLIBRARIES:
+ @$(NORMAL_UNINSTALL)
diff --git a/sysutils/dateutils/files/patch-lib__tzraw.c b/sysutils/dateutils/files/patch-lib__tzraw.c
new file mode 100644
index 000000000000..27d531de8f33
--- /dev/null
+++ b/sysutils/dateutils/files/patch-lib__tzraw.c
@@ -0,0 +1,20 @@
+--- ./lib/tzraw.c.orig 2014-01-29 10:08:23.000000000 -0500
++++ ./lib/tzraw.c 2014-03-27 23:53:01.000000000 -0400
+@@ -70,9 +70,14 @@
+ /* me own header, innit */
+ #include "tzraw.h"
+
+-#if !defined MAP_ANONYMOUS && defined MAP_ANON
+-# define MAP_ANONYMOUS (MAP_ANON)
+-#endif /* MAP_ANON->MAP_ANONYMOUS */
++#ifndef MAP_ANONYMOUS
++#define MAP_ANONYMOUS 0x1000
++#endif
++
++#ifndef MAP_ANON
++#define MAP_ANON 0x1000
++#endif
++
+
+ #if defined TZDIR
+ static const char tzdir[] = TZDIR;
diff --git a/sysutils/dateutils/files/patch-src__prchunk.c b/sysutils/dateutils/files/patch-src__prchunk.c
new file mode 100644
index 000000000000..a1ff28e10f2e
--- /dev/null
+++ b/sysutils/dateutils/files/patch-src__prchunk.c
@@ -0,0 +1,19 @@
+--- ./src/prchunk.c.orig 2014-01-29 10:08:23.000000000 -0500
++++ ./src/prchunk.c 2014-03-27 23:53:01.000000000 -0400
+@@ -61,9 +61,13 @@
+ #define MAX_NLINES (16384)
+ #define MAX_LLEN (1024)
+
+-#if !defined MAP_ANONYMOUS && defined MAP_ANON
+-# define MAP_ANONYMOUS (MAP_ANON)
+-#endif /* MAP_ANON->MAP_ANONYMOUS */
++#ifndef MAP_ANONYMOUS
++#define MAP_ANONYMOUS 0x1000
++#endif
++
++#ifndef MAP_ANON
++#define MAP_ANON 0x1000
++#endif
+
+ #if defined __INTEL_COMPILER
+ # pragma warning(disable: 981)
diff --git a/sysutils/dateutils/pkg-descr b/sysutils/dateutils/pkg-descr
new file mode 100644
index 000000000000..a8f6f9ce5b12
--- /dev/null
+++ b/sysutils/dateutils/pkg-descr
@@ -0,0 +1,6 @@
+Dateutils are a collection of tools that revolve around manipulating
+dates and times on the command line. Commands included in the suite
+offer ways of converting dates between calendars, computing durations
+between dates, and finding dates in input streams.
+
+WWW: http://www.fresse.org/dateutils/
diff --git a/sysutils/dateutils/pkg-plist b/sysutils/dateutils/pkg-plist
new file mode 100644
index 000000000000..48b64f7699f5
--- /dev/null
+++ b/sysutils/dateutils/pkg-plist
@@ -0,0 +1,37 @@
+bin/dadd
+bin/dconv
+bin/ddiff
+bin/dgrep
+bin/dround
+bin/dseq
+bin/dtest
+bin/strptime
+include/dateutils/boops.h
+include/dateutils/date-core-strpf.h
+include/dateutils/date-core.h
+include/dateutils/dt-core-strpf.h
+include/dateutils/dt-core-tz-glue.h
+include/dateutils/dt-core.h
+include/dateutils/generics.h
+include/dateutils/leaps.h
+include/dateutils/leapseconds.def
+include/dateutils/nifty.h
+include/dateutils/strops.h
+include/dateutils/time-core-strpf.h
+include/dateutils/time-core.h
+include/dateutils/token.h
+include/dateutils/tzraw.h
+lib/libdut.a
+libdata/pkgconfig/libdut.pc
+man/man1/dadd.1.gz
+man/man1/dateutils.1.gz
+man/man1/dconv.1.gz
+man/man1/ddiff.1.gz
+man/man1/dgrep.1.gz
+man/man1/dround.1.gz
+man/man1/dseq.1.gz
+man/man1/dtest.1.gz
+man/man1/strptime.1.gz
+%%PORTDOCS%%%%DOCSDIR%%/README.md
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+@dirrm include/dateutils