aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authorwen <wen@FreeBSD.org>2015-04-30 16:58:56 +0800
committerwen <wen@FreeBSD.org>2015-04-30 16:58:56 +0800
commit07af3e3c8c5040ca377bcc3b5518f04e729e4f48 (patch)
treec6761da235cb31c750ed114a3b33a99ba1e2fd43 /sysutils
parentdd4250555a552c9a02f53f746fe7ff8a9494271f (diff)
downloadfreebsd-ports-gnome-07af3e3c8c5040ca377bcc3b5518f04e729e4f48.tar.gz
freebsd-ports-gnome-07af3e3c8c5040ca377bcc3b5518f04e729e4f48.tar.zst
freebsd-ports-gnome-07af3e3c8c5040ca377bcc3b5518f04e729e4f48.zip
- Update to 1.9.1
PR: 196723 Submitted by: sascha@root-login.org Approved by: michael@ranner.eu(maintainer)
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/duply/Makefile7
-rw-r--r--sysutils/duply/distinfo4
-rw-r--r--sysutils/duply/files/periodic_duply.in18
3 files changed, 18 insertions, 11 deletions
diff --git a/sysutils/duply/Makefile b/sysutils/duply/Makefile
index f6a19268e95e..72a75c05dbb4 100644
--- a/sysutils/duply/Makefile
+++ b/sysutils/duply/Makefile
@@ -2,9 +2,9 @@
# $FreeBSD$
PORTNAME= duply
-PORTVERSION= 1.7.4
+PORTVERSION= 1.9.1
CATEGORIES= sysutils
-MASTER_SITES= SF/ftplicity/${PORTNAME}%20%28simple%20duplicity%29/1.7.x/
+MASTER_SITES= SF/ftplicity/${PORTNAME}%20%28simple%20duplicity%29/1.9.x/
DISTNAME= ${PORTNAME}_${PORTVERSION}
EXTRACT_SUFX= .tgz
@@ -17,6 +17,8 @@ LICENSE_FILE= ${WRKSRC}/gpl-2.0.txt
RUN_DEPENDS= duplicity:${PORTSDIR}/sysutils/duplicity \
bash:${PORTSDIR}/shells/bash
+USES= python
+
NO_BUILD= yes
PORTDOCS= INSTALL.txt gpl-2.0.txt
@@ -27,6 +29,7 @@ SUB_FILES= pkg-message periodic_duply
post-patch:
${REINPLACE_CMD} -e "s,/etc/duply,${ETCDIR},g" ${WRKSRC}/duply
+ ${REINPLACE_CMD} -e "s,(python,(${PYTHON_CMD},g" ${WRKSRC}/duply
do-install:
${INSTALL_SCRIPT} ${WRKSRC}/duply ${STAGEDIR}${PREFIX}/bin/duply
diff --git a/sysutils/duply/distinfo b/sysutils/duply/distinfo
index 674e5574696a..8f618107ebbe 100644
--- a/sysutils/duply/distinfo
+++ b/sysutils/duply/distinfo
@@ -1,2 +1,2 @@
-SHA256 (duply_1.7.4.tgz) = 2bbcd6e55fcaa7ae2c416a6ce2d3ae0bc219dd05049d8708ff0e79a3349599e7
-SIZE (duply_1.7.4.tgz) = 34887
+SHA256 (duply_1.9.1.tgz) = e5f11c5a31a55de24cc5101a6429ea3eac14c0d3f0d6dec344b687089845efc5
+SIZE (duply_1.9.1.tgz) = 35883
diff --git a/sysutils/duply/files/periodic_duply.in b/sysutils/duply/files/periodic_duply.in
index a35461463e3a..96b6d37e3bc6 100644
--- a/sysutils/duply/files/periodic_duply.in
+++ b/sysutils/duply/files/periodic_duply.in
@@ -44,13 +44,17 @@ case "$backup_duply_enable" in
eval sleep $(jot -r 1 0 ${backup_duply_random})
echo
echo "Duply Backup:"
- eval duply ${backup_duply_profile} ${backup_duply_command} ${backup_duply_opt}
- if [ $? -gt 0 ]
- then
- echo "Errors were reported during backup."
- rc=3
- fi
- ;;
+ for duply_profile in ${backup_duply_profile}
+ do
+ eval duply ${duply_profile} ${backup_duply_command} ${backup_duply_opt}
+ if [ $? -gt 0 ]
+ then
+ echo "Errors were reported during backup."
+ rc=3
+ break
+ fi
+ done
+ ;;
esac
exit $rc