aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2014-07-31 04:59:56 +0800
committermarino <marino@FreeBSD.org>2014-07-31 04:59:56 +0800
commit28cccdff543bfae0863c4ac89b07afd2376e3e8c (patch)
treec5680bdec4e660630637b37356b3b37f42b020fb /sysutils
parent9e35aa10e95aa7fc028b6c4bd4a5890d7c0eddcb (diff)
downloadfreebsd-ports-gnome-28cccdff543bfae0863c4ac89b07afd2376e3e8c.tar.gz
freebsd-ports-gnome-28cccdff543bfae0863c4ac89b07afd2376e3e8c.tar.zst
freebsd-ports-gnome-28cccdff543bfae0863c4ac89b07afd2376e3e8c.zip
Stage sysutils/LPRngTool
PR: 187976 Submitted by: Ports Fury
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/LPRngTool/Makefile58
-rw-r--r--sysutils/LPRngTool/pkg-descr2
-rw-r--r--sysutils/LPRngTool/pkg-install99
-rw-r--r--sysutils/LPRngTool/pkg-plist8
4 files changed, 19 insertions, 148 deletions
diff --git a/sysutils/LPRngTool/Makefile b/sysutils/LPRngTool/Makefile
index 314ccb3d8b49..a42bf11105da 100644
--- a/sysutils/LPRngTool/Makefile
+++ b/sysutils/LPRngTool/Makefile
@@ -3,60 +3,30 @@
PORTNAME= LPRngTool
PORTVERSION= 1.3.2
-PORTREVISION= 7
+PORTREVISION= 8
CATEGORIES= sysutils print
-MASTER_SITES= ftp://ftp.lprng.com/pub/%SUBDIR%/ \
- ftp://ftp.cise.ufl.edu/pub/mirrors/%SUBDIR%/ \
- ftp://ftp.cs.umn.edu/pub/%SUBDIR%/ \
- ftp://ftp.informatik.uni-hamburg.de/pub/os/unix/utils/%SUBDIR%/ \
- ftp://ftp.uni-paderborn.de/pub/unix/printer/%SUBDIR%/
-MASTER_SITE_SUBDIR= LPRng/LPRngTool
+MASTER_SITES= SF/lprng/lprngtool/LRPngTool-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Configuration Tool for LPRng
-BUILD_DEPENDS= a2ps:${PORTSDIR}/print/a2ps \
- wish:${PORTSDIR}/x11-toolkits/tk-wrapper
+LICENSE= GPLv2
-#RUN_DEPENDS= ifhp:${PORTSDIR}/print/ifhp
+BUILD_DEPENDS= a2ps:${PORTSDIR}/print/a2ps \
+ mpage:${PORTSDIR}/print/mpage
+USES= tar:tgz tk
USE_GHOSTSCRIPT_BUILD= yes
-USES= tk tar:tgz
-
-.if defined(SYSCONFDIR)
-PLIST_SUB+= CWD="" SYSCONFDIR="${SYSCONFDIR:S,^/,,}"
-.else
-SYSCONFDIR= ${PREFIX}/etc
-PLIST_SUB+= CWD="@comment " SYSCONFDIR="${SYSCONFDIR:S,^${PREFIX}/,,}"
-.endif
-
GNU_CONFIGURE= yes
+CONFIGURE_ENV= ac_cv_path_WISH=${WISH}
+CONFIGURE_ARGS= --with-spool_directory=/var/spool/lpd
USE_LDCONFIG= yes
-CONFIGURE_ARGS+= --with-spool_directory=/var/spool/lpd \
- --with-sysconfdir="${SYSCONFDIR}"
-
-MAN1= lprngtool.1
-
-NO_STAGE= yes
-pre-everything::
- @${ECHO_MSG} "If you want to replace the default printing system with LPRng, use:"
- @${ECHO_MSG} " make PREFIX=/usr SYSCONFDIR=/etc clean all install"
- @if [ "${PREFIX}" = "/usr" -a ! -d /usr/man ] ; then \
- ${ECHO_MSG} "The man pages will be installed in /usr/man." ; \
- ${ECHO_MSG} "You should make a symbolic link /usr/share/man from /usr/man"; \
- ${ECHO_MSG} " ln -s /usr/share/man /usr/man"; \
- ${ECHO_MSG} "If you do not, you will retain the old FreeBSD man pages."; \
- ${ECHO_MSG} "See the hier(7) man page for details of the FreeBSD file system"; \
- ${ECHO_MSG} "layout. Configure is not equipped to determine the location of"; \
- ${ECHO_MSG} 'man pages and defaults to $${PREFIX}/man, which is incorrect for FreeBSD.'; \
- exit 1; \
- fi
- @${ECHO_MSG} "Configuring with '${CONFIGURE_ARGS}'"
-
-post-install:
- @if [ ! -f ${SYSCONFDIR}/lprngtool.conf ]; then \
- ${CP} ${SYSCONFDIR}/lprngtool.conf.sample ${SYSCONFDIR}/lprngtool.conf; \
- fi
+post-patch:
+ @${REINPLACE_CMD} -e \
+ 's|=freebsd|=generic|' ${WRKSRC}/Makefile.in
+ @${REINPLACE_CMD} -e \
+ '/cp $$p.sample $$p;/d ; \
+ /chmod 644 $$p;/d' ${WRKSRC}/postinstall.generic.sh
.include <bsd.port.mk>
diff --git a/sysutils/LPRngTool/pkg-descr b/sysutils/LPRngTool/pkg-descr
index f4d6da3eb15e..6ccae5bb963d 100644
--- a/sysutils/LPRngTool/pkg-descr
+++ b/sysutils/LPRngTool/pkg-descr
@@ -8,3 +8,5 @@ Graphical User Interface that allows users to:
enable and disable spooling to print queues
- configure print filters such as IFHP and the RedHat
print filters
+
+WWW: http://lprng.sourceforge.net/
diff --git a/sysutils/LPRngTool/pkg-install b/sysutils/LPRngTool/pkg-install
deleted file mode 100644
index 7edaac001983..000000000000
--- a/sysutils/LPRngTool/pkg-install
+++ /dev/null
@@ -1,99 +0,0 @@
-#!/bin/sh
-PREFIX=/usr
-SYSCONFDIR=/usr/etc
-LPRNGTOOL_CONF=/usr/etc/lprngtool.conf
-MANDIR=/usr/man
-VERSION=1.3.1
-#
-# -- START --
-# $FreeBSD$
-# $Id: postinstall.freebsd.sh,v 1.8 2000/11/27 20:09:31 papowell Exp papowell $
-#
-# If you are building a PORT, see the
-# DISTRIBUTIONS/Freebsd directory for a complete port
-# building package.
-#
-# This is the shell script that does the postinstall
-# dynamic fixup
-# It needs to be massaged with the information for
-# various paths.
-# If you are building a package, then you do NOT want
-# to have this executed - it will put the sample files
-# in place. You need to do this during the postinstall
-# step in the package installation.
-#
-echo RUNNING postinstall.freebsd.sh MAKEPACKAGE="$MAKEPACKAGE" MAKEINSTALL="$MAKEINSTALL" PREFIX="$PREFIX" cwd `pwd`
-if [ "$VERBOSE_INSTALL" != "" ] ; then set -x; fi
-fix () {
- v=`echo $1 | sed -e 's/[:;].*//'`;
- p=`echo $2 | sed -e 's/:.*//'`; d=`dirname $p`;
- if expr "$p" : "\|" >/dev/null ; then
- echo "$v is a filter '$p'"
- exit 0
- fi
- echo "Putting $p in $d, using $v.sample"
- if [ ! -d "$d" ] ; then
- echo "Directory $d does not exist!"
- mkdir -p $d
- fi
- if [ -f $v.sample ] ; then
- if [ $v.sample != $p.sample ] ; then cp $v.sample $p.sample; fi
- elif [ -f $v ] ; then
- if [ $v != $p.sample ] ; then cp $v $p.sample; fi
- else
- echo "Do not have $v.sample or $v"
- fi
- if [ ! -f $p.sample ] ; then
- echo "Do not have $p.sample"
- else
- if [ -f $p ] ; then
- date=`date | awk '{ print $6, $2, $3, $4;}' | sed -e 's/ */_/g' `
- echo "Saving $p in $p.$date"
- mv $p $p.$date
- fi
- chmod 644 $p.sample
- cp $p.sample $p;
- chmod 644 $p;
- fi;
-}
-# we use the /usr/local/etc/rc.d method to start
-# lpd
-# we have to take them from one place and put in another
-if [ "X$MAKEPACKAGE" = "XYES" ] ; then
- hold=${DESTDIR}${PREFIX}/etc
- echo "Setting up configuration files path for package creation" ${hold}
- if [ ! -d ${hold} ] ; then mkdir -p ${hold} ; fi;
- cp lprngtool.conf ${hold}/lprngtool.conf.sample
-elif [ X$MAKEINSTALL = XYES ] ; then
- # we have the port pre-install operation
- if [ "$MANDIR" = "/usr/man" -a ! -d ${DESTDIR}/usr/man ] ; then
- # we have the dreaded standard installation
- # try to make a symbolic link to
- echo "Creating symbolic link from /usr/man to /usr/share/man"
- v=`ln -s ${DESTDIR}/usr/share/man ${DESTDIR}/usr/man`;
- fi
- hold=${DESTDIR}${PREFIX}/etc
- echo "Setting up configuration files path for installation" ${hold}
- if [ ! -d ${hold} ] ; then mkdir -p ${hold} ; fi;
- cp lprngtool.conf ${hold}/lprngtool.conf.sample
- fix lprngtool.conf "${DESTDIR}${LPRNGTOOL_CONF}"
-elif [ "X$2" = "XPOST-INSTALL" ] ; then
- # when doing an install from a package we get the file from the package
- hold=etc
- if [ -f ${hold}/lprngtool.conf.sample ] ; then
- fix ${hold}/lprngtool.conf "${LPRNGTOOL_CONF}"
- else
- echo "WARNING: configuration files missing from package! CWD " `pwd`
- ls
- exit 1
- fi
-elif [ "X$2" = "XPRE-INSTALL" ] ; then
- # we have the port pre-install operation
- if [ "$MANDIR" = "/usr/man" -a ! -d /usr/man ] ; then
- # we have the dreaded standard installation
- # try to make a symbolic link to
- echo "Creating symbolic link from /usr/man to /usr/share/man"
- v=`ln -s /usr/share/man /usr/man`;
- fi
-fi
-exit 0
diff --git a/sysutils/LPRngTool/pkg-plist b/sysutils/LPRngTool/pkg-plist
index 30e26f5543d4..b9fed206b774 100644
--- a/sysutils/LPRngTool/pkg-plist
+++ b/sysutils/LPRngTool/pkg-plist
@@ -1,13 +1,11 @@
bin/lprngtool
+@sample etc/lprngtool.conf.sample
libexec/filters/atalkprint
libexec/filters/ncpprint
-libexec/filters/smbprint
libexec/filters/printerdb
+libexec/filters/smbprint
libexec/filters/testpage.asc
libexec/filters/testpage.ps
libexec/filters/testpage-a4.ps
+man/man1/lprngtool.1.gz
@dirrmtry libexec/filters
-%%CWD%%@cwd /
-@unexec if cmp -s %D/%%SYSCONFDIR%%/lprngtool.conf %D/%%SYSCONFDIR%%/lprngtool.conf.sample; then rm -f %D/%%SYSCONFDIR%%/lprngtool.conf; fi
-%%SYSCONFDIR%%/lprngtool.conf.sample
-@exec [ -f %B/lprngtool.conf ] || cp %B/%f %B/lprngtool.conf