aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2007-10-09 22:32:46 +0800
committerehaupt <ehaupt@FreeBSD.org>2007-10-09 22:32:46 +0800
commit2bcdf15753d020915c941a490e9edff4fc642fe0 (patch)
tree89d957dab3bbd81571f4adb59848b630420926ab /sysutils
parent7893a3498de3d6a6a474f041cc4614c72a1bc871 (diff)
downloadfreebsd-ports-gnome-2bcdf15753d020915c941a490e9edff4fc642fe0.tar.gz
freebsd-ports-gnome-2bcdf15753d020915c941a490e9edff4fc642fe0.tar.zst
freebsd-ports-gnome-2bcdf15753d020915c941a490e9edff4fc642fe0.zip
Add weedit, a file duplicate scanner with database support.
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/weedit/Makefile36
-rw-r--r--sysutils/weedit/distinfo3
-rw-r--r--sysutils/weedit/pkg-descr4
4 files changed, 44 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index c116c289c074..3d3ffbf24610 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -689,6 +689,7 @@
SUBDIR += watchfolder
SUBDIR += webjob
SUBDIR += webmin
+ SUBDIR += weedit
SUBDIR += whatpix
SUBDIR += whowatch
SUBDIR += wmapm
diff --git a/sysutils/weedit/Makefile b/sysutils/weedit/Makefile
new file mode 100644
index 000000000000..999a70c1e022
--- /dev/null
+++ b/sysutils/weedit/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: weedit
+# Date created: 9 Oct 2007
+# Whom: Emanuel Haupt <ehaupt@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= weedit
+PORTVERSION= 2.0.1
+CATEGORIES= sysutils
+MASTER_SITES= http://adm1n.cjb.net/cw/ \
+ http://critical.ch/distfiles/ \
+ http://energy.critical.ch/distfiles/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= ehaupt@FreeBSD.org
+COMMENT= File duplicate scanner with database support
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+SRCF= crc32 dlink weedit md5
+
+PLIST_FILES= bin/weedit bin/weeditreaddb
+
+do-build:
+.for f in ${SRCF}
+ ${CC} ${CFLAGS} -c ${WRKSRC}/${f}.c -o ${WRKSRC}/${f}.o
+.endfor
+ ${CC} ${CFLAGS} ${WRKSRC}/utils/readdb.c -o ${WRKSRC}/weeditreaddb
+ ${CC} ${LDFLAGS} -o ${WRKSRC}/${PORTNAME} \
+ ${SRCF:C/(.*)/${WRKSRC}\/\1.o/}
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/weeditreaddb ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/sysutils/weedit/distinfo b/sysutils/weedit/distinfo
new file mode 100644
index 000000000000..520616a0953e
--- /dev/null
+++ b/sysutils/weedit/distinfo
@@ -0,0 +1,3 @@
+MD5 (weedit-2.0.1.tgz) = 0be21183ee88a6bbbd49d317650b69b6
+SHA256 (weedit-2.0.1.tgz) = 213781f8ecd929ad8902486b6da7b47d3a3bb908641cc8cde3d044fea4a3768f
+SIZE (weedit-2.0.1.tgz) = 20378
diff --git a/sysutils/weedit/pkg-descr b/sysutils/weedit/pkg-descr
new file mode 100644
index 000000000000..a50b64948ef6
--- /dev/null
+++ b/sysutils/weedit/pkg-descr
@@ -0,0 +1,4 @@
+weedit is a file duplicate scanner with database support. It uses CRC32, MD5,
+and file size to scan for duplicates.
+
+WWW: http://adm1n.cjb.net/cw/