aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2012-06-16 05:53:04 +0800
committerbapt <bapt@FreeBSD.org>2012-06-16 05:53:04 +0800
commit2d08a7d68b857fab0b43002fba3f307f50027f02 (patch)
treef1349888ddbb98a8829f41a114389c9234c43434 /sysutils
parent46d7ce6a27d3d997d5da010606e07507ba45bd0f (diff)
downloadfreebsd-ports-gnome-2d08a7d68b857fab0b43002fba3f307f50027f02.tar.gz
freebsd-ports-gnome-2d08a7d68b857fab0b43002fba3f307f50027f02.tar.zst
freebsd-ports-gnome-2d08a7d68b857fab0b43002fba3f307f50027f02.zip
- update to 3.0.0
- add an options for NLS - upstream changes: * fix size and inode calculation on FreeBSD * new aguments: -l: show only local mounts -d: show the used size -e: allow to export informations in TeX, HTML, CSV -p: filter on file system name -q: sort the output * more: http://projects.gw-computing.net/news/12
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/dfc/Makefile23
-rw-r--r--sysutils/dfc/distinfo4
-rw-r--r--sysutils/dfc/files/patch-src__dfc.c26
-rw-r--r--sysutils/dfc/pkg-plist16
4 files changed, 45 insertions, 24 deletions
diff --git a/sysutils/dfc/Makefile b/sysutils/dfc/Makefile
index 2508f47300f8..ca0732841d6a 100644
--- a/sysutils/dfc/Makefile
+++ b/sysutils/dfc/Makefile
@@ -6,22 +6,31 @@
#
PORTNAME= dfc
-PORTVERSION= 2.5.0
+PORTVERSION= 3.0.0
CATEGORIES= sysutils
-MASTER_SITES= http://projects.gw-computing.net/attachments/download/42/
+MASTER_SITES= http://projects.gw-computing.net/attachments/download/63/
MAINTAINER= bapt@FreeBSD.org
COMMENT= Display file system space usage using graph and colors
LICENSE= BSD
-PLIST_FILES= bin/dfc
+OPTIONS_DEFINE= NLS
+
+USE_CMAKE= yes
+CMAKE_ARGS+= -DMAN_PATH=${MANPREFIX}/man -DDFC_DOC_PATH=${DOCSDIR}
+MANLANG= "" fr
MAN1= dfc.1
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if ${OSVERSION} < 800000
-BROKEN= does not compile on FreeBSD 7.X
+.if ${PORT_OPTIONS:MNLS}
+CMAKE_ARGS+= -DNLS_ENABLED=true
+USE_GETTEXT= yes
+PLIST_SUB+= NLS=""
+.else
+CMAKE_ARGS+= -DNLS_ENABLED=false
+PLIST_SUB+= NLS="@comment "
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/sysutils/dfc/distinfo b/sysutils/dfc/distinfo
index 210174f11883..dbbb096876b5 100644
--- a/sysutils/dfc/distinfo
+++ b/sysutils/dfc/distinfo
@@ -1,2 +1,2 @@
-SHA256 (dfc-2.5.0.tar.gz) = c76c6fc3cefd12609e5e09e3cd2773b1c78e2020ef58546964ce2180c83f65b1
-SIZE (dfc-2.5.0.tar.gz) = 12226
+SHA256 (dfc-3.0.0.tar.gz) = 703c40e99eeee764b53af3e2a16159fe24f87152780942d307a86535b07c5a8f
+SIZE (dfc-3.0.0.tar.gz) = 39334
diff --git a/sysutils/dfc/files/patch-src__dfc.c b/sysutils/dfc/files/patch-src__dfc.c
index eecffca877ea..693a7a696dd9 100644
--- a/sysutils/dfc/files/patch-src__dfc.c
+++ b/sysutils/dfc/files/patch-src__dfc.c
@@ -1,15 +1,11 @@
---- ./src/dfc.c.orig 2012-04-03 23:38:18.000000000 +0200
-+++ ./src/dfc.c 2012-04-13 00:05:00.488294758 +0200
-@@ -713,10 +713,12 @@
- if (strlcat(buffer, ",acls", bufsize) >= bufsize)
- goto truncated;
- /* NOTREACHED */
-+#if __FreeBSD__version > 800000
- if (flags & MNT_NFS4ACLS)
- if (strlcat(buffer, ",nfsv4acls", bufsize) >= bufsize)
- goto truncated;
- /* NOTREACHED */
-+#endif
-
- return buffer;
- /* NOTREACHED */
+--- ./src/dfc.c.orig 2012-05-31 00:25:46.000000000 +0200
++++ ./src/dfc.c 2012-06-15 23:39:58.405538089 +0200
+@@ -853,7 +853,7 @@
+ #if defined(__FreeBSD__) || defined(__APPLE__)
+ { MNT_MULTILABEL, "multilabel" },
+ #endif
+-#if defined(__FreeBSD__)
++#if defined(__FreeBSD__) && __FreeBSD__version > 800000
+ { MNT_NFS4ACLS, "nfs4acls" },
+ #endif
+ #if defined(__DragonFly__) || defined(__FreeBSD__) || defined(__NetBSD__) \
diff --git a/sysutils/dfc/pkg-plist b/sysutils/dfc/pkg-plist
new file mode 100644
index 000000000000..dfa72e89505e
--- /dev/null
+++ b/sysutils/dfc/pkg-plist
@@ -0,0 +1,16 @@
+etc/xdg/dfc/dfcrc
+etc/xdg/dfc/fr/dfcrc
+bin/dfc
+%%DOCSDIR%%/AUTHORS
+%%DOCSDIR%%/HACKING
+%%DOCSDIR%%/LICENSE
+%%DOCSDIR%%/README
+%%DOCSDIR%%/TRANSLATORS
+%%NLS%% share/locale/fr/LC_MESSAGES/dfc.mo
+@dirrmtry %%DOCSDIR%%/
+@dirrmtry man/fr/man1
+@dirrmtry man/fr
+@dirrmtry etc/xdg/dfc/fr
+@dirrmtry etc/xdg/dfc
+@dirrmtry etc/xdg
+