aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2003-12-17 09:30:15 +0800
committerpav <pav@FreeBSD.org>2003-12-17 09:30:15 +0800
commit2f49ca3d03372638a300d5f813fdacc548c48653 (patch)
tree79d901a44d0e74a4c54fc5879b8591ea088407ea /sysutils
parent8cc80b8c29e26056b6702fdee326d9b8503cf2f6 (diff)
downloadfreebsd-ports-gnome-2f49ca3d03372638a300d5f813fdacc548c48653.tar.gz
freebsd-ports-gnome-2f49ca3d03372638a300d5f813fdacc548c48653.tar.zst
freebsd-ports-gnome-2f49ca3d03372638a300d5f813fdacc548c48653.zip
Add coreutils, port of basic GNU file, shell and text manipulation utilities.
This port replaces fileutils, shellutils and textutils, which were distributed as three individual sets, but now have been combined into coreutils. For more details, see http://www.gnu.org/software/coreutils/ PR: ports/59422 Submitted by: Jason Harris <jharris@widomaker.com>
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/coreutils/Makefile70
-rw-r--r--sysutils/coreutils/distinfo2
-rw-r--r--sysutils/coreutils/files/patch-lib-Makefile.in11
-rw-r--r--sysutils/coreutils/files/patch-src-stat.c36
-rw-r--r--sysutils/coreutils/pkg-descr23
-rw-r--r--sysutils/coreutils/pkg-plist149
7 files changed, 292 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index 725c515b7780..d4ae4617c421 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -58,6 +58,7 @@
SUBDIR += consolehm
SUBDIR += contool
SUBDIR += copytape
+ SUBDIR += coreutils
SUBDIR += cotty
SUBDIR += cpbk
SUBDIR += cpdup
diff --git a/sysutils/coreutils/Makefile b/sysutils/coreutils/Makefile
new file mode 100644
index 000000000000..8828fdcb02cb
--- /dev/null
+++ b/sysutils/coreutils/Makefile
@@ -0,0 +1,70 @@
+# New ports collection makefile for: coreutils
+# Date created: 18 November 2003
+# Whom: Jason Harris <jharris@widomaker.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= coreutils
+PORTVERSION= 5.0
+CATEGORIES= sysutils textproc
+MASTER_SITES= ${MASTER_SITE_GNU}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX} ${DISTNAME}${EXTRACT_SUFX}.sig
+EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
+
+MAINTAINER= jharris@widomaker.com
+COMMENT= The Free Software Foundation's core utilities
+
+LIB_DEPENDS= intl.5:${PORTSDIR}/devel/gettext
+
+CONFLICTS= sh-utils-* fileutils-* textutils-* id-utils-*
+
+# Global variables
+#
+
+USE_BZIP2= yes
+GNU_CONFIGURE= yes
+USE_REINPLACE= yes
+CONFIGURE_ARGS= --program-prefix=g
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" LIBS="-L${LOCALBASE}/lib"
+
+USE_GMAKE= yes
+
+INFO= coreutils
+
+MAN1= gbasename.1 gcat.1 gchgrp.1 gchmod.1 gchown.1 gchroot.1 gcksum.1 \
+ gcomm.1 gcp.1 gcsplit.1 gcut.1 gdate.1 gdd.1 gdf.1 gdir.1 \
+ gdircolors.1 gdirname.1 gdu.1 gecho.1 genv.1 gexpand.1 gexpr.1 \
+ gfactor.1 gfalse.1 gfmt.1 gfold.1 ggroups.1 ghead.1 ghostid.1 \
+ ghostname.1 gid.1 ginstall.1 gjoin.1 glink.1 gln.1 glogname.1 gls.1 \
+ gmd5sum.1 gmkdir.1 gmkfifo.1 gmknod.1 gmv.1 gnice.1 gnl.1 gnohup.1 \
+ god.1 gpaste.1 gpathchk.1 gpinky.1 gpr.1 gprintenv.1 gprintf.1 gptx.1 \
+ gpwd.1 greadlink.1 grm.1 grmdir.1 gseq.1 gsha1sum.1 gshred.1 gsleep.1 \
+ gsort.1 gsplit.1 gstat.1 gstty.1 gsu.1 gsum.1 gsync.1 gtac.1 gtail.1 \
+ gtee.1 gtest.1 gtouch.1 gtr.1 gtrue.1 gtsort.1 gtty.1 guname.1 \
+ gunexpand.1 guniq.1 gunlink.1 guptime.1 gusers.1 gvdir.1 gwc.1 gwho.1 \
+ gwhoami.1 gyes.1
+
+# Local variables
+#
+
+INSTALL_INFO?= install-info
+
+# Patch
+#
+
+post-patch:
+.if !defined(WITH_SUID)
+ @${REINPLACE_CMD} -e "s/u\+s/u\+w/g" ${WRKSRC}/src/Makefile.in
+.endif
+
+# Post-install
+#
+
+post-install: install-info
+
+install-info:
+ @${INSTALL_INFO} ${PREFIX}/info/${PORTNAME}.info ${PREFIX}/info/dir
+
+.include <bsd.port.mk>
diff --git a/sysutils/coreutils/distinfo b/sysutils/coreutils/distinfo
new file mode 100644
index 000000000000..affbc386ca87
--- /dev/null
+++ b/sysutils/coreutils/distinfo
@@ -0,0 +1,2 @@
+MD5 (coreutils-5.0.tar.bz2) = 94e5558ee2a65723d4840bfde2d323f0
+MD5 (coreutils-5.0.tar.bz2.sig) = 86116a258f352c423e6e13f555f9d338
diff --git a/sysutils/coreutils/files/patch-lib-Makefile.in b/sysutils/coreutils/files/patch-lib-Makefile.in
new file mode 100644
index 000000000000..ebee823c65c5
--- /dev/null
+++ b/sysutils/coreutils/files/patch-lib-Makefile.in
@@ -0,0 +1,11 @@
+--- lib/Makefile.in.orig Wed Apr 2 16:28:42 2003
++++ lib/Makefile.in Wed Dec 17 02:03:19 2003
+@@ -823,7 +823,7 @@
+ $(INSTALL_DATA) $(charset_tmp) $(charset_alias) ; \
+ rm -f $(charset_tmp) ; \
+ else \
+- if test @GLIBC21@ = no; then \
++ if 0; then \
+ sed -f ref-add.sed charset.alias > $(charset_tmp) ; \
+ $(INSTALL_DATA) $(charset_tmp) $(charset_alias) ; \
+ rm -f $(charset_tmp) ; \
diff --git a/sysutils/coreutils/files/patch-src-stat.c b/sysutils/coreutils/files/patch-src-stat.c
new file mode 100644
index 000000000000..358e30b321c5
--- /dev/null
+++ b/sysutils/coreutils/files/patch-src-stat.c
@@ -0,0 +1,36 @@
+--- src/stat.c.orig Sat Mar 22 23:32:02 2003
++++ src/stat.c Wed Dec 17 01:35:58 2003
+@@ -23,20 +23,22 @@
+ #include <sys/types.h>
+ #include <pwd.h>
+ #include <grp.h>
+-#include <unistd.h>
+-#include <time.h>
+-#if HAVE_SYS_STATVFS_H
++#if HAVE_SYS_STATVFS_H && HAVE_STRUCT_STATVFS_F_BASETYPE
+ # include <sys/statvfs.h>
+-#endif
+-#if HAVE_SYS_VFS_H
++#elif HAVE_SYS_VFS_H
+ # include <sys/vfs.h>
+-#endif
+-
++#elif HAVE_SYS_MOUNT_H && HAVE_SYS_PARAM_H
++/* NOTE: freebsd5.0 needs sys/param.h and sys/mount.h for statfs.
++ It does have statvfs.h, but shouldn't use it, since it doesn't
++ HAVE_STRUCT_STATVFS_F_BASETYPE. So find a clean way to fix it. */
+ /* NetBSD 1.5.2 needs these, for the declaration of struct statfs. */
+-#if !HAVE_SYS_STATVFS_H && !HAVE_SYS_VFS_H
+-# if HAVE_SYS_MOUNT_H && HAVE_SYS_PARAM_H
+-# include <sys/param.h>
+-# include <sys/mount.h>
++# include <sys/param.h>
++# include <sys/mount.h>
++# if HAVE_NETINET_IN_H && HAVE_NFS_NFS_CLNT_H && HAVE_NFS_VFS_H
++/* Ultrix 4.4 needs these for the declaration of struct statfs. */
++# include <netinet/in.h>
++# include <nfs/nfs_clnt.h>
++# include <nfs/vfs.h>
+ # endif
+ #endif
+
diff --git a/sysutils/coreutils/pkg-descr b/sysutils/coreutils/pkg-descr
new file mode 100644
index 000000000000..b6f958f97c4f
--- /dev/null
+++ b/sysutils/coreutils/pkg-descr
@@ -0,0 +1,23 @@
+The Free Software Foundation's core utilities:
+
+ basename, cat, chgrp, chmod, chown, chroot, cksum, comm, cp, csplit,
+ cut, date, dd, df, dir, dircolors, dirname, du, echo, env, expand, expr,
+ factor, false, fmt, fold, groups, head, hostid, hostname, id, install,
+ join, kill, link, ln, logname, ls, md5sum, mkdir, mkfifo, mknod, mv, nice,
+ nl, nohup, od, paste, pathchk, pinky, pr, printenv, printf, ptx, pwd,
+ readlink, rm, rmdir, seq, sha1sum, shred, sleep, sort, split, stat, stty,
+ su, sum, sync, tac, tail, tee, test, touch, tr, true, tsort, tty, uname,
+ unexpand, uniq, unlink, uptime, users, vdir, wc, who, whoami, yes
+
+Similar utilities to most of these exist in the FreeBSD base system,
+but many of the GNU versions have added functionality that is
+useful.
+
+Note that this port will install these utilities with a `g' prefix,
+for example gdate, gexpr, and gtest, but the texinfo documentation
+will refer to them without the `g' prefix.
+
+GNU su does not support a wheel group. This port installs it
+without the suid bit, unless you define WITH_SUID while building.
+
+WWW: http://www.gnu.org/directory/coreutils.html
diff --git a/sysutils/coreutils/pkg-plist b/sysutils/coreutils/pkg-plist
new file mode 100644
index 000000000000..c571d9616c3d
--- /dev/null
+++ b/sysutils/coreutils/pkg-plist
@@ -0,0 +1,149 @@
+bin/gbasename
+bin/gcat
+bin/gchgrp
+bin/gchmod
+bin/gchown
+bin/gchroot
+bin/gcksum
+bin/gcomm
+bin/gcp
+bin/gcsplit
+bin/gcut
+bin/gdate
+bin/gdd
+bin/gdf
+bin/gdir
+bin/gdircolors
+bin/gdirname
+bin/gdu
+bin/gecho
+bin/genv
+bin/gexpand
+bin/gexpr
+bin/gfactor
+bin/gfalse
+bin/gfmt
+bin/gfold
+bin/ggroups
+bin/ghead
+bin/ghostid
+bin/ghostname
+bin/gid
+bin/ginstall
+bin/gjoin
+bin/gkill
+bin/glink
+bin/gln
+bin/glogname
+bin/gls
+bin/gmd5sum
+bin/gmkdir
+bin/gmkfifo
+bin/gmknod
+bin/gmv
+bin/gnice
+bin/gnl
+bin/gnohup
+bin/god
+bin/gpaste
+bin/gpathchk
+bin/gpinky
+bin/gpr
+bin/gprintenv
+bin/gprintf
+bin/gptx
+bin/gpwd
+bin/greadlink
+bin/grm
+bin/grmdir
+bin/gseq
+bin/gsha1sum
+bin/gshred
+bin/gsleep
+bin/gsort
+bin/gsplit
+bin/gstat
+bin/gstty
+bin/gsu
+bin/gsum
+bin/gsync
+bin/gtac
+bin/gtail
+bin/gtee
+bin/gtest
+bin/gtouch
+bin/gtr
+bin/gtrue
+bin/gtsort
+bin/gtty
+bin/guname
+bin/gunexpand
+bin/guniq
+bin/gunlink
+bin/guptime
+bin/gusers
+bin/gvdir
+bin/gwc
+bin/gwho
+bin/gwhoami
+bin/gyes
+share/locale/be/LC_MESSAGES/coreutils.mo
+share/locale/be/LC_TIME/coreutils.mo
+share/locale/ca/LC_MESSAGES/coreutils.mo
+share/locale/ca/LC_TIME/coreutils.mo
+share/locale/cs/LC_MESSAGES/coreutils.mo
+share/locale/cs/LC_TIME/coreutils.mo
+share/locale/da/LC_MESSAGES/coreutils.mo
+share/locale/da/LC_TIME/coreutils.mo
+share/locale/de/LC_MESSAGES/coreutils.mo
+share/locale/de/LC_TIME/coreutils.mo
+share/locale/el/LC_MESSAGES/coreutils.mo
+share/locale/el/LC_TIME/coreutils.mo
+share/locale/es/LC_MESSAGES/coreutils.mo
+share/locale/es/LC_TIME/coreutils.mo
+share/locale/et/LC_MESSAGES/coreutils.mo
+share/locale/et/LC_TIME/coreutils.mo
+share/locale/fi/LC_MESSAGES/coreutils.mo
+share/locale/fi/LC_TIME/coreutils.mo
+share/locale/fr/LC_MESSAGES/coreutils.mo
+share/locale/fr/LC_TIME/coreutils.mo
+share/locale/gl/LC_MESSAGES/coreutils.mo
+share/locale/gl/LC_TIME/coreutils.mo
+share/locale/hu/LC_MESSAGES/coreutils.mo
+share/locale/hu/LC_TIME/coreutils.mo
+share/locale/it/LC_MESSAGES/coreutils.mo
+share/locale/it/LC_TIME/coreutils.mo
+share/locale/ja/LC_MESSAGES/coreutils.mo
+share/locale/ja/LC_TIME/coreutils.mo
+share/locale/ko/LC_MESSAGES/coreutils.mo
+share/locale/ko/LC_TIME/coreutils.mo
+share/locale/lg/LC_MESSAGES/coreutils.mo
+share/locale/lg/LC_TIME/coreutils.mo
+share/locale/ms/LC_MESSAGES/coreutils.mo
+share/locale/ms/LC_TIME/coreutils.mo
+share/locale/nb/LC_MESSAGES/coreutils.mo
+share/locale/nb/LC_TIME/coreutils.mo
+share/locale/nl/LC_MESSAGES/coreutils.mo
+share/locale/nl/LC_TIME/coreutils.mo
+share/locale/no/LC_MESSAGES/coreutils.mo
+share/locale/no/LC_TIME/coreutils.mo
+share/locale/pl/LC_MESSAGES/coreutils.mo
+share/locale/pl/LC_TIME/coreutils.mo
+share/locale/pt/LC_MESSAGES/coreutils.mo
+share/locale/pt/LC_TIME/coreutils.mo
+share/locale/pt_BR/LC_MESSAGES/coreutils.mo
+share/locale/pt_BR/LC_TIME/coreutils.mo
+share/locale/ru/LC_MESSAGES/coreutils.mo
+share/locale/ru/LC_TIME/coreutils.mo
+share/locale/sk/LC_MESSAGES/coreutils.mo
+share/locale/sk/LC_TIME/coreutils.mo
+share/locale/sl/LC_MESSAGES/coreutils.mo
+share/locale/sl/LC_TIME/coreutils.mo
+share/locale/sv/LC_MESSAGES/coreutils.mo
+share/locale/sv/LC_TIME/coreutils.mo
+share/locale/tr/LC_MESSAGES/coreutils.mo
+share/locale/tr/LC_TIME/coreutils.mo
+share/locale/zh_CN/LC_MESSAGES/coreutils.mo
+share/locale/zh_CN/LC_TIME/coreutils.mo
+share/locale/zh_TW/LC_MESSAGES/coreutils.mo
+share/locale/zh_TW/LC_TIME/coreutils.mo