aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authordanfe <danfe@FreeBSD.org>2014-01-28 22:45:30 +0800
committerdanfe <danfe@FreeBSD.org>2014-01-28 22:45:30 +0800
commit4181b5e26bffa5d06b9dfb3b1430d6517eb45f51 (patch)
treeabd5f78841908e1bcf4c69bc8c7d5c0670cc9db9 /sysutils
parent1b8e39c7d52e5256c3b920343b06216101ee1bea (diff)
downloadfreebsd-ports-gnome-4181b5e26bffa5d06b9dfb3b1430d6517eb45f51.tar.gz
freebsd-ports-gnome-4181b5e26bffa5d06b9dfb3b1430d6517eb45f51.tar.zst
freebsd-ports-gnome-4181b5e26bffa5d06b9dfb3b1430d6517eb45f51.zip
- Remove references to long unsupported "alpha" architecture
- While here, cleanup and simplify the Makefiles
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/gpart/Makefile9
-rw-r--r--sysutils/screen/Makefile15
2 files changed, 8 insertions, 16 deletions
diff --git a/sysutils/gpart/Makefile b/sysutils/gpart/Makefile
index d10462b88fba..ceb2a705233d 100644
--- a/sysutils/gpart/Makefile
+++ b/sysutils/gpart/Makefile
@@ -18,15 +18,12 @@ PLIST_FILES= sbin/gpart man/man8/gpart.8.gz
CFLAGS+= -std=c99
OPTIONS_DEFINE= STATIC
+STATIC_LDFLAGS= -static
.include <bsd.port.options.mk>
-.if ${ARCH} != "i386" && ${ARCH} != "alpha" && ${ARCH} != "amd64"
-BROKEN= Only compiles on i386, amd64 and alpha.
-.endif
-
-.if ${PORT_OPTIONS:MSTATIC}
-LDFLAGS+= -static
+.if ${ARCH} != "i386" && ${ARCH} != "amd64"
+BROKEN= only compiles on i386 and amd64
.endif
.include <bsd.port.mk>
diff --git a/sysutils/screen/Makefile b/sysutils/screen/Makefile
index 7c950e9030fe..10b1cc137cb2 100644
--- a/sysutils/screen/Makefile
+++ b/sysutils/screen/Makefile
@@ -1,4 +1,4 @@
-# Created by: ache
+# Created by: Andrey Chernov <ache@FreeBSD.org>
# $FreeBSD$
PORTNAME= screen
@@ -8,11 +8,10 @@ CATEGORIES= sysutils
MASTER_SITES= ftp://ftp.uni-erlangen.de/pub/utilities/screen/ \
http://komquats.com/distfiles/ \
http://people.freebsd.org/~cy/distfiles/ \
- ${MASTER_SITE_GNU}
-MASTER_SITE_SUBDIR= screen
+ GNU
MAINTAINER= cy@FreeBSD.org
-COMMENT= A multi-screen window manager
+COMMENT= Multi-screen window manager
OPTIONS_DEFINE= CJK INFO MAN NETHACK XTERM_256 HOSTINLOCKED SHOWENC
OPTIONS_DEFAULT= INFO MAN NETHACK XTERM_256
@@ -40,10 +39,6 @@ INFO= screen
MAKE_ARGS+= -DWITH_INFO
.endif
-.if ${ARCH} == "alpha"
-CFLAGS+= -O0
-.endif
-
# Enables support for 256 colour xterm. Note that you may need to
# set up a custom termcap entry or .screenrc which modifies termcap
# to contain the following: Co#256:AB=\E[48;5;%dm:AF=\E[38;5;%dm
@@ -76,7 +71,7 @@ post-patch:
post-install:
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
- @${INSTALL_DATA} ${WRKSRC}/etc/etcscreenrc ${STAGEDIR}${EXAMPLESDIR}/screenrc
-
+ ${INSTALL_DATA} ${WRKSRC}/etc/etcscreenrc \
+ ${STAGEDIR}${EXAMPLESDIR}/screenrc
.include <bsd.port.mk>