aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authorrakuco <rakuco@FreeBSD.org>2015-08-18 19:32:38 +0800
committerrakuco <rakuco@FreeBSD.org>2015-08-18 19:32:38 +0800
commit509d21a5853a263eeb726a448d70dfce0a495137 (patch)
tree464836fb493fbf79794a472fe93d48aa37539944 /sysutils
parent6c7e68b86a85a3fe21a871a20411dda30e22505b (diff)
downloadfreebsd-ports-gnome-509d21a5853a263eeb726a448d70dfce0a495137.tar.gz
freebsd-ports-gnome-509d21a5853a263eeb726a448d70dfce0a495137.tar.zst
freebsd-ports-gnome-509d21a5853a263eeb726a448d70dfce0a495137.zip
Import upstream commit to make emacs-in-tmux-in-tmux show cursor.
Import upstream commit 2c53b23d59 to make the cursor appear when running Emacs in a tmux nested inside another tmux session (this is particularly useful when trying to edit a text file on a remote server that is also running tmux). Approved by: mat (maintainer) Differential Revision: https://reviews.freebsd.org/D3408
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/tmux/Makefile1
-rw-r--r--sysutils/tmux/files/patch-git_2c53b23d35
2 files changed, 36 insertions, 0 deletions
diff --git a/sysutils/tmux/Makefile b/sysutils/tmux/Makefile
index c367d30fc536..0f2f957e4c01 100644
--- a/sysutils/tmux/Makefile
+++ b/sysutils/tmux/Makefile
@@ -3,6 +3,7 @@
PORTNAME= tmux
PORTVERSION= 2.0
+PORTREVISION= 1
CATEGORIES= sysutils
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION:S/a$//}
diff --git a/sysutils/tmux/files/patch-git_2c53b23d b/sysutils/tmux/files/patch-git_2c53b23d
new file mode 100644
index 000000000000..7076db980eac
--- /dev/null
+++ b/sysutils/tmux/files/patch-git_2c53b23d
@@ -0,0 +1,35 @@
+commit 2c53b23d5968da2e796ead6ed9f8ff3c33b8bbfb
+Author: nicm <nicm>
+Date: Tue May 19 08:48:37 2015 +0000
+
+ In terminfo, sometimes cvvis implies cnorm and sometimes it doesn't, so
+ don't assume it does. Fixes missing cursor with emacs-in-tmux-in-tmux.
+
+--- tty.c
++++ tty.c
+@@ -507,14 +507,17 @@ tty_update_mode(struct tty *tty, int mode, struct screen *s)
+ mode &= ~MODE_CURSOR;
+
+ changed = mode ^ tty->mode;
+- if (changed & (MODE_CURSOR|MODE_BLINKING)) {
+- if (mode & MODE_CURSOR) {
+- if (mode & MODE_BLINKING &&
+- tty_term_has(tty->term, TTYC_CVVIS))
+- tty_putcode(tty, TTYC_CVVIS);
+- else
+- tty_putcode(tty, TTYC_CNORM);
+- } else
++ if (changed & MODE_BLINKING) {
++ if (tty_term_has(tty->term, TTYC_CVVIS))
++ tty_putcode(tty, TTYC_CVVIS);
++ else
++ tty_putcode(tty, TTYC_CNORM);
++ changed |= MODE_CURSOR;
++ }
++ if (changed & MODE_CURSOR) {
++ if (mode & MODE_CURSOR)
++ tty_putcode(tty, TTYC_CNORM);
++ else
+ tty_putcode(tty, TTYC_CIVIS);
+ }
+ if (s != NULL && tty->cstyle != s->cstyle) {