aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authorantoine <antoine@FreeBSD.org>2014-02-09 20:11:18 +0800
committerantoine <antoine@FreeBSD.org>2014-02-09 20:11:18 +0800
commit5e6f44c51f5ef77f100d79d3b18456bc6ab93348 (patch)
tree36c6db177bbbe3af2a739e606f71860fe88ea0d0 /sysutils
parent453345fdc3ea357f8f74808783843ad8f59fbd98 (diff)
downloadfreebsd-ports-gnome-5e6f44c51f5ef77f100d79d3b18456bc6ab93348.tar.gz
freebsd-ports-gnome-5e6f44c51f5ef77f100d79d3b18456bc6ab93348.tar.zst
freebsd-ports-gnome-5e6f44c51f5ef77f100d79d3b18456bc6ab93348.zip
- Finish stage support (man page)
- Shebangfix a perl script - Remove DOCS conditionals
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/sec/Makefile11
1 files changed, 4 insertions, 7 deletions
diff --git a/sysutils/sec/Makefile b/sysutils/sec/Makefile
index 1073900ecb86..86dcf270de4c 100644
--- a/sysutils/sec/Makefile
+++ b/sysutils/sec/Makefile
@@ -2,6 +2,7 @@
PORTNAME= sec
PORTVERSION= 2.7.5
+PORTREVISION= 1
CATEGORIES= sysutils
MASTER_SITES= SF/simple-evcorr/${PORTNAME}/${PORTVERSION}
@@ -12,30 +13,26 @@ LICENSE= GPLv2
USE_RC_SUBR= sec
-USES= perl5
+USES= perl5 shebangfix
+SHEBANG_FILES= sec
USE_PERL5= run
NO_BUILD= yes
-MAN8= sec.8
PORTDOCS= ChangeLog README
-PLIST_FILES= bin/sec
+PLIST_FILES= bin/sec man/man8/sec.8.gz
PORTCONTRIB= convert.pl itostream.c swatch2sec.pl
PLIST_FILES+= ${PORTCONTRIB:S|^|%%DATADIR%%/|}
PLIST_DIRS+= %%DATADIR%%
OPTIONS_DEFINE= DOCS
-.include <bsd.port.options.mk>
-
do-install:
${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/sec.man ${STAGEDIR}${MANPREFIX}/man/man8/sec.8
@${MKDIR} ${STAGEDIR}${DATADIR}
cd ${WRKSRC}/contrib && ${INSTALL_DATA} ${PORTCONTRIB} ${STAGEDIR}${DATADIR}
-.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
-.endif
.include <bsd.port.mk>