aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authoraaron <aaron@FreeBSD.org>2006-06-19 15:50:50 +0800
committeraaron <aaron@FreeBSD.org>2006-06-19 15:50:50 +0800
commit6b7786686c6d7418c62e0af15289e0026847c708 (patch)
tree1f9788a06089ac2d7c3cceb2ede2569f1277b40f /sysutils
parent2acc5367ec7b5dc43f48660661fb102ef6409d9a (diff)
downloadfreebsd-ports-gnome-6b7786686c6d7418c62e0af15289e0026847c708.tar.gz
freebsd-ports-gnome-6b7786686c6d7418c62e0af15289e0026847c708.tar.zst
freebsd-ports-gnome-6b7786686c6d7418c62e0af15289e0026847c708.zip
Adding port sysutils/p5-Filesys-Statvfs, Perl extension for statvfs() and
fstatvfs(). PR: ports/98249 Submitted by: aaron Approved by: maintainer timeout, tobez (implicit)
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/p5-Filesys-Statvfs/Makefile28
-rw-r--r--sysutils/p5-Filesys-Statvfs/distinfo3
-rw-r--r--sysutils/p5-Filesys-Statvfs/pkg-descr16
-rw-r--r--sysutils/p5-Filesys-Statvfs/pkg-plist7
5 files changed, 55 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index fdcde1628827..2719d5cc4690 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -377,6 +377,7 @@
SUBDIR += p5-Filesys-DiskFree
SUBDIR += p5-Filesys-DiskSpace
SUBDIR += p5-Filesys-DiskUsage
+ SUBDIR += p5-Filesys-Statvfs
SUBDIR += p5-FreeBSD-Portindex
SUBDIR += p5-LJ-Cache
SUBDIR += p5-LJ-TextMessage
diff --git a/sysutils/p5-Filesys-Statvfs/Makefile b/sysutils/p5-Filesys-Statvfs/Makefile
new file mode 100644
index 000000000000..0e268e77edee
--- /dev/null
+++ b/sysutils/p5-Filesys-Statvfs/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: p5-Filesys-Statvfs
+# Date created: 31 May 2006
+# Whom: Aaron Dalton <aaron@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Filesys-Statvfs
+PORTVERSION= 0.80
+CATEGORIES= sysutils perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Filesys
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= pirzyk@freebsd.org
+COMMENT= Perl extension for statvfs() and fstatvfs()
+
+PERL_CONFIGURE= yes
+
+MAN3= Filesys::Statvfs.3
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+IGNORE= requires statvfs() which is not available before FreeBSD-5*
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/sysutils/p5-Filesys-Statvfs/distinfo b/sysutils/p5-Filesys-Statvfs/distinfo
new file mode 100644
index 000000000000..f06e9dcb89e2
--- /dev/null
+++ b/sysutils/p5-Filesys-Statvfs/distinfo
@@ -0,0 +1,3 @@
+MD5 (Filesys-Statvfs-0.80.tar.gz) = c34b93d70cd654fd9ef322b5dab977b4
+SHA256 (Filesys-Statvfs-0.80.tar.gz) = d8e001cf36e4bdc1d068cfc0dbcb844ef91d29e04d6d91a01ef0666beb879c97
+SIZE (Filesys-Statvfs-0.80.tar.gz) = 3730
diff --git a/sysutils/p5-Filesys-Statvfs/pkg-descr b/sysutils/p5-Filesys-Statvfs/pkg-descr
new file mode 100644
index 000000000000..c1ffb25411a0
--- /dev/null
+++ b/sysutils/p5-Filesys-Statvfs/pkg-descr
@@ -0,0 +1,16 @@
+Interface for statvfs() and fstatvfs()
+
+Unless you need access to the bsize, flag, and namemax values, you should
+probably look at using Filesys::DfPortable or Filesys::Df instead.
+
+The statvfs() and fstatvfs() functions will return a list of values, or
+will return undef and set $! if there was an error.
+
+The values returned are described in the statvfs header or the statvfs()
+man page.
+
+The module assumes that if you have statvfs(), fstatvfs() will also be
+available.
+
+WWW: http://search.cpan.org/dist/Filesys-Statvfs/
+Author: Ian Guthrie <IGuthrie@aol.com>
diff --git a/sysutils/p5-Filesys-Statvfs/pkg-plist b/sysutils/p5-Filesys-Statvfs/pkg-plist
new file mode 100644
index 000000000000..25c9848712f7
--- /dev/null
+++ b/sysutils/p5-Filesys-Statvfs/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/Filesys/Statvfs.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Filesys/Statvfs/.packlist
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Filesys/Statvfs/Statvfs.bs
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Filesys/Statvfs/Statvfs.so
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Filesys/Statvfs
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Filesys
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/Filesys