aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authorstas <stas@FreeBSD.org>2008-04-06 16:58:21 +0800
committerstas <stas@FreeBSD.org>2008-04-06 16:58:21 +0800
commit6fbde8aaf51fc0bcaf991519b739b0592c98f740 (patch)
tree280ebf175af2693f172cb9dc5674fa73fb5992d3 /sysutils
parentf29755f74021d623e3671b29c948ead5c3e33715 (diff)
downloadfreebsd-ports-gnome-6fbde8aaf51fc0bcaf991519b739b0592c98f740.tar.gz
freebsd-ports-gnome-6fbde8aaf51fc0bcaf991519b739b0592c98f740.tar.zst
freebsd-ports-gnome-6fbde8aaf51fc0bcaf991519b739b0592c98f740.zip
- Add ruby 1.9 support
- Implement new knobs for gems and rake (these are included in ruby 1.9 distribution already). Also move gem bits from ruby-gems/Makefile.common to bsd.ruby.mk[1]. Now to depend on gems or rake you should define USE_RUBYGEMS/USE_RAKE accordingly. Also RAKE_BIN variable is provided for pointing to the right rake executable. - Rewrite RUBY_SCHEBANG in awk to eliminate build dependency on ruby. Discussed with: Jonathan Weiss <jw@innerewut.de> [1] (gems maintainer) Tested by: ports@
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/rubygem-capistrano/Makefile11
-rw-r--r--sysutils/rubygem-god/Makefile7
2 files changed, 10 insertions, 8 deletions
diff --git a/sysutils/rubygem-capistrano/Makefile b/sysutils/rubygem-capistrano/Makefile
index ceb2a05d56e6..65ce9e8435c6 100644
--- a/sysutils/rubygem-capistrano/Makefile
+++ b/sysutils/rubygem-capistrano/Makefile
@@ -13,10 +13,13 @@ MASTER_SITES= RF
MAINTAINER= r.s.a.vandomburg@nedforce.nl
COMMENT= A utility for executing commands in parallel on multiple machines
-RUN_DEPENDS= rake:${PORTSDIR}/devel/rubygem-rake \
- ${LOCALBASE}/${SPEC_DIR}/net-sftp-1.1.0.gemspec:${PORTSDIR}/security/rubygem-net-sftp \
+RUN_DEPENDS= ${LOCALBASE}/${SPEC_DIR}/net-sftp-1.1.0.gemspec:${PORTSDIR}/security/rubygem-net-sftp \
rubygem-highline>=1.4.0:${PORTSDIR}/devel/rubygem-highline
+USE_RUBY= yes
+USE_RAKE= yes
+USE_RUBYGEMS= yes
+
post-install:
@${ECHO_MSG} "======================================================================"
@${ECHO_MSG}
@@ -27,6 +30,4 @@ post-install:
@${ECHO_MSG}
@${ECHO_MSG} "======================================================================"
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/ruby-gems/Makefile.common"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/sysutils/rubygem-god/Makefile b/sysutils/rubygem-god/Makefile
index 258d9379d6ce..16c6ac98bca9 100644
--- a/sysutils/rubygem-god/Makefile
+++ b/sysutils/rubygem-god/Makefile
@@ -15,6 +15,7 @@ COMMENT= Monitoring framework written in Ruby
BUILD_DEPENDS= rubygem-hoe>=1.3.0:${PORTSDIR}/devel/rubygem-hoe
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/ruby-gems/Makefile.common"
-.include <bsd.port.post.mk>
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+
+.include <bsd.port.mk>