aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authorkevlo <kevlo@FreeBSD.org>2012-05-11 15:08:07 +0800
committerkevlo <kevlo@FreeBSD.org>2012-05-11 15:08:07 +0800
commit7bd4037b10b3b0e3a1dc27c402798dc8e5641208 (patch)
tree27c58ac93e243b57212ad3d20a4e4b871239267d /sysutils
parent1aa4993b208db16f5fcadc03879469f5e7b23874 (diff)
downloadfreebsd-ports-gnome-7bd4037b10b3b0e3a1dc27c402798dc8e5641208.tar.gz
freebsd-ports-gnome-7bd4037b10b3b0e3a1dc27c402798dc8e5641208.tar.zst
freebsd-ports-gnome-7bd4037b10b3b0e3a1dc27c402798dc8e5641208.zip
Fix build on 10-CURRENT
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/fusefs-kmod/Makefile6
-rw-r--r--sysutils/fusefs-kmod/files/extrapatch-fuse_module__fuse_vnops.c11
2 files changed, 16 insertions, 1 deletions
diff --git a/sysutils/fusefs-kmod/Makefile b/sysutils/fusefs-kmod/Makefile
index c276b53e4ab1..b2411f35d06d 100644
--- a/sysutils/fusefs-kmod/Makefile
+++ b/sysutils/fusefs-kmod/Makefile
@@ -7,7 +7,7 @@
PORTNAME= fusefs
DISTVERSION= 0.3.9-pre1.20080208
-PORTREVISION= 9
+PORTREVISION= 10
CATEGORIES= sysutils kld
MASTER_SITES= http://mercurial.creo.hu/repos/fuse4bsd-hg/index.cgi/archive/
PKGNAMESUFFIX= -kmod
@@ -62,6 +62,10 @@ OPTIONS= AUTOSETUP "Automatic global config file setup" off
EXTRA_PATCHES+= ${FILESDIR}/extra-patch-fuse_module__fuse_vnops.c
.endif
+.if ${OSVERSION} >= 1000011
+EXTRA_PATCHES+= ${FILESDIR}/extrapatch-fuse_module__fuse_vnops.c
+.endif
+
.if !exists(${SRC_BASE}/sys/Makefile)
IGNORE= requires the Kernel source to be installed. Set SRC_BASE if it is not in /usr/src
.endif
diff --git a/sysutils/fusefs-kmod/files/extrapatch-fuse_module__fuse_vnops.c b/sysutils/fusefs-kmod/files/extrapatch-fuse_module__fuse_vnops.c
new file mode 100644
index 000000000000..e74e067fbf7c
--- /dev/null
+++ b/sysutils/fusefs-kmod/files/extrapatch-fuse_module__fuse_vnops.c
@@ -0,0 +1,11 @@
+--- fuse_module/fuse_vnops.c.orig 2012-05-11 14:59:59.000000000 +0800
++++ fuse_module/fuse_vnops.c 2012-05-11 15:00:05.000000000 +0800
+@@ -663,7 +663,7 @@
+ if ((err = fuse_recyc_backend(vp, td)))
+ return err;
+
+- vrecycle(vp, td);
++ vrecycle(vp);
+
+ return (0);
+ }