aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authorlioux <lioux@FreeBSD.org>2006-03-28 00:28:57 +0800
committerlioux <lioux@FreeBSD.org>2006-03-28 00:28:57 +0800
commit820b0d40be0aee7a9f2ccae43e7dd7981f2321c0 (patch)
tree9ea9e9faf7fc7f5e2732677342b84bd830914e2e /sysutils
parentd116e9d444819f76a7f93792c61bf92fc5e20da8 (diff)
downloadfreebsd-ports-gnome-820b0d40be0aee7a9f2ccae43e7dd7981f2321c0.tar.gz
freebsd-ports-gnome-820b0d40be0aee7a9f2ccae43e7dd7981f2321c0.tar.zst
freebsd-ports-gnome-820b0d40be0aee7a9f2ccae43e7dd7981f2321c0.zip
o dvd+rw-tools Makefile uses an incorrect compile time macro due
to a typo. It should be using -D_THREAD_SAFE instead of -DTHREAS_SAFE o Futhermore, make sure the port upholds PTHREAD_{CFLAGS,LIBS} o Bump PORTREVISION PR: 92315 Approved by: maintainer
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/dvd+rw-tools/Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/sysutils/dvd+rw-tools/Makefile b/sysutils/dvd+rw-tools/Makefile
index a8cc87f61639..f83eeb8d3d90 100644
--- a/sysutils/dvd+rw-tools/Makefile
+++ b/sysutils/dvd+rw-tools/Makefile
@@ -6,7 +6,7 @@
PORTNAME= dvd+rw-tools
PORTVERSION= 6.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= sysutils
MASTER_SITES= http://www.franksworld.org/dist/dvd+rw/ \
http://www.pkix.net/mirror/fy.chalmers.se/ \
@@ -26,7 +26,12 @@ PLIST_FILES= ${BIN_FILES:S|^|bin/|}
PORTDOCS= index.html
post-patch:
- ${REINPLACE_CMD} -e 's/-O2//' ${WRKSRC}/Makefile.m4
+ ${REINPLACE_CMD} -E \
+ -e 's/-D_THREAS_SAFE/-D_THREAD_SAFE/' \
+ -e 's/-D_THREAD_SAFE/-D_THREAD_SAFE ${PTHREAD_CFLAGS}/' \
+ -e 's/-pthread/${PTHREAD_LIBS}/' \
+ -e 's/-O2//' \
+ ${WRKSRC}/Makefile.m4
do-install:
.for i in ${BIN_FILES}