aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authorian <ian@FreeBSD.org>2015-08-09 09:44:22 +0800
committerian <ian@FreeBSD.org>2015-08-09 09:44:22 +0800
commit8713e593a39032a1433e9253c24d4986cb6548e3 (patch)
tree7f8d03b8c43131123fa01a4619a174d879eb968a /sysutils
parent995be3ecba62d0597df6ceaf64c073e095951a0c (diff)
downloadfreebsd-ports-gnome-8713e593a39032a1433e9253c24d4986cb6548e3.tar.gz
freebsd-ports-gnome-8713e593a39032a1433e9253c24d4986cb6548e3.tar.zst
freebsd-ports-gnome-8713e593a39032a1433e9253c24d4986cb6548e3.zip
Use gcc 4.9.2 to cross-compile u-boot for beaglebone.
Approved by: rpaulo
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/u-boot-beaglebone/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/sysutils/u-boot-beaglebone/Makefile b/sysutils/u-boot-beaglebone/Makefile
index a5af20b0f3f1..01fe651068fb 100644
--- a/sysutils/u-boot-beaglebone/Makefile
+++ b/sysutils/u-boot-beaglebone/Makefile
@@ -12,7 +12,9 @@ COMMENT= Cross-build U-Boot loader for BeagleBone and BeagleBone Black
LICENSE= GPLv2
-BUILD_DEPENDS= arm-none-eabi-gcc:${PORTSDIR}/devel/arm-none-eabi-gcc
+BUILD_DEPENDS= ${CROSS_GCC}:${PORTSDIR}/devel/arm-none-eabi-gcc492
+
+CROSS_GCC= arm-none-eabi-gcc-4.9.2
NO_ARCH= yes
@@ -26,6 +28,7 @@ PLIST_FILES= ${U_BOOT_DIR}/u-boot.img \
${U_BOOT_DIR}/README
MAKE_ARGS+= ARCH=arm \
+ CC=${CROSS_GCC} \
CROSS_COMPILE=arm-none-eabi-
do-configure: