aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authornetchild <netchild@FreeBSD.org>2005-06-18 06:59:29 +0800
committernetchild <netchild@FreeBSD.org>2005-06-18 06:59:29 +0800
commit8d63fa8ce3e1cb7a464d405732fcf971c5848297 (patch)
treebef012ab5e448ce5c144b7bb40139ba1dfd902a6 /sysutils
parent5f5845bb3ad1db90d601456aaaea7343c4dabfc6 (diff)
downloadfreebsd-ports-gnome-8d63fa8ce3e1cb7a464d405732fcf971c5848297.tar.gz
freebsd-ports-gnome-8d63fa8ce3e1cb7a464d405732fcf971c5848297.tar.zst
freebsd-ports-gnome-8d63fa8ce3e1cb7a464d405732fcf971c5848297.zip
Mega-patch to cleanup the ports infrastructure regarding our linux bits:
- USE_LINUX now implies NO_FILTER_SHLIBS=yes. It also doesn't use FreeBSD tools to strip binaries anymore, so it's not neccesary anymore to override STRIP and STRIP_CMD. - USE_LINUX_PREFIX implies NO_MTREE now. - In the USE_LINUX case, USE_XLIB now depends upon the linux X11 libraries instead upon the native FreeBSD libraries. - The variable LINUX_BASE_PORT contains a string which is suitable as an item in *_DEPENDS, so if a port BATCH_DEPENDS or FETCH_DEPENDS upon the default (or overriden) linux base, ${LINUX_BASE_PORT} should be used instead of a hardcoded reference. - Change all ports to comply to the "new world order". - The Ports Collection now allows to override the default linux_base port. Specify e.g. OVERRIDE_LINUX_BASE_PORT=rh-9 in /etc/make.conf to use ${PORTSDIR}/emulators/linux_base-rh-9 (the logic is to use ${PORTSDIR}/emulators/linux_base-${OVERRIDE_LINUX_BASE_PORT}). - If USE_LINUX or OVERRIDE_LINUX_BASE doesn't point to an existing linux_base port and if USE_LINUX isn't set to "yes" (case insensitive), the port will be marked as IGNORE. [1] - Readd USE_LINUX knobs into several ports and make several uses of a conditional dependency ("USE_LINUX?=") into an unconditional one ("USE_LINUX=") which where removed/changed by Trevor to allow the use of alternative linux_base ports. While this is a nice goal, the implementation resulted in missing dependencies. The OVERRIDE_LINUX_BASE_PORT knob in this commit is supposed to fix the problem while keeping the feature. Basicaly this includes a backout of Trevor's commit, to prevent confusion I mention it here explicitely. - Use the correct prefix (X11- instead of LOCAL- or LINUX-) for some ports. Chase dependencies for this. - Changes to make linux_devtools installable on amd64, remove some stray device nodes (they don't work on recent OS versions and aren't really needed). - Make linux_base-8 PREFIX clean and remove some stray device nodes. Additionally tell a little bit more about how to setup NIS/YP [2]. - Update the PGSQL dependency in the linux-opengroupware port to a recent version (the old one isn't available anymore), I don't know if this works (at least it isn't more broken than before). - Use PREFIX/usr/share/doc instead of PREFIX/usr/doc in the divx4linux ports, the former path exists already and gets populated by other packages too (PREFIX=LINUXPREFIX!). - Fix some obvious (non-linuxolator) bugs in some linux ports while being there. - Bump PORTREVISION where neccesary. Requested by: portmgr (linimon) [1] Submittted by: Gerrit Kuehn <gerrit_huehn@gruft.fido.de [2] Approved by: portmgr (kris, linimon), maintainers (or maintainer timeout) Tested on: ports cluster (kris) Reviewed by: silence on emulation@ Superseedes PR: 69997 Maintainer approval from: chris@chrisburkert.de cracauer@cons.org des girgen jamie@bishopston.net mezz mi nivit@users.sf.net pat simond@irrelevant.org riggs@rrr.de Udo.Schweigert@Siemens.com
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/linux-acu/Makefile9
-rw-r--r--sysutils/linux-afaapps/Makefile12
2 files changed, 12 insertions, 9 deletions
diff --git a/sysutils/linux-acu/Makefile b/sysutils/linux-acu/Makefile
index 6c90599fcbd9..ec9180a25979 100644
--- a/sysutils/linux-acu/Makefile
+++ b/sysutils/linux-acu/Makefile
@@ -7,7 +7,7 @@
PORTNAME= acu
PORTVERSION= 2.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= sysutils linux
MASTER_SITES= # fetch manually
PKGNAMEPREFIX= linux-
@@ -30,9 +30,9 @@ IGNORE= may not be automatically fetched due to licensing\
.endif
ONLY_FOR_ARCHS= i386
-PREFIX?= ${X11BASE}
+USE_LINUX= yes
+USE_X_PREFIX= yes
NO_WRKSUBDIR= yes
-NO_BUILD= yes
NO_CDROM= "Redistribution not allowed"
LINPROCFS!= /sbin/mount | ${GREP} linprocfs | ${AWK} '{print $1}'
@@ -55,6 +55,9 @@ post-extract:
@${FALSE}
.endif
+do-build:
+ @${BRANDELF} -t Linux ${WRKSRC}/utilities/acu
+
do-install:
@${MKDIR} ${PREFIX}/bin
@${MKDIR} ${LINUXBASE}/proc/aironet
diff --git a/sysutils/linux-afaapps/Makefile b/sysutils/linux-afaapps/Makefile
index 319d1eec68d3..973355f41e8b 100644
--- a/sysutils/linux-afaapps/Makefile
+++ b/sysutils/linux-afaapps/Makefile
@@ -7,7 +7,7 @@
PORTNAME= afaapps
PORTVERSION= 2.7
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= sysutils linux
MASTER_SITES= ftp://ftp.us.dell.com/scsi-raid/
PKGNAMEPREFIX= linux-
@@ -26,12 +26,11 @@ RESTRICTED= "binary redistribution license needs clarification"
NO_BUILD= yes
NO_WRKSUBDIR= yes
-USE_LINUX_PREFIX= yes
-NO_MTREE= yes
+USE_LINUX= yes
+USE_LINUX_PREFIX= yes
LDCONFIG_LINUX= ${LINUXBASE}/sbin/ldconfig
ONLY_FOR_ARCHS= i386
-NO_FILTER_SHLIBS= yes
PLIST= ${MASTERDIR}/pkg-plist.${MACHINE_ARCH}
MD5_FILE= ${MASTERDIR}/distinfo.${MACHINE_ARCH}
@@ -43,8 +42,9 @@ RPMFLAGS= --ignoreos --root ${PREFIX} --dbpath ${DBPATH} \
do-install:
@${LOCALBASE}/bin/rpm -U ${RPMFLAGS} ${WRKDIR}/${RPMFILE}
- @${RM} ${LINUXBASE}/usr/sbin/afacli
- @${MV} ${LINUXBASE}/usr/sbin/afacli.bin ${LINUXBASE}/usr/sbin/afacli
+ @${RM} ${PREFIX}/usr/sbin/afacli
+ @${MV} ${PREFIX}/usr/sbin/afacli.bin ${PREFIX}/usr/sbin/afacli
+ @${BRANDELF} -t Linux ${PREFIX}/usr/sbin/afacli
@${LDCONFIG_LINUX}
.include <bsd.port.mk>
5-09-29 21:37:44 +0800'>2005-09-292-0/+26 * Remove obsolete mastersites.linimon2005-09-291-2/+1 * Fix typo error (USE_REPLACE => USE_REINPLACE), my fault :(vanilla2005-09-291-1/+1 * Fix manpage pathnames.vanilla2005-09-291-0/+5 * - Update to 5.0.55sem2005-09-262-1/+3 * Update to 0.1.5.novel2005-09-264-8/+8 * search.cpan.org redirect reduction canonicalization project, pass 1:fenner2005-09-222-2/+2 * - Fix chown in post-installpav2005-09-192-3/+5 * - Fix distinfopav2005-09-191-2/+2 * - Fix outputpav2005-09-181-6/+6 * - Update to 3.4.1pav2005-09-1812-1015/+214 * - Fix rc scriptpav2005-09-181-4/+4 * - Update to 6.19.4pav2005-09-1814-890/+103 * - Update to 7.1.2pav2005-09-1625-327/+456 * Drop maintainership, since I'm buried in the $REALLIFE stuff.krion2005-09-141-1/+1 * - Flip TCL option to default to onpav2005-09-111-8/+2 * Update to 0.5.kwm2005-09-105-69/+55 * Update to 2.4.5.marcus2005-09-102-3/+3 * - Remove WITH_SOCKS5 option which never workedlawrance2005-09-091-9/+5 * - Add gaim-irchelperahze2005-09-055-0/+55 * Update to 2.0.0lawrance2005-09-046-6/+60 * It has been reported that the Perl plug-in works fine on amd64 now, somarcus2005-09-021-2/+2 * Update to 5.0.54lawrance2005-08-312-1/+3 * BROKEN on amd64: Does not buildkris2005-08-311-0/+4 * Update to 0.4.5perky2005-08-292-3/+3 * o Update to -> 0.67mich2005-08-292-3/+3 * Update to 0.9.1krion2005-08-282-3/+3 * Unbreak.tobez2005-08-022-156/+150 * - Update to 0.1.4clement2005-08-014-8/+10 * - Update tp 0.1.13clement2005-07-314-8/+10 * Update to 0.9.0krion2005-07-272-3/+3 * - Update to 0.3.12garga2005-07-264-27/+18 * Since ports/75832 is already closed by committing a workaround, this portmezz2005-07-252-14/+2 * Add conflicts line for irssi-devel.vsevolod2005-07-251-0/+2 * Add development version of irssi irc client.vsevolod2005-07-258-126/+185 * This port is scheduled for deletion on 2005-09-22 if it is still brokenkris2005-07-231-0/+2 * - Update to 0.45.3novel2005-07-224-90/+110 * Update my email address.vsevolod2005-07-221-1/+1 * - Update irc/p5-POE-Component-IRC to 4.65leeym2005-07-223-3/+5 * - Move .pid file to /var/runpav2005-07-213-6/+20 * GGI:IRC is a Perl/CGI program that lets you access IRC from a web browser, it ispav2005-07-195-0/+164 * - Update to 0.5.4pav2005-07-184-17/+18 * With portmgr hat on, reset eik's ports since he has been inactive forlinimon2005-07-181-1/+1 * - Update to 20050715pav2005-07-163-3/+34 * This is a collection of useful scripts for the irssi IRC-client maintained bypav2005-07-165-0/+367 * - Fix 'echo' syntaxsem2005-07-151-1/+1 * This is plugin pack for Supybot, IRC robot. These pluginspav2005-07-135-0/+716 * - Fix empty directoriespav2005-07-131-0/+2 * - Update to 2.11.1p1pav2005-07-132-4/+4 * Update to 5.0.3.novel2005-07-122-3/+3 * - Update to 2.0.1pav2005-07-032-6/+5 * - Update to 0.99pav2005-07-032-3/+3 * Fix build with ipfilter4arved2005-06-291-5/+11 * - Update to 4.63sem2005-06-233-27/+34 * - Update to 2.4.4.mezz2005-06-223-6/+9 * Directory share/pixmaps is now included in mtreelesi2005-06-152-2/+0 * Update to 0.4.6pat2005-06-102-3/+3 * Redo CONFIGURE/MAKE_ARGS handlingvs2005-06-084-53/+10 * - Distfile was rerolled. Only change is the removal of gcov related CXXFLAGSmarkus2005-06-084-4/+6 * - Update to version 0.18markus2005-06-0712-46/+158 * - Update MASTER_SITESpav2005-06-062-2/+2 * - Update to 5.0.53.flz2005-06-022-3/+7 * - Add pear-Net_SmartIRC PEAR class for communication with IRC networks.flz2005-05-314-0/+113 * - rcNG'ify the port.flz2005-05-315-37/+37 * Update to version 2.11.1.thierry2005-05-302-3/+3 * Add solid-ircd 3.4.7,oliver2005-05-285-0/+55 * This is an encryption plugin for irssi, it is based on blowfish andpav2005-05-264-0/+62 * - Fix package to create empty lib/irssi/modules directory, to match port'spav2005-05-264-2/+4 * - Assorted fixes and improvementspav2005-05-257-882/+127 * - Update to 0.1.2clement2005-05-224-6/+6 * o Update to 0.66mich2005-05-192-3/+3 * Update port: irc/ptlink-ircd Update from 6.18.2 to 6.19.3edwin2005-05-1911-51/+931 * bump revision for new patchalfred2005-05-172-4/+36 * Update to 0.4.5jylefort2005-05-162-4/+3 * - Move USE_OPENSSL and USE_PYTHON above of bsd.port.mksem2005-05-152-26/+26 * Change maintainer address.thierry2005-05-141-1/+1 * - version update to 5.0.51vs2005-05-115-35/+38 * - Update to 0.0.5 [1]jylefort2005-05-113-6/+10 * - Update to version 0.1.1clement2005-05-074-10/+32 * Fix build on amd64.krion2005-05-011-0/+1 * BROKEN: Does not buildkris2005-04-301-0/+2 * Update to 1.9.5vs2005-04-293-3/+7 * Fix RUN_DEPENDS and thus package building.danfe2005-04-281-1/+1 * - Put period at the end of sentencedanfe2005-04-261-1/+3 * Add thales 1.0, GNU Thales -- An IRC to MySQL gateway.danfe2005-04-265-0/+214 * - Update to 0.70sem2005-04-234-57/+81 * Update to version 2.6.2krion2005-04-214-22/+12 * - Add WWW: line in pkg-descr.flz2005-04-212-1/+3 * Special version of IRC server for RusNet IRC Network.pav2005-04-2115-0/+2220 * Don't remove plugin-directory as it is owned by xchat2vs2005-04-201-1/+0 * Don't remove plugin-directory as it is owned by the xchat2vs2005-04-201-1/+0 * - Unquote IGNORE messagenovel2005-04-191-2/+2 * o Update to -> 0.65mich2005-04-182-3/+3 * - Update to 3.2.0sem2005-04-1712-194/+684 * - Update to 4.0sem2005-04-173-7/+23 * - Mark BROKEN on ia64.flz2005-04-152-2/+14 * - Add irc/xchat-ecl-plugin 0.3, a plugin to allow Common Lisp scripting inflz2005-04-144-0/+46 * At Kris's request, back out the MACHINE_ARCH spelling correction untilobrien2005-04-1212-13/+13 * - Update to 5.0.50pav2005-04-122-2/+7 * - Update to 3.2.3pav2005-04-1211-172/+456 * Assist getting more ports working on AMD64 by obeying theobrien2005-04-1112-13/+13 * Fix plist.krion2005-04-114-4/+2 * BROKEN on !i386: Does not buildkris2005-04-111-1/+7 * - utilize OPTIONS, DOCSDIR, DATADIR ...leeym2005-04-103-32/+49 * - Try to remove etc/ircd-ru before ask users to do itleeym2005-04-101-1/+1 * Update to version 0.17markus2005-04-076-10/+10 * - Reset unreachable maintainer (mail bounces)pav2005-04-061-1/+1 * - Update to 0.80.1pav2005-04-065-172/+354 * Update to 5.0.2vs2005-04-042-3/+3 * Update to version 0.16markus2005-04-046-182/+402 * - Update to 1.4.4 [1]hq2005-04-033-7/+8 * Update to 2.4.3.marcus2005-04-033-62/+4 * - Remove submitter's real name.flz2005-04-022-3/+3 * Update to 0.4.4.perky2005-03-212-3/+3 * We don't need tHose anymore.mat2005-03-191-8/+0 * - Update to 2.4.2ahze2005-03-173-4/+5 * - Update to 1.3pav2005-03-175-18/+86 * Update master-sitevs2005-03-164-4/+6 * - Add epic5 0.0.3, a beta release of the popular epic textmode IRC client.flz2005-03-146-1018/+126 * Update to 0.6.1krion2005-03-13