aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authormartymac <martymac@FreeBSD.org>2011-11-25 20:56:22 +0800
committermartymac <martymac@FreeBSD.org>2011-11-25 20:56:22 +0800
commitb7648ae612ac805673206bf797ff157e87f9f75e (patch)
tree00e06ccaef4a189a40f282c4756c949d511791dc /sysutils
parentc70656b082fcc51ece50f16bbed50f45d7d90c1e (diff)
downloadfreebsd-ports-gnome-b7648ae612ac805673206bf797ff157e87f9f75e.tar.gz
freebsd-ports-gnome-b7648ae612ac805673206bf797ff157e87f9f75e.tar.zst
freebsd-ports-gnome-b7648ae612ac805673206bf797ff157e87f9f75e.zip
Add fpart, a tool to sort files and divide them into partitions
Feature safe: yes
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/fpart/Makefile39
-rw-r--r--sysutils/fpart/distinfo2
-rw-r--r--sysutils/fpart/files/patch-Makefile11
-rw-r--r--sysutils/fpart/pkg-descr8
5 files changed, 61 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index c6d7c0a2fd96..504fdec68fa5 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -239,6 +239,7 @@
SUBDIR += fonteditfs
SUBDIR += foremost
SUBDIR += fortunelock
+ SUBDIR += fpart
SUBDIR += fpc-syslog
SUBDIR += fpc-users
SUBDIR += fpc-utmp
diff --git a/sysutils/fpart/Makefile b/sysutils/fpart/Makefile
new file mode 100644
index 000000000000..d65038b86f6f
--- /dev/null
+++ b/sysutils/fpart/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: fpart
+# Date created: 24 Nov 2011
+# Whom: Ganael Laplanche <ganael.laplanche@martymac.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= fpart
+PORTVERSION= 0.2
+CATEGORIES= sysutils
+MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION} \
+ http://contribs.martymac.org/fpart/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= martymac@FreeBSD.org
+COMMENT= Sort files and divide them into partitions
+
+LICENSE= BSD
+
+MANCOMPRESSED= yes
+MAN1= fpart.1
+PLIST_FILES= bin/fpart
+PORTDOCS= Changelog README TODO
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 800067
+BROKEN= needs getline() and strnlen()
+.endif
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+.for doc in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${doc} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/sysutils/fpart/distinfo b/sysutils/fpart/distinfo
new file mode 100644
index 000000000000..436a674f8c85
--- /dev/null
+++ b/sysutils/fpart/distinfo
@@ -0,0 +1,2 @@
+SHA256 (fpart-0.2.tgz) = 20ba0b08d49924065c65258ee15e207a8a716676bbefcdc0f01b7e866120bccc
+SIZE (fpart-0.2.tgz) = 15669
diff --git a/sysutils/fpart/files/patch-Makefile b/sysutils/fpart/files/patch-Makefile
new file mode 100644
index 000000000000..56f13334f818
--- /dev/null
+++ b/sysutils/fpart/files/patch-Makefile
@@ -0,0 +1,11 @@
+--- Makefile.orig 2011-11-25 12:44:43.011993455 +0100
++++ Makefile 2011-11-25 12:44:54.583395080 +0100
+@@ -36,7 +36,7 @@
+
+ # Configuration / variables section
+ DESTDIR=
+-PREFIX= /usr/local
++PREFIX?= /usr/local
+
+ # Default installation paths
+ BINDIR= $(PREFIX)/bin
diff --git a/sysutils/fpart/pkg-descr b/sysutils/fpart/pkg-descr
new file mode 100644
index 000000000000..8700e4bb0430
--- /dev/null
+++ b/sysutils/fpart/pkg-descr
@@ -0,0 +1,8 @@
+Fpart is a tool that helps you sort files and divide them into bags
+("partitions"). It is developped in C and available under the BSD license.
+
+It splits a list of directories and files into a certain number of partitions,
+trying to produce partitions with the same size and number of files. It can
+also produce partitions with a given number of files or a limited size.
+
+WWW: http://contribs.martymac.org