aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authormezz <mezz@FreeBSD.org>2006-06-12 12:58:43 +0800
committermezz <mezz@FreeBSD.org>2006-06-12 12:58:43 +0800
commitb86cc8d4c3812f7f58f2621fdb68c89ce44b1365 (patch)
treef9d882c6238664cc6cb4f6fbae4e5bdb2e1364ee /sysutils
parent73e90e9463c57f1bcaa52ced2bda3fd8af02b294 (diff)
downloadfreebsd-ports-gnome-b86cc8d4c3812f7f58f2621fdb68c89ce44b1365.tar.gz
freebsd-ports-gnome-b86cc8d4c3812f7f58f2621fdb68c89ce44b1365.tar.zst
freebsd-ports-gnome-b86cc8d4c3812f7f58f2621fdb68c89ce44b1365.zip
Use the correct mtree when you change the prefix, for example:
Incorrect: (before) ================================ # cd /usr/ports/x11-toolkits/pango # make -V MTREE_FILE /etc/mtree/BSD.x11-4.dist # make PREFIX=/tmp/foo -V MTREE_FILE /etc/mtree/BSD.local.dist <-- Here... ================================ Correct: (after) ================================ # cd /usr/ports/x11-toolkits/pango # make -V MTREE_FILE /etc/mtree/BSD.x11-4.dist # make PREFIX=/tmp/foo -V MTREE_FILE /etc/mtree/BSD.x11-4.dist <-- Here... ================================
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/system-tools-backends/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/sysutils/system-tools-backends/Makefile b/sysutils/system-tools-backends/Makefile
index e00e9f461568..c2eafe8a0ef1 100644
--- a/sysutils/system-tools-backends/Makefile
+++ b/sysutils/system-tools-backends/Makefile
@@ -32,6 +32,12 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
RUN_DEPENDS+= ${SITE_PERL}/File/Temp.pm:${PORTSDIR}/devel/p5-File-Temp
.endif
+.if ${X_WINDOW_SYSTEM:L} == xfree86-3
+MTREE_FILE= /etc/mtree/BSD.x11.dist
+.else
+MTREE_FILE= /etc/mtree/BSD.x11-4.dist
+.endif
+
.if ${PERL_LEVEL} < 500600
post-configure:
@${FIND} ${WRKSRC} \( -name "*.pl" -or -name "*-conf" \) | \