aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authorpgollucci <pgollucci@FreeBSD.org>2012-03-09 02:45:38 +0800
committerpgollucci <pgollucci@FreeBSD.org>2012-03-09 02:45:38 +0800
commitbdc7b8de9b4a00d6f78b8a20e6e92ad630e44558 (patch)
tree0af98c25fc0d67ccc871639ecd10e8476cfd8de7 /sysutils
parenta72ed0005b1dc840337c91df5cde89b1015c75f8 (diff)
downloadfreebsd-ports-gnome-bdc7b8de9b4a00d6f78b8a20e6e92ad630e44558.tar.gz
freebsd-ports-gnome-bdc7b8de9b4a00d6f78b8a20e6e92ad630e44558.tar.zst
freebsd-ports-gnome-bdc7b8de9b4a00d6f78b8a20e6e92ad630e44558.zip
- Remove ports that only work with < perl 5.12 (devel/p5-B-Size, devel/p5-Devel-Arena)
- Remove conditionals for PERL_LEVEL < 501200 - Remove regression-test targets b/c this will be centralized in Mk/bsd.perl.mk - Other minor cleanups RUN_DEPENDS = ${BUILD_DEPENDS} -> RUN_DEPENDS:= ${BUILD_DEPENDS} PR: ports/165605 Submitted by: pgollucci (myself) Approved by: portmgr (linimon) Exp Run by: linimon Tested by: make index
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/p5-Brackup/Makefile12
-rw-r--r--sysutils/p5-MogileFS-Utils/Makefile11
-rw-r--r--sysutils/p5-Monitor-Simple/Makefile9
-rw-r--r--sysutils/p5-arclog/Makefile10
-rw-r--r--sysutils/p5-reslog/Makefile10
5 files changed, 8 insertions, 44 deletions
diff --git a/sysutils/p5-Brackup/Makefile b/sysutils/p5-Brackup/Makefile
index 750742a483ab..8f8ef18872b7 100644
--- a/sysutils/p5-Brackup/Makefile
+++ b/sysutils/p5-Brackup/Makefile
@@ -54,14 +54,4 @@ MAN3= Brackup.3 \
Brackup::Target::Riak.3 \
Brackup::Target::Sftp.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500905
-RUN_DEPENDS+= p5-File-Temp>=0.17:${PORTSDIR}/devel/p5-File-Temp
-.endif
-
-.if ${PERL_LEVEL} < 501001
-BUILD_DEPENDS+= p5-ExtUtils-Manifest>=1.52:${PORTSDIR}/devel/p5-ExtUtils-Manifest
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/sysutils/p5-MogileFS-Utils/Makefile b/sysutils/p5-MogileFS-Utils/Makefile
index 48b3b1fe58b4..19709acbbd50 100644
--- a/sysutils/p5-MogileFS-Utils/Makefile
+++ b/sysutils/p5-MogileFS-Utils/Makefile
@@ -17,8 +17,7 @@ COMMENT= MogileFS tools
BUILD_DEPENDS= p5-MogileFS-Client>=1.14:${PORTSDIR}/sysutils/p5-MogileFS-Client \
p5-libwww>=0:${PORTSDIR}/www/p5-libwww
-RUN_DEPENDS= p5-MogileFS-Client>=1.14:${PORTSDIR}/sysutils/p5-MogileFS-Client \
- p5-libwww>=0:${PORTSDIR}/www/p5-libwww
+RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
@@ -35,13 +34,7 @@ MAN1= mogadm.1 \
mogupload.1
MAN3= MogileFS::Utils.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 501000
-RUN_DEPENDS+= p5-IO-Compress>=0:${PORTSDIR}/archivers/p5-IO-Compress
-.endif
-
post-patch:
@${REINPLACE_CMD} -e '/NAME/ s|MogileFS-Utils|MogileFS::Utils|' ${WRKSRC}/Makefile.PL
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/sysutils/p5-Monitor-Simple/Makefile b/sysutils/p5-Monitor-Simple/Makefile
index 44cab802662f..2878ea816456 100644
--- a/sysutils/p5-Monitor-Simple/Makefile
+++ b/sysutils/p5-Monitor-Simple/Makefile
@@ -38,11 +38,4 @@ MAN3= Monitor::Simple.3 \
Monitor::Simple::UserAgent.3 \
Monitor::Simple::Utils.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 501001
-BUILD_DEPENDS+= p5-Getopt-Long>=2.38:${PORTSDIR}/devel/p5-Getopt-Long
-RUN_DEPENDS+= p5-Getopt-Long>=2.38:${PORTSDIR}/devel/p5-Getopt-Long
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/sysutils/p5-arclog/Makefile b/sysutils/p5-arclog/Makefile
index 324ec87f1f1e..41ecdf6f630c 100644
--- a/sysutils/p5-arclog/Makefile
+++ b/sysutils/p5-arclog/Makefile
@@ -20,7 +20,7 @@ RUN_DEPENDS= p5-TimeDate>=0:${PORTSDIR}/devel/p5-TimeDate \
p5-Compress-Bzip2>=0:${PORTSDIR}/archivers/p5-Compress-Bzip2 \
p5-File-MMagic>=0:${PORTSDIR}/devel/p5-File-MMagic \
p5-Term-ReadKey>=0:${PORTSDIR}/devel/p5-Term-ReadKey
-BUILD_DEPENDS= ${RUN_DEPENDS}
+BUILD_DEPENDS:= ${RUN_DEPENDS}
PERL_CONFIGURE= yes
MAN1= arclog.1
@@ -29,10 +29,4 @@ PLIST_FILES= bin/arclog \
%%SITE_PERL%%/%%PERL_ARCH%%/auto/arclog/.packlist
PLIST_DIRS= %%SITE_PERL%%/%%PERL_ARCH%%/auto/arclog
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500903
-RUN_DEPENDS+= p5-IO-Compress>=2.017:${PORTSDIR}/archivers/p5-IO-Compress
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/sysutils/p5-reslog/Makefile b/sysutils/p5-reslog/Makefile
index 18d922e207dd..362ce03faf00 100644
--- a/sysutils/p5-reslog/Makefile
+++ b/sysutils/p5-reslog/Makefile
@@ -19,7 +19,7 @@ COMMENT= Reverse-resolve IP in Apache log files
RUN_DEPENDS= p5-Compress-Bzip2>=0:${PORTSDIR}/archivers/p5-Compress-Bzip2 \
p5-File-MMagic>=0:${PORTSDIR}/devel/p5-File-MMagic \
p5-Term-ReadKey>=0:${PORTSDIR}/devel/p5-Term-ReadKey
-BUILD_DEPENDS= ${RUN_DEPENDS}
+BUILD_DEPENDS:= ${RUN_DEPENDS}
PERL_CONFIGURE= yes
MAN1= reslog.1
@@ -28,10 +28,4 @@ PLIST_FILES= bin/reslog \
%%SITE_PERL%%/%%PERL_ARCH%%/auto/reslog/.packlist
PLIST_DIRS= %%SITE_PERL%%/%%PERL_ARCH%%/auto/reslog
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500903
-RUN_DEPENDS+= p5-IO-Compress>=2.017:${PORTSDIR}/archivers/p5-IO-Compress
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>