aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authorthierry <thierry@FreeBSD.org>2004-04-07 03:17:02 +0800
committerthierry <thierry@FreeBSD.org>2004-04-07 03:17:02 +0800
commitca335aa04c0ead2a688d497b1dc9f5a93838288c (patch)
tree0dd4f162e9021696ed87d3cfc9291d14a6f67b28 /sysutils
parented6230128c94c95bc3975c73e12f589851a8dd43 (diff)
downloadfreebsd-ports-gnome-ca335aa04c0ead2a688d497b1dc9f5a93838288c.tar.gz
freebsd-ports-gnome-ca335aa04c0ead2a688d497b1dc9f5a93838288c.tar.zst
freebsd-ports-gnome-ca335aa04c0ead2a688d497b1dc9f5a93838288c.zip
Add pear-Cache 1.5.4, PEAR framework for caching of arbitrary data.
Approved by: pav (mentor).
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/pear-Cache/Makefile28
-rw-r--r--sysutils/pear-Cache/distinfo2
-rw-r--r--sysutils/pear-Cache/pkg-descr5
4 files changed, 36 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index 50e493e74c17..6ad126e298f8 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -263,6 +263,7 @@
SUBDIR += paicc
SUBDIR += pciutils
SUBDIR += pdumpfs
+ SUBDIR += pear-Cache
SUBDIR += pear-File
SUBDIR += pear-File_Find
SUBDIR += pear-Log
diff --git a/sysutils/pear-Cache/Makefile b/sysutils/pear-Cache/Makefile
new file mode 100644
index 000000000000..94dd80b7dbdc
--- /dev/null
+++ b/sysutils/pear-Cache/Makefile
@@ -0,0 +1,28 @@
+# Ports collection makefile for: pear-Cache
+# Date created: 5 April 2004
+# Whom: Thierry Thomas (<thierry@FreeBSD.org>)
+#
+# $FreeBSD$
+#
+
+PORTNAME= Cache
+PORTVERSION= 1.5.4
+CATEGORIES= sysutils www pear
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= PEAR framework for caching of arbitrary data
+
+BUILD_DEPENDS= ${PEARDIR}/HTTP/Request.php:${PORTSDIR}/www/pear-HTTP_Request
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+CATEGORY= Cache
+FILES= Application.php Cache.php Container.php Container/db.php \
+ Container/dbx.php Container/file.php Container/mdb.php \
+ Container/mdb_cache_schema.xml Container/msession.php \
+ Container/phplib.php Container/shm.php Container/trifile.php \
+ Error.php Function.php Graphics.php HTTP_Request.php Output.php \
+ OutputCompression.php
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/devel/pear-PEAR/Makefile.common"
+.include <bsd.port.post.mk>
diff --git a/sysutils/pear-Cache/distinfo b/sysutils/pear-Cache/distinfo
new file mode 100644
index 000000000000..5a9c4cd69102
--- /dev/null
+++ b/sysutils/pear-Cache/distinfo
@@ -0,0 +1,2 @@
+MD5 (PEAR/Cache-1.5.4.tgz) = 1a7698fcfdf9ab63e56bbbff0c76a13d
+SIZE (PEAR/Cache-1.5.4.tgz) = 30690
diff --git a/sysutils/pear-Cache/pkg-descr b/sysutils/pear-Cache/pkg-descr
new file mode 100644
index 000000000000..4155a4ca03ec
--- /dev/null
+++ b/sysutils/pear-Cache/pkg-descr
@@ -0,0 +1,5 @@
+With the PEAR Cache you can cache the result of certain function
+calls, as well as the output of a whole script run or share data
+between applications.
+
+WWW: http://pear.php.net/package/Cache/