aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authoraraujo <araujo@FreeBSD.org>2017-03-17 17:59:15 +0800
committeraraujo <araujo@FreeBSD.org>2017-03-17 17:59:15 +0800
commitd23d8dac7d128df1b57a6b08efa0e094f9a52106 (patch)
tree37e9bf8a4682c7f28f7ea6eef3d099daf75f3054 /sysutils
parent9b64d75a45a80df3839a5b00f6cfe2795d5989e1 (diff)
downloadfreebsd-ports-gnome-d23d8dac7d128df1b57a6b08efa0e094f9a52106.tar.gz
freebsd-ports-gnome-d23d8dac7d128df1b57a6b08efa0e094f9a52106.tar.zst
freebsd-ports-gnome-d23d8dac7d128df1b57a6b08efa0e094f9a52106.zip
iocage is a jail/container manager amalgamating some of the best
features and technologies the FreeBSD operating system has to offer. It is geared for ease of use with a simple and easy to understand command syntax. This is the new and the most updated version of iocage written in python3.6. Submitted by: brandon@ixsystems.com (author and maintainer) via email.
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/py3-iocage/Makefile40
-rw-r--r--sysutils/py3-iocage/distinfo3
-rw-r--r--sysutils/py3-iocage/files/iocage.in47
-rw-r--r--sysutils/py3-iocage/pkg-descr6
5 files changed, 97 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index 12933c882cf2..c36bbdd337c5 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -895,6 +895,7 @@
SUBDIR += py-zdaemon
SUBDIR += py-zfs
SUBDIR += pydf
+ SUBDIR += py3-iocage
SUBDIR += qchroot
SUBDIR += qjail
SUBDIR += qjail2
diff --git a/sysutils/py3-iocage/Makefile b/sysutils/py3-iocage/Makefile
new file mode 100644
index 000000000000..be15ce0d139a
--- /dev/null
+++ b/sysutils/py3-iocage/Makefile
@@ -0,0 +1,40 @@
+# $FreeBSD$
+
+PORTNAME= iocage
+PORTVERSION= 0.9.7
+CATEGORIES= sysutils python
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= brandon@ixsystems.com
+COMMENT= FreeBSD jail manager written in Python3
+
+LICENSE= BSD2CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}click>=6.7:devel/py3-click \
+ ${PYTHON_PKGNAMEPREFIX}tqdm>=4.10.0:misc/py3-tqdm \
+ ca_root_nss>0:security/ca_root_nss \
+ ${PYTHON_PKGNAMEPREFIX}texttable>=0.8.7:textproc/py3-texttable \
+ ${PYTHON_PKGNAMEPREFIX}requests>=2.11.1:www/py3-requests
+
+USE_GITHUB= yes
+
+NO_ARCH= yes
+USES= python:3.6
+USE_PYTHON= autoplist distutils
+
+CONFLICTS= py-iocage-[0-9]* iocage-[0-9]* iocage-devel-[0-9]*
+
+pre-everything::
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} "##################################################"
+ @${ECHO_MSG} " The new iocage needs python ${PYTHON_VER} or greater."
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} " If you want use the new iocage, stop the build now and"
+ @${ECHO_MSG} " add this line to your /etc/make.conf, and then restart the build."
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} " DEFAULT_VERSIONS+=python3=${PYTHON_VER}"
+ @${ECHO_MSG} "##################################################"
+ @${ECHO_MSG} ""
+
+.include <bsd.port.mk>
diff --git a/sysutils/py3-iocage/distinfo b/sysutils/py3-iocage/distinfo
new file mode 100644
index 000000000000..3cae61ad50ae
--- /dev/null
+++ b/sysutils/py3-iocage/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1489549714
+SHA256 (iocage-iocage-0.9.7_GH0.tar.gz) = 76dab74df5f9d8b169924fcc0addaa1a291a8274bf6e0e222fb5d62425456a72
+SIZE (iocage-iocage-0.9.7_GH0.tar.gz) = 325256
diff --git a/sysutils/py3-iocage/files/iocage.in b/sysutils/py3-iocage/files/iocage.in
new file mode 100644
index 000000000000..0041f8d7a37f
--- /dev/null
+++ b/sysutils/py3-iocage/files/iocage.in
@@ -0,0 +1,47 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+
+# PROVIDE: iocage
+# REQUIRE: LOGIN cleanvar sshd ZFS
+# BEFORE: securelevel
+# KEYWORD: shutdown
+
+# Add the following lines to /etc/rc.conf to enable iocage:
+#
+# iocage_enable="YES"
+#
+#
+
+. /etc/rc.subr
+
+name="iocage"
+rcvar=iocage_enable
+
+# read configuration and set defaults
+load_rc_config "$name"
+: ${iocage_enable="NO"}
+: ${iocage_lang="en_US.UTF-8"}
+
+start_cmd="iocage_start"
+stop_cmd="iocage_stop"
+export LANG=$iocage_lang
+
+iocage_start()
+{
+ if checkyesno ${rcvar}; then
+ echo "* [I|O|C] starting jails... "
+ /usr/local/bin/iocage start --rc
+ fi
+}
+
+iocage_stop()
+{
+ if checkyesno ${rcvar}; then
+ echo "* [I|O|C] stopping jails... "
+ /usr/local/bin/iocage stop --rc
+ fi
+}
+
+run_rc_command "$1"
diff --git a/sysutils/py3-iocage/pkg-descr b/sysutils/py3-iocage/pkg-descr
new file mode 100644
index 000000000000..bbd20fe4a985
--- /dev/null
+++ b/sysutils/py3-iocage/pkg-descr
@@ -0,0 +1,6 @@
+iocage is a jail/container manager amalgamating some of the best
+features and technologies the FreeBSD operating system has
+to offer. It is geared for ease of use with a simple and easy
+to understand command syntax.
+
+WWW: https://github.com/iocage/iocage