aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authorsobomax <sobomax@FreeBSD.org>2001-07-04 02:13:14 +0800
committersobomax <sobomax@FreeBSD.org>2001-07-04 02:13:14 +0800
commitd79f87a1b872132d106b5e8d977a16a54d148b28 (patch)
treee4bac8ef052d933ced950cb5068d430bc622d9d1 /sysutils
parentd4041d6109dba8643ba91bb2de3b57b0832e1173 (diff)
downloadfreebsd-ports-gnome-d79f87a1b872132d106b5e8d977a16a54d148b28.tar.gz
freebsd-ports-gnome-d79f87a1b872132d106b5e8d977a16a54d148b28.tar.zst
freebsd-ports-gnome-d79f87a1b872132d106b5e8d977a16a54d148b28.zip
Add e2fsprogs 1.22, a set of utilities and library to manipulate an ext2
filesystem. WARNING: The sole reason why I'm adding this port is to allow me upgrade gnomeutils port to the latest version. For some very strange reason this new version requires libext2fs to build. The only thing I know for sure about e2fsprogs is that it compiles cleanly on 4-STABLE and 5-CURRENT systems - I have not tested it in action. Please use it with extremal precaution, because due to its low-level nature and Linux roots it can do Very Bad Things[tm] to your data, set fire on your house, kill your cat or something else even more horrible. If someone wants to take over maintainership please feel free to do so.
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/e2fsprogs/Makefile37
-rw-r--r--sysutils/e2fsprogs/distinfo1
-rw-r--r--sysutils/e2fsprogs/files/patch-MCONFIG.in25
-rw-r--r--sysutils/e2fsprogs/files/patch-Makefile.in18
-rw-r--r--sysutils/e2fsprogs/files/patch-debugfs::Makefile.in26
-rw-r--r--sysutils/e2fsprogs/files/patch-e2fsck::journal.c14
-rw-r--r--sysutils/e2fsprogs/files/patch-lib::Makefile.elf-lib22
-rw-r--r--sysutils/e2fsprogs/files/patch-lib::ext2fs::Makefile.in14
-rw-r--r--sysutils/e2fsprogs/files/patch-lib::ext2fs::flushb.c13
-rw-r--r--sysutils/e2fsprogs/pkg-comment1
-rw-r--r--sysutils/e2fsprogs/pkg-descr3
-rw-r--r--sysutils/e2fsprogs/pkg-plist41
13 files changed, 216 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index 251242b10375..dc1c5f02094f 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -40,6 +40,7 @@
SUBDIR += doconfig
SUBDIR += du2ps
SUBDIR += dvdtape
+ SUBDIR += e2fsprogs
SUBDIR += eject
SUBDIR += extipl
SUBDIR += fcron
diff --git a/sysutils/e2fsprogs/Makefile b/sysutils/e2fsprogs/Makefile
new file mode 100644
index 000000000000..1b2ced2d7c7e
--- /dev/null
+++ b/sysutils/e2fsprogs/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: e2fsprogs
+# Date created: 3 July 2001
+# Whom: Maxim Sobolev <sobomax@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= e2fsprogs
+PORTVERSION= 1.22
+CATEGORIES= sysutils
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= ports@FreeBSD.org
+
+USE_GMAKE= yes
+INSTALLS_SHLIB= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --enable-elf-shlibs
+CONFIGURE_ENV= CPPFLAGS="-I/usr/include -I${LOCALBASE}/include \
+ -Derrcode_t=long" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+MAN1= chattr.1 lsattr.1 uuidgen.1
+MAN8= badblocks.8 debugfs.8 dumpe2fs.8 e2fsck.8 e2image.8 e2label.8 fsck.8 \
+ mke2fs.8 mklost+found.8 resize2fs.8 tune2fs.8
+
+post-patch:
+ @find ${WRKSRC} -name "*.[ch]" | xargs ${PERL} -pi -e \
+ 's|LIST_HEAD|LIN_LST_HEAD|g ; \
+ s|et/com_err.h|com_err.h|g'
+
+post-install:
+ ${MKDIR} ${PREFIX}/include/ext2fs
+ ${INSTALL_DATA} ${WRKSRC}/lib/ext2fs/*.h ${PREFIX}/include/ext2fs
+
+.include <bsd.port.mk>
diff --git a/sysutils/e2fsprogs/distinfo b/sysutils/e2fsprogs/distinfo
new file mode 100644
index 000000000000..f75e84eee072
--- /dev/null
+++ b/sysutils/e2fsprogs/distinfo
@@ -0,0 +1 @@
+MD5 (e2fsprogs-1.22.tar.gz) = a2b689fda4e954df0258c2605bc65d9b
diff --git a/sysutils/e2fsprogs/files/patch-MCONFIG.in b/sysutils/e2fsprogs/files/patch-MCONFIG.in
new file mode 100644
index 000000000000..21bdc912776c
--- /dev/null
+++ b/sysutils/e2fsprogs/files/patch-MCONFIG.in
@@ -0,0 +1,25 @@
+
+$FreeBSD$
+
+--- MCONFIG.in.orig Sat Jun 23 07:25:59 2001
++++ MCONFIG.in Tue Jul 3 18:29:41 2001
+@@ -57,15 +57,15 @@
+ # Library definitions
+ #
+ LIB = $(top_builddir)/lib
+-LIBSS = $(LIB)/libss@LIB_EXT@
+-LIBCOM_ERR = $(LIB)/libcom_err@LIB_EXT@
++LIBSS = /usr/lib/libss.so
++LIBCOM_ERR = /usr/lib/libcom_err.so
+ LIBE2P = $(LIB)/libe2p@LIB_EXT@
+ LIBEXT2FS = $(LIB)/libext2fs@LIB_EXT@
+ LIBUUID = $(LIB)/libuuid@LIB_EXT@ @SOCKET_LIB@
+ DEPLIBUUID = $(LIB)/libuuid@LIB_EXT@
+
+-STATIC_LIBSS = $(LIB)/libss@STATIC_LIB_EXT@
+-STATIC_LIBCOM_ERR = $(LIB)/libcom_err@STATIC_LIB_EXT@
++STATIC_LIBSS = /usr/lib/libss.a
++STATIC_LIBCOM_ERR = /usr/lib/libcom_err.a
+ STATIC_LIBE2P = $(LIB)/libe2p@STATIC_LIB_EXT@
+ STATIC_LIBEXT2FS = $(LIB)/libext2fs@STATIC_LIB_EXT@
+ STATIC_LIBUUID = $(LIB)/libuuid@STATIC_LIB_EXT@ @SOCKET_LIB@
diff --git a/sysutils/e2fsprogs/files/patch-Makefile.in b/sysutils/e2fsprogs/files/patch-Makefile.in
new file mode 100644
index 000000000000..51c7fdbe0037
--- /dev/null
+++ b/sysutils/e2fsprogs/files/patch-Makefile.in
@@ -0,0 +1,18 @@
+
+$FreeBSD$
+
+--- Makefile.in.orig Sat Jun 23 07:25:59 2001
++++ Makefile.in Tue Jul 3 18:51:42 2001
+@@ -10,9 +10,9 @@
+ @RESIZER_CMT@RESIZE_DIR= resize
+ @DEBUGFS_CMT@DEBUGFS_DIR= debugfs
+
+-LIB_SUBDIRS=lib/et lib/ss lib/e2p lib/ext2fs lib/uuid # lib/finddev
+-PROG_SUBDIRS=e2fsck $(DEBUGFS_DIR) misc $(RESIZE_DIR) tests/progs
+-SUBDIRS=util $(LIB_SUBDIRS) $(PROG_SUBDIRS) tests
++LIB_SUBDIRS=lib/e2p lib/ext2fs lib/uuid # lib/finddev
++PROG_SUBDIRS=e2fsck $(DEBUGFS_DIR) misc $(RESIZE_DIR)
++SUBDIRS=util $(LIB_SUBDIRS) $(PROG_SUBDIRS)
+
+ SUBS= lib/ext2fs/ext2_types.h
+
diff --git a/sysutils/e2fsprogs/files/patch-debugfs::Makefile.in b/sysutils/e2fsprogs/files/patch-debugfs::Makefile.in
new file mode 100644
index 000000000000..ba4235916a3b
--- /dev/null
+++ b/sysutils/e2fsprogs/files/patch-debugfs::Makefile.in
@@ -0,0 +1,26 @@
+
+$FreeBSD$
+
+--- debugfs/Makefile.in.orig Sat Jun 23 07:25:59 2001
++++ debugfs/Makefile.in Tue Jul 3 18:49:18 2001
+@@ -14,7 +14,7 @@
+ PROGS= debugfs
+ MANPAGES= debugfs.8
+
+-MK_CMDS= _SS_DIR_OVERRIDE=../lib/ss ../lib/ss/mk_cmds
++MK_CMDS= mk_cmds
+
+ DEBUG_OBJS= debug_cmds.o debugfs.o util.o ncheck.o icheck.o ls.o \
+ lsdel.o dump.o setsuper.o logdump.o
+@@ -75,9 +75,9 @@
+ # the Makefile.in file
+ #
+ debug_cmds.o: debug_cmds.c $(top_srcdir)/lib/ss/ss.h \
+- $(top_builddir)/lib/ss/ss_err.h
++
+ debugfs.o: $(srcdir)/debugfs.c $(top_srcdir)/lib/et/com_err.h \
+- $(top_srcdir)/lib/ss/ss.h $(top_builddir)/lib/ss/ss_err.h \
++ $(top_srcdir)/lib/ss/ss.h \
+ $(srcdir)/debugfs.h $(top_srcdir)/lib/ext2fs/ext2_fs.h \
+ $(top_builddir)/lib/ext2fs/ext2_types.h $(top_srcdir)/lib/ext2fs/ext2fs.h \
+ $(top_srcdir)/lib/ext2fs/ext2_io.h $(top_builddir)/lib/ext2fs/ext2_err.h \
diff --git a/sysutils/e2fsprogs/files/patch-e2fsck::journal.c b/sysutils/e2fsprogs/files/patch-e2fsck::journal.c
new file mode 100644
index 000000000000..9a9487822579
--- /dev/null
+++ b/sysutils/e2fsprogs/files/patch-e2fsck::journal.c
@@ -0,0 +1,14 @@
+
+$FreeBSD$
+
+--- e2fsck/journal.c 2001/07/03 14:35:01 1.1
++++ e2fsck/journal.c 2001/07/03 14:35:13
+@@ -13,6 +13,8 @@
+ */
+
+ #ifdef HAVE_SYS_MOUNT_H
++#include <sys/param.h>
++#include <sys/types.h>
+ #include <sys/mount.h>
+ #define MNT_FL (MS_MGC_VAL | MS_RDONLY)
+ #endif
diff --git a/sysutils/e2fsprogs/files/patch-lib::Makefile.elf-lib b/sysutils/e2fsprogs/files/patch-lib::Makefile.elf-lib
new file mode 100644
index 000000000000..bb0a6f80de4d
--- /dev/null
+++ b/sysutils/e2fsprogs/files/patch-lib::Makefile.elf-lib
@@ -0,0 +1,22 @@
+
+$FreeBSD$
+
+--- lib/Makefile.elf-lib.orig Sat Jun 23 07:25:59 2001
++++ lib/Makefile.elf-lib Tue Jul 3 18:57:04 2001
+@@ -39,13 +39,12 @@
+ installdirs:: installdirs-elf-lib
+
+ install-shlibs install:: $(ELF_LIB) installdirs-elf-lib
+- $(INSTALL_PROGRAM) $(ELF_LIB) $(DESTDIR)$(ELF_INSTALL_DIR)/$(ELF_LIB)
++ $(INSTALL_PROGRAM) $(ELF_LIB) $(DESTDIR)$(ELF_INSTALL_DIR)/$(ELF_SONAME)
++ $(INSTALL_DATA) $(ELF_IMAGE).a $(DESTDIR)$(ELF_INSTALL_DIR)/
+ $(STRIP) --strip-debug \
+- $(DESTDIR)$(ELF_INSTALL_DIR)/$(ELF_LIB)
+- $(LN_S) -f $(ELF_LIB) $(DESTDIR)$(ELF_INSTALL_DIR)/$(ELF_SONAME)
++ $(DESTDIR)$(ELF_INSTALL_DIR)/$(ELF_SONAME)
+ $(LN_S) -f $(ELF_INSTALL_DIR)/$(ELF_SONAME) \
+ $(DESTDIR)$(libdir)/$(ELF_IMAGE).so
+- -$(LDCONFIG)
+
+ uninstall-shlibs uninstall::
+ $(RM) -f $(DESTDIR)$(ELF_INSTALL_DIR)/$(ELF_LIB) \
diff --git a/sysutils/e2fsprogs/files/patch-lib::ext2fs::Makefile.in b/sysutils/e2fsprogs/files/patch-lib::ext2fs::Makefile.in
new file mode 100644
index 000000000000..ac516f420cea
--- /dev/null
+++ b/sysutils/e2fsprogs/files/patch-lib::ext2fs::Makefile.in
@@ -0,0 +1,14 @@
+
+$FreeBSD$
+
+--- lib/ext2fs/Makefile.in 2001/07/03 15:30:54 1.1
++++ lib/ext2fs/Makefile.in 2001/07/03 15:31:07
+@@ -156,7 +156,7 @@
+ @ELF_CMT@ $(CC) $(ALL_CFLAGS) -fPIC -o elfshared/$*.o -c $<
+ @BSDLIB_CMT@ $(CC) $(ALL_CFLAGS) -fpic -o pic/$*.o -c $<
+
+-COMPILE_ET=../et/compile_et
++COMPILE_ET=compile_et
+
+ DISTFILES= Makefile *.c *.h image
+
diff --git a/sysutils/e2fsprogs/files/patch-lib::ext2fs::flushb.c b/sysutils/e2fsprogs/files/patch-lib::ext2fs::flushb.c
new file mode 100644
index 000000000000..b7ef006a8a36
--- /dev/null
+++ b/sysutils/e2fsprogs/files/patch-lib::ext2fs::flushb.c
@@ -0,0 +1,13 @@
+
+$FreeBSD$
+
+--- lib/ext2fs/flushb.c 2001/07/03 14:28:59 1.1
++++ lib/ext2fs/flushb.c 2001/07/03 14:30:57
+@@ -21,6 +21,7 @@
+ #include <sys/ioctl.h>
+ #endif
+ #if HAVE_SYS_MOUNT_H
++#include <sys/param.h>
+ #include <sys/mount.h> /* This may define BLKFLSBUF */
+ #endif
+
diff --git a/sysutils/e2fsprogs/pkg-comment b/sysutils/e2fsprogs/pkg-comment
new file mode 100644
index 000000000000..436bb0f0874b
--- /dev/null
+++ b/sysutils/e2fsprogs/pkg-comment
@@ -0,0 +1 @@
+A set of utilities and library to manipulate an ext2 filesystem
diff --git a/sysutils/e2fsprogs/pkg-descr b/sysutils/e2fsprogs/pkg-descr
new file mode 100644
index 000000000000..139744bdee2a
--- /dev/null
+++ b/sysutils/e2fsprogs/pkg-descr
@@ -0,0 +1,3 @@
+Set of utilities and library to manipulate an ext2 filesystem.
+
+WWW: http://e2fsprogs.sourceforge.net/
diff --git a/sysutils/e2fsprogs/pkg-plist b/sysutils/e2fsprogs/pkg-plist
new file mode 100644
index 000000000000..ec2c0836c14c
--- /dev/null
+++ b/sysutils/e2fsprogs/pkg-plist
@@ -0,0 +1,41 @@
+bin/chattr
+bin/lsattr
+bin/uuidgen
+include/ext2fs/bitops.h
+include/ext2fs/brel.h
+include/ext2fs/dosio.h
+include/ext2fs/e2image.h
+include/ext2fs/ext2_err.h
+include/ext2fs/ext2_fs.h
+include/ext2fs/ext2_io.h
+include/ext2fs/ext2_types.h
+include/ext2fs/ext2fs.h
+include/ext2fs/ext2fsP.h
+include/ext2fs/irel.h
+include/ext2fs/jfs_dat.h
+include/ext2fs/jfs_user.h
+info/libext2fs.info.gz
+lib/libe2p.a
+lib/libe2p.so
+lib/libe2p.so.2
+lib/libext2fs.a
+lib/libext2fs.so
+lib/libext2fs.so.2
+lib/libuuid.a
+lib/libuuid.so
+lib/libuuid.so.1
+sbin/badblocks
+sbin/debugfs
+sbin/dumpe2fs
+sbin/e2fsck
+sbin/e2image
+sbin/e2label
+sbin/fsck
+sbin/fsck.ext2
+sbin/fsck.ext3
+sbin/mke2fs
+sbin/mkfs.ext2
+sbin/mklost+found
+sbin/resize2fs
+sbin/tune2fs
+@dirrm include/ext2fs