aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authortobik <tobik@FreeBSD.org>2017-07-25 19:46:38 +0800
committertobik <tobik@FreeBSD.org>2017-07-25 19:46:38 +0800
commitdfe92b184ed6c428d23b62635ae08eaf9026c576 (patch)
treedf9798a40a0d27b7ac29d2a66a1a9bfe53319cfd /sysutils
parent3030c20bd3fca916afcaf0688cdb250a88528c57 (diff)
downloadfreebsd-ports-gnome-dfe92b184ed6c428d23b62635ae08eaf9026c576.tar.gz
freebsd-ports-gnome-dfe92b184ed6c428d23b62635ae08eaf9026c576.tar.zst
freebsd-ports-gnome-dfe92b184ed6c428d23b62635ae08eaf9026c576.zip
sysutils/xe: Update to 0.9
Changes: https://github.com/chneukirchen/xe/blob/v0.9/NEWS.md
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/xe/Makefile2
-rw-r--r--sysutils/xe/distinfo6
-rw-r--r--sysutils/xe/files/patch-tests35
-rw-r--r--sysutils/xe/files/patch-xe.c12
4 files changed, 23 insertions, 32 deletions
diff --git a/sysutils/xe/Makefile b/sysutils/xe/Makefile
index 2489cf106c8e..f95008be69c4 100644
--- a/sysutils/xe/Makefile
+++ b/sysutils/xe/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= xe
-PORTVERSION= 0.7.0
+PORTVERSION= 0.9
DISTVERSIONPREFIX= v
CATEGORIES= sysutils
diff --git a/sysutils/xe/distinfo b/sysutils/xe/distinfo
index e292e52d6757..d7dc0217bf73 100644
--- a/sysutils/xe/distinfo
+++ b/sysutils/xe/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1492163693
-SHA256 (chneukirchen-xe-v0.7.0_GH0.tar.gz) = 32af920a2d27ed0bb8bcb69339fcc805110888e872c92a372d3888df52b300f8
-SIZE (chneukirchen-xe-v0.7.0_GH0.tar.gz) = 7047
+TIMESTAMP = 1500981663
+SHA256 (chneukirchen-xe-v0.9_GH0.tar.gz) = 0e72bafd0d5c30953ef7a5dca710296aec621a60fb62c0aaf7ee2af5e68c2ac2
+SIZE (chneukirchen-xe-v0.9_GH0.tar.gz) = 8444
diff --git a/sysutils/xe/files/patch-tests b/sysutils/xe/files/patch-tests
index e27bf41912c6..f5017fb3e03a 100644
--- a/sysutils/xe/files/patch-tests
+++ b/sysutils/xe/files/patch-tests
@@ -1,48 +1,39 @@
Fix tests
-- -A% with no arguments fails now with the additional checks in 0.7.0
- Trying to exec /dev/null/calc.exe on FreeBSD will fail with ENOENT
(xe exit 127) but on Linux fails with ENODIR (xe exit 126)
- The argscap check returns 8186 + 8186 + 1339 = 17711 on FreeBSD,
which should be fine.
---- tests.orig 2017-04-13 15:28:38 UTC
+--- tests.orig 2017-07-17 14:20:26 UTC
+++ tests
-@@ -1,5 +1,5 @@
- #!/bin/sh
--printf '1..42\n'
-+printf '1..41\n'
-
- set -e
+@@ -194,7 +194,7 @@ check_output 'using -LL' '{ echo 1; sleep 1; echo 2; s
+ EOF
-@@ -127,9 +127,6 @@ check_output 'using -A%' '$XE -A% echo -
- -- 3
+ check_output 'using -vvL' '{ echo 1; sleep 1; echo 2; sleep 1; echo 3; } | xe -j2 -vvL -s "printf \$1; sleep 1; echo \$1" | wc -l' <<EOF
+-9
++ 9
EOF
--check_output 'using -A% with no arguments' '$XE -A% echo' <<EOF
--EOF
--
- check_output 'using -A% with no command' '$XE -N2 -A% % 1 2 3' <<EOF
- 1
- 2
-@@ -196,7 +193,7 @@ check_output 'exit code when process was
+ printf '# error handling\n'
+@@ -219,7 +219,7 @@ check_output 'exit code when process was killed' 'nech
125
EOF
--check_output 'exit code when command cannot be run' 'necho a | $XE /dev/null/calc.exe 2>/dev/null || echo $?' <<EOF
-+check_output 'exit code when command cannot be run' 'necho a | $XE /dev/null 2>/dev/null || echo $?' <<EOF
+-check_output 'exit code when command cannot be run' 'necho a | xe /dev/null/calc.exe 2>/dev/null || echo $?' <<EOF
++check_output 'exit code when command cannot be run' 'necho a | xe /dev/null 2>/dev/null || echo $?' <<EOF
126
EOF
-@@ -236,10 +233,8 @@ EOF
+@@ -265,10 +265,8 @@ EOF
printf '# limit checks, expecting maximal POSIX limits available\n'
--check_output 'argscap check' 'head -c 17711 /dev/zero | tr "\0" "\012" | $XE -N0 -s "echo \$#"' <<EOF
+-check_output 'argscap check' 'head -c 17711 /dev/zero | tr "\0" "\012" | xe -N0 -s "echo \$#"' <<EOF
-8187
-8187
-1337
-+check_output 'argscap check' 'head -c 17711 /dev/zero | tr "\0" "\012" | $XE -N0 -s "echo \$#" | awk "{sum+=\$0}END{print sum}"' <<EOF
++check_output 'argscap check' 'head -c 17711 /dev/zero | tr "\0" "\012" | xe -N0 -s "echo \$#" | awk "{sum+=\$0}END{print sum}"' <<EOF
+17711
EOF
diff --git a/sysutils/xe/files/patch-xe.c b/sysutils/xe/files/patch-xe.c
index 7e3e0287073d..4bbe18b03f33 100644
--- a/sysutils/xe/files/patch-xe.c
+++ b/sysutils/xe/files/patch-xe.c
@@ -1,6 +1,6 @@
---- xe.c.orig 2017-04-13 15:28:38 UTC
+--- xe.c.orig 2017-07-17 14:20:26 UTC
+++ xe.c
-@@ -12,6 +12,7 @@
+@@ -13,6 +13,7 @@
#include <limits.h>
#include <errno.h>
@@ -8,16 +8,16 @@
#include <stdio.h>
#include <stdlib.h>
#include <string.h>
-@@ -99,7 +100,7 @@ mywait()
+@@ -114,7 +115,7 @@ my_child:
} else if (WEXITSTATUS(status) > 125) {
exit(WEXITSTATUS(status));
}
- } else if (WIFSIGNALED(status)) {
+ } else if (WIFSIGNALED(status) && !(fflag && WTERMSIG(status) == SIGPIPE)) {
- fprintf(stderr, "xe: pid %d terminated by signal %d\n",
- pid, WTERMSIG(status));
+ fprintf(stderr, "xe: job %ld [pid %ld] terminated by signal %d\n",
+ children[i].iter, (long)pid, WTERMSIG(status));
exit(125);
-@@ -358,6 +359,7 @@ main(int argc, char *argv[], char *envp[
+@@ -472,6 +473,7 @@ main(int argc, char *argv[], char *envp[])
pusharg("/bin/sh");
pusharg("-c");
pusharg(sflag);