aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2008-09-27 07:30:17 +0800
committermiwi <miwi@FreeBSD.org>2008-09-27 07:30:17 +0800
commite06051e7e97c00bdfb6999f3dbce62208a116cd5 (patch)
tree3fb6f8606df0a066b302a1a7139ad2c60328845c /sysutils
parent0947b1e5020a2c466e48ca821e1b08d0de5d9dbf (diff)
downloadfreebsd-ports-gnome-e06051e7e97c00bdfb6999f3dbce62208a116cd5.tar.gz
freebsd-ports-gnome-e06051e7e97c00bdfb6999f3dbce62208a116cd5.tar.zst
freebsd-ports-gnome-e06051e7e97c00bdfb6999f3dbce62208a116cd5.zip
Tool intended to prevent the accidental deletion of important files
by replacing /bin/rm with a wrapper, which checks the given arguments against a configurable blacklist of files and directories that should never be removed. WWW: http://code.google.com/p/safe-rm/ PR: ports/127332 Submitted by: Yi-Jheng Lin <yzlin at cs.nctu.edu.tw>
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/safe-rm/Makefile32
-rw-r--r--sysutils/safe-rm/distinfo3
-rw-r--r--sysutils/safe-rm/pkg-descr6
4 files changed, 42 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index cd68a6652b26..fa24fa025a7b 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -632,6 +632,7 @@
SUBDIR += rubygem-god
SUBDIR += runit
SUBDIR += runwhen
+ SUBDIR += safe-rm
SUBDIR += safecat
SUBDIR += samefile
SUBDIR += sarah
diff --git a/sysutils/safe-rm/Makefile b/sysutils/safe-rm/Makefile
new file mode 100644
index 000000000000..99815f5bfad5
--- /dev/null
+++ b/sysutils/safe-rm/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: safe-rm
+# Date created: 2008-09-13
+# Whom: Yi-Jheng Lin <yzlin@cs.nctu.edu.tw>
+#
+# $FreeBSD$
+#
+
+PORTNAME= safe-rm
+PORTVERSION= 0.3
+CATEGORIES= sysutils
+MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
+
+MAINTAINER= yzlin@cs.nctu.edu.tw
+COMMENT= Wrapper around the rm command to prevent accidental deletions
+
+USE_PERL5_RUN= yes
+
+NO_BUILD= yes
+
+PORTDOCS= COPYING Changes README
+PLIST_FILES= bin/safe-rm
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/safe-rm ${PREFIX}/bin
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_MAN} ${PORTDOCS:S,^,${WRKSRC}/,} ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/sysutils/safe-rm/distinfo b/sysutils/safe-rm/distinfo
new file mode 100644
index 000000000000..b6e0e6d4a505
--- /dev/null
+++ b/sysutils/safe-rm/distinfo
@@ -0,0 +1,3 @@
+MD5 (safe-rm-0.3.tar.gz) = 3df0f9b0caf75f2f22797b83a58ca24e
+SHA256 (safe-rm-0.3.tar.gz) = f9d1cc2d0aad9fb7067fb817bb003c010b132c88d2d5962e44e9d82dcb4e1e36
+SIZE (safe-rm-0.3.tar.gz) = 14674
diff --git a/sysutils/safe-rm/pkg-descr b/sysutils/safe-rm/pkg-descr
new file mode 100644
index 000000000000..0138f7f6eb98
--- /dev/null
+++ b/sysutils/safe-rm/pkg-descr
@@ -0,0 +1,6 @@
+Tool intended to prevent the accidental deletion of important files
+by replacing /bin/rm with a wrapper, which checks the given arguments
+against a configurable blacklist of files and directories that should
+never be removed.
+
+WWW: http://code.google.com/p/safe-rm/