aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2009-01-16 12:46:57 +0800
committermarcus <marcus@FreeBSD.org>2009-01-16 12:46:57 +0800
commite37f5a3eafb465331595d336bd70fc80a57810b0 (patch)
tree695c1ff4d0de0437aed10007a7a8e877177083c2 /sysutils
parentd7b8b00d26439b7394e987e35c85497fc93b8efc (diff)
downloadfreebsd-ports-gnome-e37f5a3eafb465331595d336bd70fc80a57810b0.tar.gz
freebsd-ports-gnome-e37f5a3eafb465331595d336bd70fc80a57810b0.tar.zst
freebsd-ports-gnome-e37f5a3eafb465331595d336bd70fc80a57810b0.zip
Fix detection of media on FreeBSD. There are still some issues with brasero,
but hopefully they will be worked out soon. Reported by: Alexander Logvinov <freebsd@akavia.ru>
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/brasero/Makefile4
-rw-r--r--sysutils/brasero/files/patch-src_scsi-cam.c22
2 files changed, 24 insertions, 2 deletions
diff --git a/sysutils/brasero/Makefile b/sysutils/brasero/Makefile
index f610f498a261..13a5d717b95d 100644
--- a/sysutils/brasero/Makefile
+++ b/sysutils/brasero/Makefile
@@ -7,7 +7,7 @@
PORTNAME= brasero
PORTVERSION= 0.8.4
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= sysutils audio multimedia gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/${PORTNAME}/${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\1/}
@@ -28,7 +28,7 @@ USE_GSTREAMER= gconf core
INSTALLS_OMF= yes
INSTALLS_ICONS= yes
CONFIGURE_ARGS= --disable-inotify
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -DHAVE_CAM_LIB_H=1" \
LDFLAGS="-L${LOCALBASE}/lib"
MAN1= brasero.1
diff --git a/sysutils/brasero/files/patch-src_scsi-cam.c b/sysutils/brasero/files/patch-src_scsi-cam.c
new file mode 100644
index 000000000000..74546979f326
--- /dev/null
+++ b/sysutils/brasero/files/patch-src_scsi-cam.c
@@ -0,0 +1,22 @@
+--- src/scsi-cam.c.orig 2009-01-13 21:35:42.000000000 -0500
++++ src/scsi-cam.c 2009-01-13 21:36:01.000000000 -0500
+@@ -62,7 +62,7 @@ typedef struct _BraseroScsiCmd BraseroSc
+ #define BRASERO_SCSI_CMD_OPCODE_OFF 0
+ #define BRASERO_SCSI_CMD_SET_OPCODE(command) (command->cmd [BRASERO_SCSI_CMD_OPCODE_OFF] = command->info->opcode)
+
+-#define OPEN_FLAGS O_RDWR /*|O_EXCL */|O_NONBLOCK
++#define OPEN_FLAGS O_RDONLY /*|O_EXCL */|O_NONBLOCK
+
+ BraseroScsiResult
+ brasero_scsi_command_issue_sync (gpointer command,
+@@ -158,8 +158,8 @@ brasero_device_handle_open (const gchar
+
+ g_assert (path != NULL);
+
+- if (exclusive)
+- flags |= O_EXCL;
++/* if (exclusive)
++ flags |= O_EXCL;*/
+
+ /* cam_open_device() fails unless we use O_RDWR */
+ cam = cam_open_device (path, O_RDWR);