aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authordanilo <danilo@FreeBSD.org>2018-09-03 01:41:41 +0800
committerdanilo <danilo@FreeBSD.org>2018-09-03 01:41:41 +0800
commite51ec22b3f8945edd4b4ab70de9e145342afe231 (patch)
tree9277756c174394131851f4b1c9c8da93a7de1ae4 /sysutils
parent6313b79b4afa6b13d75d0f39a68ef18599f6a4c8 (diff)
downloadfreebsd-ports-gnome-e51ec22b3f8945edd4b4ab70de9e145342afe231.tar.gz
freebsd-ports-gnome-e51ec22b3f8945edd4b4ab70de9e145342afe231.tar.zst
freebsd-ports-gnome-e51ec22b3f8945edd4b4ab70de9e145342afe231.zip
- Update to 0.1.1
- Use GO_* variables to simplify the Makefile
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/eksctl/Makefile17
-rw-r--r--sysutils/eksctl/distinfo6
-rw-r--r--sysutils/eksctl/files/patch-pkg_eks_auth.go11
-rw-r--r--sysutils/eksctl/files/patch-pkg_utils_kubectl.go45
4 files changed, 7 insertions, 72 deletions
diff --git a/sysutils/eksctl/Makefile b/sysutils/eksctl/Makefile
index c21bde871d60..d9ec7e53b45a 100644
--- a/sysutils/eksctl/Makefile
+++ b/sysutils/eksctl/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= eksctl
-PORTVERSION= 0.1.0
+PORTVERSION= 0.1.1
CATEGORIES= sysutils
MAINTAINER= danilo@FreeBSD.org
@@ -19,20 +19,11 @@ USES= go
USE_GITHUB= yes
GH_ACCOUNT= weaveworks
-GH_SUBDIR= src/github.com/weaveworks/${PORTNAME}
PLIST_FILES= bin/${PORTNAME}
-do-build:
- cd ${WRKSRC}/${GH_SUBDIR} && \
- GOPATH=${WRKSRC} go build \
- -ldflags="-X main.gitCommit=${PORTVERSION} \
- -X main.builtAt=$$(date +'%s')" \
- ./cmd/${PORTNAME}
-
-do-install:
- ${INSTALL_PROGRAM} \
- ${WRKSRC}/${PORTNAME} \
- ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
+GO_PKGNAME= github.com/weaveworks/${PORTNAME}
+GO_TARGET= ${GO_PKGNAME}/cmd/${PORTNAME}
+GO_BUILDFLAGS= -ldflags="-X main.gitCommit=${PORTVERSION}"
.include <bsd.port.mk>
diff --git a/sysutils/eksctl/distinfo b/sysutils/eksctl/distinfo
index 5f83098242d2..fc213498d464 100644
--- a/sysutils/eksctl/distinfo
+++ b/sysutils/eksctl/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1534530868
-SHA256 (weaveworks-eksctl-0.1.0_GH0.tar.gz) = 81ed110dcb67df9105034243453debba42aaf013d4dfe72ce292a52076bad023
-SIZE (weaveworks-eksctl-0.1.0_GH0.tar.gz) = 15217839
+TIMESTAMP = 1535897918
+SHA256 (weaveworks-eksctl-0.1.1_GH0.tar.gz) = c97c0eb3603076943a0edb2a58eb09a2fa422ce834782f57028faef69549fd67
+SIZE (weaveworks-eksctl-0.1.1_GH0.tar.gz) = 15258231
diff --git a/sysutils/eksctl/files/patch-pkg_eks_auth.go b/sysutils/eksctl/files/patch-pkg_eks_auth.go
deleted file mode 100644
index 01c1d9372fbc..000000000000
--- a/sysutils/eksctl/files/patch-pkg_eks_auth.go
+++ /dev/null
@@ -1,11 +0,0 @@
---- pkg/eks/auth.go.orig 2018-08-17 20:19:48 UTC
-+++ pkg/eks/auth.go
-@@ -192,7 +192,7 @@ func (c *ClientConfig) WithExecHeptioAuthenticator() *
- x := clientConfigCopy.Client.AuthInfos[c.ContextName]
- x.Exec = &clientcmdapi.ExecConfig{
- APIVersion: "client.authentication.k8s.io/v1alpha1",
-- Command: "heptio-authenticator-aws",
-+ Command: "aws-iam-authenticator",
- Args: []string{"token", "-i", c.Cluster.ClusterName},
- /*
- Args: []string{"token", "-i", c.Cluster.ClusterName, "-r", c.roleARN},
diff --git a/sysutils/eksctl/files/patch-pkg_utils_kubectl.go b/sysutils/eksctl/files/patch-pkg_utils_kubectl.go
deleted file mode 100644
index 19d244463143..000000000000
--- a/sysutils/eksctl/files/patch-pkg_utils_kubectl.go
+++ /dev/null
@@ -1,45 +0,0 @@
---- pkg/utils/kubectl.go.orig 2018-08-17 19:52:51 UTC
-+++ pkg/utils/kubectl.go
-@@ -46,22 +46,12 @@ func CheckKubectlVersion(env []string) error {
- return nil
- }
-
--func CheckHeptioAuthenticatorAWS() error {
-- path, err := exec.LookPath("heptio-authenticator-aws")
-- if err == nil {
-- logger.Debug("heptio-authenticator-aws: %q", path)
-- } else {
-- return fmt.Errorf("heptio-authenticator-aws not installed")
-- }
-- return nil
--}
--
- func CheckAllCommands(kubeconfigPath string, isContextSet bool, contextName string, env []string) error {
- if err := CheckKubectlVersion(env); err != nil {
- return err
- }
-
-- if err := CheckHeptioAuthenticatorAWS(); err != nil {
-+ if err := checkAuthenticator(); err != nil {
- return err
- }
-
-@@ -97,4 +87,18 @@ func CheckAllCommands(kubeconfigPath string, isContext
- }
-
- return nil
-+}
-+
-+// checkAuthenticator checks for the authenticator binary existence.
-+func checkAuthenticator() error {
-+ binaries := []string{"heptio-authenticator-aws", "aws-iam-authenticator"}
-+ for _, bin := range binaries {
-+ path, err := exec.LookPath(bin)
-+ if err == nil {
-+ // binary was found
-+ logger.Debug("%s: %q", bin, path)
-+ return nil
-+ }
-+ }
-+ return fmt.Errorf("neither aws-iam-authenticator nor heptio-authenticator-aws are installed")
- }