aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authorpi <pi@FreeBSD.org>2016-04-06 02:00:09 +0800
committerpi <pi@FreeBSD.org>2016-04-06 02:00:09 +0800
commite53a74bd14364b19e637c63d0d39a3123ddd71fc (patch)
tree4931c41e6a5af26013d11238131c8e35265608e9 /sysutils
parent5b55cbdf475eabba3d0f5b60a37eb25734c558e9 (diff)
downloadfreebsd-ports-gnome-e53a74bd14364b19e637c63d0d39a3123ddd71fc.tar.gz
freebsd-ports-gnome-e53a74bd14364b19e637c63d0d39a3123ddd71fc.tar.zst
freebsd-ports-gnome-e53a74bd14364b19e637c63d0d39a3123ddd71fc.zip
New port: sysutils/zap
Use zap to maintain ZFS snapshots with cron. - Uses neither configuration files nor custom ZFS properties - all information is supplied when zap is invoked and stored in snapshot names. - Uses namespaces to avoid collisions with other snapshots. - Creates and destroys snapshots only when it makes sense to. - Written in POSIX sh. WWW: https://github.com/Jehops/zap PR: 208495 Submitted by: Joseph Mingrone <jrm@ftfl.ca>
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/zap/Makefile26
-rw-r--r--sysutils/zap/distinfo2
-rw-r--r--sysutils/zap/pkg-descr10
4 files changed, 39 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index f2fa9a2083f6..63c1a4d5cf43 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -1200,6 +1200,7 @@
SUBDIR += xsysstats
SUBDIR += xvidcap
SUBDIR += yum
+ SUBDIR += zap
SUBDIR += zbackup
SUBDIR += zeitgeist
SUBDIR += zeroer
diff --git a/sysutils/zap/Makefile b/sysutils/zap/Makefile
new file mode 100644
index 000000000000..733facc1809b
--- /dev/null
+++ b/sysutils/zap/Makefile
@@ -0,0 +1,26 @@
+# $FreeBSD$
+
+PORTNAME= zap
+PORTVERSION= 0.1
+CATEGORIES= sysutils
+
+MAINTAINER= jrm@ftfl.ca
+COMMENT= Maintain ZFS snapshots with cron
+
+LICENSE= BSD2CLAUSE
+
+NO_ARCH= yes
+NO_BUILD= yes
+
+USE_GITHUB= yes
+GH_ACCOUNT= Jehops
+GH_TAGNAME= 0.1
+
+PLIST_FILES= bin/zap %%PORTDOCS%%%%DOCSDIR%%/README.org
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/zap ${STAGEDIR}${PREFIX}/bin
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README.org ${STAGEDIR}${DOCSDIR}
+
+.include <bsd.port.mk>
diff --git a/sysutils/zap/distinfo b/sysutils/zap/distinfo
new file mode 100644
index 000000000000..cbf94819da97
--- /dev/null
+++ b/sysutils/zap/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Jehops-zap-0.1_GH0.tar.gz) = 31aa6f579c41e399646b54116bd33aeb1a1020c41436df3c66c4226d94206014
+SIZE (Jehops-zap-0.1_GH0.tar.gz) = 2487
diff --git a/sysutils/zap/pkg-descr b/sysutils/zap/pkg-descr
new file mode 100644
index 000000000000..6f7098bd43a1
--- /dev/null
+++ b/sysutils/zap/pkg-descr
@@ -0,0 +1,10 @@
+Use zap to maintain ZFS snapshots with cron.
+
+- Uses neither configuration files nor custom ZFS properties
+- all information is supplied when zap is invoked and stored in snapshot
+ names.
+- Uses namespaces to avoid collisions with other snapshots.
+- Creates and destroys snapshots only when it makes sense to.
+- Written in POSIX sh.
+
+WWW: https://github.com/Jehops/zap