aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authoraz <az@FreeBSD.org>2013-09-16 16:39:20 +0800
committeraz <az@FreeBSD.org>2013-09-16 16:39:20 +0800
commitf78a349cd860b168f6d0dbee042ecd178e53d23e (patch)
treed471d509e8536b17b01a19757858c0918802bab8 /sysutils
parent6ba2c9c66e5c9908af800baa6a598f4e7db0f86e (diff)
downloadfreebsd-ports-gnome-f78a349cd860b168f6d0dbee042ecd178e53d23e.tar.gz
freebsd-ports-gnome-f78a349cd860b168f6d0dbee042ecd178e53d23e.tar.zst
freebsd-ports-gnome-f78a349cd860b168f6d0dbee042ecd178e53d23e.zip
- convert to the new perl5 framework
- convert USE_GMAKE to Uses Approved by: portmgr (bapt@, blanket)
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/busybox-unstable/Makefile7
-rw-r--r--sysutils/p5-MogileFS-Network/Makefile3
2 files changed, 6 insertions, 4 deletions
diff --git a/sysutils/busybox-unstable/Makefile b/sysutils/busybox-unstable/Makefile
index 6c3b8af03dc9..0bf7388feacf 100644
--- a/sysutils/busybox-unstable/Makefile
+++ b/sysutils/busybox-unstable/Makefile
@@ -28,8 +28,8 @@ IGNORE= is older than stable version. Use sysutils/busybox
PORTSCOUT= skipv:1.21.1
MAKE_ARGS+= SKIP_STRIP=y CC="${CC}" HOSTCC="${CC}" CXX="${CXX}" HOSTCXX="${CXX}"
+USES= gmake
USE_BZIP2= yes
-USE_GMAKE= yes
# avoid clang, breaks in findutils/find.c l. 752+,
# uses a GCC extension/invalid C code:
USE_GCC?= 4.2+
@@ -39,8 +39,9 @@ PLIST_FILES= bin/busybox
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MDOCS}
-USE_PERL5_BUILD= yes
-PORTDOCS= *
+USES+= perl5
+USE_PERL5= build
+PORTDOCS= *
.endif
post-patch:
diff --git a/sysutils/p5-MogileFS-Network/Makefile b/sysutils/p5-MogileFS-Network/Makefile
index 575c86632454..b501874eb433 100644
--- a/sysutils/p5-MogileFS-Network/Makefile
+++ b/sysutils/p5-MogileFS-Network/Makefile
@@ -19,7 +19,8 @@ BUILD_DEPENDS= p5-Net-Netmask>=0:${PORTSDIR}/net-mgmt/p5-Net-Netmask \
p5-MogileFS-Server>=2.50:${PORTSDIR}/sysutils/p5-MogileFS-Server
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= MogileFS::Network.3 \
MogileFS::ReplicationPolicy::MultipleNetworks.3