aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authorlioux <lioux@FreeBSD.org>2001-08-29 08:18:30 +0800
committerlioux <lioux@FreeBSD.org>2001-08-29 08:18:30 +0800
commit0a7014b1a379a5c5dfc974c725180fb652e250a8 (patch)
treeb42f2ddc26be47f648a00c1e0baff4e7a29beaed /sysutils
parent7faaf79beb4f25557c45dfc86f30e8818a5dc963 (diff)
downloadfreebsd-ports-gnome-0a7014b1a379a5c5dfc974c725180fb652e250a8.tar.gz
freebsd-ports-gnome-0a7014b1a379a5c5dfc974c725180fb652e250a8.tar.zst
freebsd-ports-gnome-0a7014b1a379a5c5dfc974c725180fb652e250a8.zip
New port gkrellmouse version 0.0.2: Mouse odometer plugin for
GKrellM PR: 29833 Submitted by: Patrick Li <pat@databits.net>
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/gkrellmouse/Makefile29
-rw-r--r--sysutils/gkrellmouse/distinfo1
-rw-r--r--sysutils/gkrellmouse/files/patch-Makefile19
-rw-r--r--sysutils/gkrellmouse/pkg-comment1
-rw-r--r--sysutils/gkrellmouse/pkg-descr10
-rw-r--r--sysutils/gkrellmouse/pkg-plist1
7 files changed, 62 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index 4cb9d7e5fb98..f2eaa00ff86e 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -58,6 +58,7 @@
SUBDIR += gcombust
SUBDIR += gkrellflynn
SUBDIR += gkrellm
+ SUBDIR += gkrellmouse
SUBDIR += glload
SUBDIR += gnomecontrolcenter
SUBDIR += gnomefind
diff --git a/sysutils/gkrellmouse/Makefile b/sysutils/gkrellmouse/Makefile
new file mode 100644
index 000000000000..6da8e5ead2e0
--- /dev/null
+++ b/sysutils/gkrellmouse/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: gkrellmouse
+# Date Created: Fri Aug 17 15:57:42 EDT 2001
+# Whom: Patrick Li <pat@databits.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gkrellmouse
+PORTVERSION= 0.0.2
+CATEGORIES= sysutils
+MASTER_SITES= http://ssl.usu.edu/paul/gkrellmouse/
+DISTNAME= ${PORTNAME}_${PORTVERSION}
+
+MAINTAINER= pat@databits.net
+
+BUILD_DEPENDS= ${X11BASE}/include/gkrellm/gkrellm.h:${PORTSDIR}/sysutils/gkrellm
+RUN_DEPENDS= gkrellm:${PORTSDIR}/sysutils/gkrellm
+
+WRKSRC= ${WRKDIR}/${DISTNAME:S/_/-/}
+USE_X_PREFIX= yes
+USE_GTK= yes
+USE_IMLIB= yes
+USE_GMAKE= yes
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/gkmouse.so \
+ ${PREFIX}/libexec/gkrellm/plugins
+
+.include <bsd.port.mk>
diff --git a/sysutils/gkrellmouse/distinfo b/sysutils/gkrellmouse/distinfo
new file mode 100644
index 000000000000..1b4619441685
--- /dev/null
+++ b/sysutils/gkrellmouse/distinfo
@@ -0,0 +1 @@
+MD5 (gkrellmouse_0.0.2.tar.gz) = 9730235b225c559a71e7ccaa5b4e819f
diff --git a/sysutils/gkrellmouse/files/patch-Makefile b/sysutils/gkrellmouse/files/patch-Makefile
new file mode 100644
index 000000000000..b4a6a9044733
--- /dev/null
+++ b/sysutils/gkrellmouse/files/patch-Makefile
@@ -0,0 +1,19 @@
+--- Makefile.orig Wed Aug 1 22:12:08 2001
++++ Makefile Tue Aug 28 21:12:58 2001
+@@ -13,12 +13,11 @@
+ DESTDIR =
+
+ # This should point to your gkrellm headers
+-GKRELLM_HDRS := /usr/include/gkrellm
++GKRELLM_HDRS := ${X11BASE}/include/gkrellm
+
+-CC := gcc
+-GTKFLAGS := $(shell gtk-config --cflags)
+-IMLIBFLAGS := $(shell imlib-config --cflags-gdk)
+-CFLAGS := $(CFLAGS) -fPIC -Wall $(GTKFLAGS) $(IMLIBFLAGS) -I$(GKRELLM_HDRS)
++GTKFLAGS = `${GTK_CONFIG} --cflags`
++IMLIBFLAGS = `${IMLIB_CONFIG} --cflags-gdk`
++CFLAGS += -fPIC -Wall $(GTKFLAGS) $(IMLIBFLAGS) -I$(GKRELLM_HDRS)
+ LDFLAGS := -shared -Wl
+ INST_DIR := $(DESTDIR)/usr/lib/gkrellm/plugins
+ USER_INST_DIR := $(DESTDIR)$(HOME)/.gkrellm/plugins
diff --git a/sysutils/gkrellmouse/pkg-comment b/sysutils/gkrellmouse/pkg-comment
new file mode 100644
index 000000000000..db5550dc3444
--- /dev/null
+++ b/sysutils/gkrellmouse/pkg-comment
@@ -0,0 +1 @@
+Mouse odometer plugin for GKrellM
diff --git a/sysutils/gkrellmouse/pkg-descr b/sysutils/gkrellmouse/pkg-descr
new file mode 100644
index 000000000000..e11a251e438c
--- /dev/null
+++ b/sysutils/gkrellmouse/pkg-descr
@@ -0,0 +1,10 @@
+This is a simple plugin for gkrellm that shows you how fast your
+mouse is going (in the chart) and the total distance in pixels it
+has travelled since the plugin was started. It's pretty simple and
+mindless, and probably shouldn't be relied upon to produce
+ultra-accurate data, but it gets the point across.
+
+WWW: http://ssl.usu.edu/paul/gkrellmouse/
+Author: Paul Cannon <paul@cannon.cs.usu.edu>
+
+- Patrick Li <pat@databits.net>
diff --git a/sysutils/gkrellmouse/pkg-plist b/sysutils/gkrellmouse/pkg-plist
new file mode 100644
index 000000000000..b97c79f601e2
--- /dev/null
+++ b/sysutils/gkrellmouse/pkg-plist
@@ -0,0 +1 @@
+libexec/gkrellm/plugins/gkmouse.so