aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authorbrooks <brooks@FreeBSD.org>2011-05-28 04:24:04 +0800
committerbrooks <brooks@FreeBSD.org>2011-05-28 04:24:04 +0800
commit2925ca2fbf322ffba7fc3d3dedf59c5691913bf7 (patch)
treec4c75593c0d04193dafb151267d19ace4300e0db /sysutils
parent916609e3b90721be04c5dc4d54cfe0690405d728 (diff)
downloadfreebsd-ports-gnome-2925ca2fbf322ffba7fc3d3dedf59c5691913bf7.tar.gz
freebsd-ports-gnome-2925ca2fbf322ffba7fc3d3dedf59c5691913bf7.tar.zst
freebsd-ports-gnome-2925ca2fbf322ffba7fc3d3dedf59c5691913bf7.zip
Fix the bogus LIB_DEPENDS in port by taking an axe to configure.in and
adding the use of autoconf. Since we don't actually need the libraries, there's no need to check for them.
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/ganglia-webfrontend/Makefile6
-rw-r--r--sysutils/ganglia-webfrontend/files/patch-.._configure.in211
2 files changed, 213 insertions, 4 deletions
diff --git a/sysutils/ganglia-webfrontend/Makefile b/sysutils/ganglia-webfrontend/Makefile
index a72541fe13a9..bd2afc5f6afe 100644
--- a/sysutils/ganglia-webfrontend/Makefile
+++ b/sysutils/ganglia-webfrontend/Makefile
@@ -7,7 +7,7 @@
PORTNAME= webfrontend
PORTVERSION= 3.1.7
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= sysutils net parallel www
MASTER_SITES= SF/ganglia/ganglia%20monitoring%20core/${PORTVERSION}
PKGNAMEPREFIX= ganglia-
@@ -16,9 +16,6 @@ DISTNAME= ganglia-${PORTVERSION}
MAINTAINER= brooks@FreeBSD.org
COMMENT= Ganglia cluster monitor, web frontend
-LIB_DEPENDS= apr-1:${PORTSDIR}/devel/apr1 \
- confuse:${PORTSDIR}/devel/libconfuse \
- pcre:${PORTSDIR}/devel/pcre
RUN_DEPENDS= ${LOCALBASE}/sbin/gmetad:${PORTSDIR}/sysutils/ganglia-monitor-core
PKGINSTALL= ${WRKDIR}/pkg-install
@@ -32,6 +29,7 @@ PLIST_SUB+= WEBFRONTDIR="${WEBFRONTDIR}"
GNU_CONFIGURE= yes
CONFIGURE_ARGS= GANGLIA_ACK_SYSCONFDIR=1
CONFIGURE_WRKSRC= ${WRKDIR}/${DISTNAME}
+USE_AUTOTOOLS= autoconf
USE_PHP= gd pcre xml ctype
WANT_PHP_MOD= yes
diff --git a/sysutils/ganglia-webfrontend/files/patch-.._configure.in b/sysutils/ganglia-webfrontend/files/patch-.._configure.in
new file mode 100644
index 000000000000..dc6bd13cf287
--- /dev/null
+++ b/sysutils/ganglia-webfrontend/files/patch-.._configure.in
@@ -0,0 +1,211 @@
+
+$FreeBSD$
+
+--- ../configure.in.orig
++++ ../configure.in
+@@ -166,31 +166,6 @@
+
+ AM_CONDITIONAL(BUILD_GMETAD, test x"$gmetad" = xyes)
+
+-AC_ARG_WITH( python,
+-[ --with-python=PATH Specify prefix for python or full path to interpreter],
+-[if test x"$withval" != xno; then enable_python="yes"; PYTHON_BIN="$withval"; fi])
+-
+-AC_ARG_WITH( librrd,
+-[ --with-librrd=DIR Specify location for librrd],
+-[if test x"$withval" != xno; then librrd="yes"; librrdpath="$withval"; fi])
+-
+-AC_ARG_WITH( libapr,
+-[ --with-libapr=PATH Specify location for libapr-1 or full path to apr-1-config],
+-[if test x"$withval" != xno; then libapr="yes"; libaprpath="$withval"; fi])
+-
+-AC_ARG_WITH( libexpat,
+-[ --with-libexpat=DIR Specify location for libexpat],
+-[if test x"$withval" != xno; then libexpat="yes"; libexpatpath="$withval"; fi])
+-
+-AC_ARG_WITH( libconfuse,
+-[ --with-libconfuse=DIR Specify location for libconfuse],
+-[if test x"$withval" != xno; then libconfuse="yes"; libconfusepath="$withval"; fi])
+-
+-AC_ARG_WITH( libpcre,
+-[ --with-libpcre=DIR Specify location for libpcre],
+-[if test x"$withval" != xno; then libpcre="yes"; libpcrepath="$withval"; fi],
+-[libpcre=yes; libpcrepath=yes ])
+-
+ AC_ARG_WITH( moduledir,
+ [ --with-moduledir=DIR Base directory for dynamically loadable modules],
+ moduledir="$withval",
+@@ -237,10 +212,6 @@
+ http://www.cbmamiga.demon.co.uk/mpatrol/],
+ [ enable_memcheck="yes" ])
+
+-AC_ARG_ENABLE( python,
+-[ --disable-python exclude mod_python and support for metric modules written in python],
+-[ if test x"$enableval" != xyes; then enable_python="no"; fi ], [ enable_python="yes" ] )
+-
+ AC_ARG_ENABLE( status,
+ [ --enable-status compile and install modgstatus to enable gmond status metric module support],
+ [ enable_status="yes"
+@@ -292,49 +263,6 @@
+
+ AC_SUBST(STATIC_USER_MODULES)
+
+-if test x"$enable_python" = xyes; then
+- echo
+- echo Checking for python
+-
+- # check for Python executable
+- if test -z "$PYTHON_BIN"; then
+- AC_PATH_PROG(PYTHON_BIN, python)
+- else
+- if test -d "$PYTHON_BIN"; then
+- PYTHON_BIN="$PYTHON_BIN/bin/python"
+- fi
+- fi
+-
+- if test -n "$PYTHON_BIN"; then
+- # find out python version
+- AC_MSG_CHECKING(Python version)
+- PyVERSION=`$PYTHON_BIN -c ['import sys; print sys.version[:3]'`]
+- PyMAJVERSION=`$PYTHON_BIN -c ['import sys; print sys.version[:1]'`]
+- AC_MSG_RESULT($PyVERSION)
+- PYTHON_VERSION=$PyVERSION
+- AC_SUBST(PYTHON_VERSION)
+-
+- PyEXEC_INSTALLDIR=`$PYTHON_BIN -c "import sys; print sys.exec_prefix"`
+- if test -f "$PyEXEC_INSTALLDIR/include/python/Python.h"; then
+- PYTHON_INCLUDES="-I$PyEXEC_INSTALLDIR/include/python"
+- else
+- if test -f "$PyEXEC_INSTALLDIR/include/python$PyVERSION/Python.h"; then
+- PYTHON_INCLUDES="-I$PyEXEC_INSTALLDIR/include/python$PyVERSION"
+- else
+- PYTHON_INCLUDES=""
+- enable_python="no"
+- fi
+- fi
+- AC_SUBST(PYTHON_INCLUDES)
+- else
+- enable_python="no"
+- fi
+-fi
+-
+-AC_MSG_CHECKING(Python support)
+-AC_MSG_RESULT($enable_python)
+-AM_CONDITIONAL(BUILD_PYTHON, test x"$enable_python" = xyes)
+-
+ LIB_SUFFIX=lib
+ case $host in
+ x86_64*linux*)
+@@ -342,112 +270,6 @@
+ ;;
+ esac
+
+-echo
+-echo Checking for apr
+-if test x"$libaprpath" != x && test x"$libaprpath" != xyes; then
+- if test -f "$libaprpath" ; then
+- APR_INCLUDES=`$libaprpath --includes`
+- AC_SUBST(APR_INCLUDES)
+- APR_LIBPATH=`$libaprpath --link-ld`
+- LDFLAGS="$LDFLAGS -L`expr "x$APR_LIBPATH" : '.*-L\(.*\) '`"
+- AC_CHECK_LIB(apr-1, apr_socket_send,,,[`$libaprpath --libs`])
+- else
+- CFLAGS="$CFLAGS -I$libaprpath/include"
+- LDFLAGS="$LDFLAGS -L$libaprpath/${LIB_SUFFIX}"
+- echo "Added -I$libaprpath/include to CFLAGS"
+- echo "Added -L$libaprpath/${LIB_SUFFIX} to LDFLAGS"
+- AC_CHECK_LIB(apr-1, apr_socket_send)
+- fi
+-else
+- AC_PATH_PROG(APR_CONFIG, apr-1-config)
+- if test -z "$APR_CONFIG"; then
+- AC_MSG_ERROR(apr-1-config binary not found in path)
+- fi
+- APR_INCLUDES=`$APR_CONFIG --includes`
+- AC_SUBST(APR_INCLUDES)
+- APR_LIBPATH=`$APR_CONFIG --link-ld`
+- APR_LIBPATH=`expr "x$APR_LIBPATH" : '.*-L\(.*\) '`
+- if test x"$APR_LIBPATH" != x; then
+- LDFLAGS="$LDFLAGS -L$APR_LIBPATH"
+- fi
+- AC_CHECK_LIB(apr-1, apr_socket_send,,,[`$APR_CONFIG --libs`])
+-fi
+-
+-if test x"$ac_cv_lib_apr_1_apr_socket_send" = xyes; then
+- echo "The ganglia utilities use the Apache Portable Runtime functions (http://www.apache.org/)"
+- echo "Found a suitable libapr1 library"
+-else
+- echo "libapr not found"
+- exit;
+-fi
+-
+-echo
+-echo Checking for confuse
+-if test x"$libconfusepath" != x && test x"$libconfusepath" != xyes; then
+- CFLAGS="$CFLAGS -I$libconfusepath/include"
+- LDFLAGS="$LDFLAGS -L$libconfusepath/${LIB_SUFFIX}"
+- echo "Added -I$libconfusepath/include to CFLAGS"
+- echo "Added -L$libconfusepath/${LIB_SUFFIX} to LDFLAGS"
+-fi
+-AC_CHECK_LIB(confuse, cfg_parse)
+-if test x"$ac_cv_lib_confuse_cfg_parse" = xno; then
+- echo Trying harder including gettext
+- unset ac_cv_lib_confuse_cfg_parse
+- LDFLAGS="$LDFLAGS -lintl"
+- AC_CHECK_LIB(confuse, cfg_parse)
+- if test x"$ac_cv_lib_confuse_cfg_parse" = xno; then
+- echo Trying harder including iconv
+- unset ac_cv_lib_confuse_cfg_parse
+- LDFLAGS="$LDFLAGS -liconv"
+- AC_CHECK_LIB(confuse, cfg_parse)
+- if test x"$ac_cv_lib_confuse_cfg_parse" = xno; then
+- echo "libconfuse not found"
+- exit
+- fi
+- fi
+-fi
+-if test x"$ac_cv_lib_confuse_cfg_parse" = xyes; then
+- echo "Found a suitable Confuse library"
+-fi
+-
+-echo
+-echo Checking for expat
+-if test x"$libexpatpath" != x && test x"$libexpatpath" != xyes; then
+- CFLAGS="$CFLAGS -I$libexpatpath/include"
+- LDFLAGS="$LDFLAGS -L$libexpatpath/${LIB_SUFFIX}"
+- echo "Added -I$libexpatpath/include to CFLAGS"
+- echo "Added -L$libexpatpath/${LIB_SUFFIX} to LDFLAGS"
+-fi
+-AC_CHECK_LIB(expat, XML_ParserCreate)
+-if test x"$ac_cv_lib_expat_XML_ParserCreate" = xyes; then
+- echo "Found a suitable Expat library"
+-else
+- echo "libexpat not found"
+- exit;
+-fi
+-
+-echo
+-echo Checking for pcre
+-if test x"$libpcrepath" != x && test x"$libpcrepath" != xyes; then
+- CFLAGS="$CFLAGS -I$libpcrepath/include"
+- LDFLAGS="$LDFLAGS -L$libpcrepath/${LIB_SUFFIX}"
+- echo "Added -I$libpcrepath/include to CFLAGS"
+- echo "Added -L$libpcrepath/${LIB_SUFFIX} to LDFLAGS"
+-fi
+-if test x"$libpcre" == xyes ; then
+- AC_CHECK_HEADERS([pcre/pcre.h pcre.h])
+- AC_CHECK_LIB(pcre, pcre_compile)
+- if test x"$ac_cv_lib_pcre_pcre_compile" = xyes; then
+- echo "Found a suitable pcre library"
+- else
+- echo "libpcre not found, specify --with-libpcre=no to build without PCRE support"
+- exit;
+- fi
+-else
+- echo "building without PCRE support"
+-fi
+-echo
+-
+ AC_CHECK_LIB(rpc, xdr_string)
+ AC_CHECK_LIB(socket, socket)
+ AC_CHECK_LIB(nsl, inet_addr)