aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authormandree <mandree@FreeBSD.org>2011-06-21 06:02:53 +0800
committermandree <mandree@FreeBSD.org>2011-06-21 06:02:53 +0800
commit40c8ff2523b73434d8bcfb726d473b290ccbf848 (patch)
treeaa7525f3c70bdace453d2bccf6fb29dc78c659f3 /sysutils
parent4bc2419e82e24d425adacfbba47449326e5f6dfc (diff)
downloadfreebsd-ports-gnome-40c8ff2523b73434d8bcfb726d473b290ccbf848.tar.gz
freebsd-ports-gnome-40c8ff2523b73434d8bcfb726d473b290ccbf848.tar.zst
freebsd-ports-gnome-40c8ff2523b73434d8bcfb726d473b290ccbf848.zip
[1] USE_GCC=4.2+, to avoid clang. Port needs -lgcc and -lgcc_s explicitly.
[2] Set include path through CPPFLAGS directly, not through CONFIGURE_ENV. Found by: -exp run [1] Found by: portlint [2]
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/e2fsprogs/Makefile6
1 files changed, 2 insertions, 4 deletions
diff --git a/sysutils/e2fsprogs/Makefile b/sysutils/e2fsprogs/Makefile
index 916888520fdf..efffa2e134b6 100644
--- a/sysutils/e2fsprogs/Makefile
+++ b/sysutils/e2fsprogs/Makefile
@@ -15,15 +15,13 @@ MAINTAINER?= mandree@FreeBSD.org
COMMENT?= Utilities & library to manipulate ext2/3/4 filesystems
PATCH_STRIP= -p1
+USE_GCC= 4.2+
USE_GMAKE= yes
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS+=--disable-fsck --disable-e2initrd-helper \
--with-root-prefix='${PREFIX}'
-#CONFIGURE_ENV+= CPPFLAGS='${CPPFLAGS} -I${WRKSRC}/lib \
-# -I${LOCALBASE}/include -D_EXT2_USE_C_VERSIONS_'
-CONFIGURE_ENV+= CPPFLAGS='${CPPFLAGS} -I${WRKSRC}/lib \
- -I${LOCALBASE}/include'
+CPPFLAGS+= -I${WRKSRC}/lib -I${LOCALBASE}/include # -D_EXT2_USE_C_VERSIONS
MAKE_ARGS+= LDFLAGS='${LDFLAGS} -L${LOCALBASE}/lib'
OPTIONS?= NLS "Enable national language support" on