aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authorlkoeller <lkoeller@FreeBSD.org>2004-01-05 03:18:20 +0800
committerlkoeller <lkoeller@FreeBSD.org>2004-01-05 03:18:20 +0800
commit5453c3248120a76c12113ac1de440b9601806d2e (patch)
treef104cb06ccd0f5128020f9ca79229606d5f86b81 /sysutils
parent528e88009d345ba94c5f0bd5694bda12f611c3be (diff)
downloadfreebsd-ports-gnome-5453c3248120a76c12113ac1de440b9601806d2e.tar.gz
freebsd-ports-gnome-5453c3248120a76c12113ac1de440b9601806d2e.tar.zst
freebsd-ports-gnome-5453c3248120a76c12113ac1de440b9601806d2e.zip
o) Update to version 3.10.9
o) files dir contains a sample config for network master-slave which seems to be stable on my test environment o) still lack of USB support, cause noone ports the LINUX usb code to FreeBSD (perhaps libusb is also a staring point)
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/apcupsd/Makefile22
-rw-r--r--sysutils/apcupsd/distinfo2
-rw-r--r--sysutils/apcupsd/files/apcupsd.conf.net-master.sample35
-rw-r--r--sysutils/apcupsd/files/apcupsd.conf.net-slave.sample18
-rw-r--r--sysutils/apcupsd/pkg-plist21
5 files changed, 73 insertions, 25 deletions
diff --git a/sysutils/apcupsd/Makefile b/sysutils/apcupsd/Makefile
index 4a2704605539..94d51225422d 100644
--- a/sysutils/apcupsd/Makefile
+++ b/sysutils/apcupsd/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= apcupsd
-PORTVERSION= 3.10.6
+PORTVERSION= 3.10.9
#PORTREVISION= 1
CATEGORIES= sysutils
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
@@ -27,8 +27,13 @@ CONFIGURE_ARGS= --prefix=${PREFIX} --sbindir=${PREFIX}/sbin \
--disable-install-distdir --enable-usb \
--sysconfdir=${PREFIX}/etc/apcupsd \
--with-serial-dev=/dev/usv \
- --enable-cgi --with-cgi-bin=${PREFIX}/etc/apcupsd/cgi \
- --enable-master-slave
+ --enable-cgi --with-cgi-bin=${PREFIX}/etc/apcupsd/cgi
+.if defined(WITH_CLIENT_ONLY)
+CONFIGURE_ARGS+=--enable-net
+.else
+CONFIGURE_ARGS+=--enable-master-slave
+.endif
+
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -L${LOCALBASE}/lib" \
CFLAGS="-I${LOCALBASE}/include -L${LOCALBASE}/lib" \
LDFLAGS="-L${LOCALBASE}/lib"
@@ -51,6 +56,17 @@ PORTDOCS= apcupsd.pdf manual.html \
wininstall1.png wininstall2.png wininstall3.png wininstall4.png \
wininstall5.png wininstall6.png wininstall7.png
+pre-everything::
+.if !defined(WITH_CLIENT_ONLY)
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} "You may use the following build options:"
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} " WITH_CLIENT_ONLY=yes if you only want a network client."
+ @${ECHO_MSG} ""
+.else
+ @${ECHO_MSG} "===> Building network client."
+.endif
+
post-configure:
${REINPLACE_CMD} -e "s|%PREFIX%|${PREFIX}|g" ${WRKSRC}/doc/apcupsd.man
diff --git a/sysutils/apcupsd/distinfo b/sysutils/apcupsd/distinfo
index b6dfae378a0e..dd220b94aa2d 100644
--- a/sysutils/apcupsd/distinfo
+++ b/sysutils/apcupsd/distinfo
@@ -1 +1 @@
-MD5 (apcupsd-3.10.6.tar.gz) = a015d65ebeae9ee08aacbc8e6e7ac217
+MD5 (apcupsd-3.10.9.tar.gz) = 693a4ecfecf5ae777f3ef4000f58d6fe
diff --git a/sysutils/apcupsd/files/apcupsd.conf.net-master.sample b/sysutils/apcupsd/files/apcupsd.conf.net-master.sample
new file mode 100644
index 000000000000..350ada686b7a
--- /dev/null
+++ b/sysutils/apcupsd/files/apcupsd.conf.net-master.sample
@@ -0,0 +1,35 @@
+## apcupsd.conf v1.1 ##
+#
+# apcupsd 3.10.X master configuration
+#
+UPSCABLE 940-1524C
+UPSTYPE smartups
+DEVICE /dev/usv
+LOCKFILE /var/spool/lock
+BATTERYLEVEL 5
+MINUTES 3
+TIMEOUT 0
+ANNOY 300
+ANNOYDELAY 60
+NOLOGON disable
+KILLDELAY 0
+NETSERVER on
+#NISIP 0.0.0.0
+NISPORT 3551
+EVENTSFILE /var/log/apcupsd.events
+EVENTSFILEMAX 10
+UPSCLASS netmaster
+UPSMODE net
+STATTIME 0
+STATFILE /var/log/apcupsd.status
+LOGSTATS off
+DATATIME 0
+UPSNAME LK-SMART
+BATTDATE 11/20/01
+WAKEUP 60
+SLEEP 180
+LOTRANSFER 208
+HITRANSFER 253
+BEEPSTATE 0
+OUTPUTVOLTS 230
+SELFTEST 168
diff --git a/sysutils/apcupsd/files/apcupsd.conf.net-slave.sample b/sysutils/apcupsd/files/apcupsd.conf.net-slave.sample
new file mode 100644
index 000000000000..5913eef01a8c
--- /dev/null
+++ b/sysutils/apcupsd/files/apcupsd.conf.net-slave.sample
@@ -0,0 +1,18 @@
+## apcupsd.conf v1.1 ##
+#
+# apcupsd 3.10.X
+#
+# "apcupsd" netslave file
+#
+UPSCABLE ether
+UPSTYPE net
+DEVICE usv.koellers.net:3551
+LOCKFILE /var/spool/lock
+EVENTSFILE /var/log/apcupsd.events
+UPSCLASS standalone
+UPSMODE disable
+NISPORT 3551
+#
+# Use this to control the poll time.
+# the default is 60 or 1 minute
+NETTIME 30
diff --git a/sysutils/apcupsd/pkg-plist b/sysutils/apcupsd/pkg-plist
index 551b302f6d57..d43f656cf43c 100644
--- a/sysutils/apcupsd/pkg-plist
+++ b/sysutils/apcupsd/pkg-plist
@@ -16,25 +16,4 @@ etc/apcupsd/cgi/upsfstats.cgi
etc/apcupsd/cgi/upsimage.cgi
etc/apcupsd/cgi/upsstats.cgi
etc/rc.d/%%STARTUP_SCRIPT%%
-%%PORTDOCS%%%%DOCSDIR%%/apcupsd.pdf
-%%PORTDOCS%%%%DOCSDIR%%/manual.html
-%%PORTDOCS%%%%DOCSDIR%%/apcupsd.png
-%%PORTDOCS%%%%DOCSDIR%%/back.png
-%%PORTDOCS%%%%DOCSDIR%%/charging.png
-%%PORTDOCS%%%%DOCSDIR%%/home.png
-%%PORTDOCS%%%%DOCSDIR%%/main_configs.png
-%%PORTDOCS%%%%DOCSDIR%%/multimon.png
-%%PORTDOCS%%%%DOCSDIR%%/next.png
-%%PORTDOCS%%%%DOCSDIR%%/onbatt.png
-%%PORTDOCS%%%%DOCSDIR%%/online.png
-%%PORTDOCS%%%%DOCSDIR%%/status.png
-%%PORTDOCS%%%%DOCSDIR%%/thanks.png
-%%PORTDOCS%%%%DOCSDIR%%/wininstall1.png
-%%PORTDOCS%%%%DOCSDIR%%/wininstall2.png
-%%PORTDOCS%%%%DOCSDIR%%/wininstall3.png
-%%PORTDOCS%%%%DOCSDIR%%/wininstall4.png
-%%PORTDOCS%%%%DOCSDIR%%/wininstall5.png
-%%PORTDOCS%%%%DOCSDIR%%/wininstall6.png
-%%PORTDOCS%%%%DOCSDIR%%/wininstall7.png
-%%PORTDOCS%%@dirrm %%DOCSDIR%%
@dirrm etc/apcupsd/cgi