aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authorpgollucci <pgollucci@FreeBSD.org>2010-10-06 08:01:23 +0800
committerpgollucci <pgollucci@FreeBSD.org>2010-10-06 08:01:23 +0800
commit99ed0275ac3b1aaa0f00d317ef2e3a94f2b8f3cd (patch)
treea4dfc8770558721ee16972658795d815d5765db1 /sysutils
parent3c5dd482a8fe278d7c21044846d38848f12fed46 (diff)
downloadfreebsd-ports-gnome-99ed0275ac3b1aaa0f00d317ef2e3a94f2b8f3cd.tar.gz
freebsd-ports-gnome-99ed0275ac3b1aaa0f00d317ef2e3a94f2b8f3cd.tar.zst
freebsd-ports-gnome-99ed0275ac3b1aaa0f00d317ef2e3a94f2b8f3cd.zip
RSYSLOG OVERHAUL: Part 1
- Update to 3.22.2, Update MASTER_SITES - unbreak umtp -> utmpx on -current - fix PORTSCOUT vars PR: ports/151021
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/rsyslog3/Makefile10
-rw-r--r--sysutils/rsyslog3/bsd.rsyslog.mk6
-rw-r--r--sysutils/rsyslog3/distinfo6
-rw-r--r--sysutils/rsyslog3/files/patch-tools__omusrmsg.c105
-rw-r--r--sysutils/rsyslog3/pkg-plist1
5 files changed, 111 insertions, 17 deletions
diff --git a/sysutils/rsyslog3/Makefile b/sysutils/rsyslog3/Makefile
index ec3ee9bfc336..3feedcfd867a 100644
--- a/sysutils/rsyslog3/Makefile
+++ b/sysutils/rsyslog3/Makefile
@@ -6,7 +6,6 @@
#
PORTNAME= rsyslog
-PORTREVISION= 2
COMMENT= Enhanced syslog daemon
@@ -25,8 +24,6 @@ CONFIGURE_ARGS+=--enable-klog --disable-static --enable-mail \
CONFIGURE_ARGS+=--enable-rtinst --enable-debug
.endif
-PORTSCOUT= skipv:3.21.10,3.21.9,3.21.8,3.21.7,3.21.6,3.21.5,3.21.4,3.21.3,3.21.2,3.21.1,3.21.0
-
post-patch:
@${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g' ${WRKSRC}/configure
@${REINPLACE_CMD} -e 's|/lib/rsyslog/|${PREFIX}/lib/rsyslog/|'\
@@ -43,10 +40,5 @@ post-install:
@${CAT} ${PKGMESSAGE}
.include "${.CURDIR}/bsd.rsyslog.mk"
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 900007
-BROKEN= does not build
-.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/sysutils/rsyslog3/bsd.rsyslog.mk b/sysutils/rsyslog3/bsd.rsyslog.mk
index 9462c9694961..25874b02cfd2 100644
--- a/sysutils/rsyslog3/bsd.rsyslog.mk
+++ b/sysutils/rsyslog3/bsd.rsyslog.mk
@@ -1,7 +1,7 @@
PORTNAME?= rsyslog
-PORTVERSION?= 3.22.1
+PORTVERSION?= 3.22.2
CATEGORIES?= sysutils
-MASTER_SITES?= http://download.rsyslog.com/rsyslog/
+MASTER_SITES?= http://www.rsyslog.com/files/download/rsyslog/
MAINTAINER?= miwi@FreeBSD.org
NO_LATEST_LINK= yes
@@ -22,8 +22,6 @@ PLIST= ""
DESCR?= ${.CURDIR}/../rsyslog3/pkg-descr
MD5_FILE?= ${.CURDIR}/../rsyslog3/distinfo
-PORTSCOUT= skipv:3.21.10,3.21.9,3.21.8,3.21.7,3.21.6,3.21.5,3.21.4,3.21.3,3.21.2,3.21.1,3.21.0
-
do-install:
@${INSTALL} -d ${PREFIX}/lib/rsyslog/
.for _T in ${MTYPES}
diff --git a/sysutils/rsyslog3/distinfo b/sysutils/rsyslog3/distinfo
index 7244bc2b619c..c7f5ca666541 100644
--- a/sysutils/rsyslog3/distinfo
+++ b/sysutils/rsyslog3/distinfo
@@ -1,3 +1,3 @@
-MD5 (rsyslog-3.22.1.tar.gz) = 64bed3d5535c17d631f7432a5badf959
-SHA256 (rsyslog-3.22.1.tar.gz) = 5d3bb28dc87b3abb7053ccae8316f032ddd0486681683b116a25f66fc0942abb
-SIZE (rsyslog-3.22.1.tar.gz) = 1358598
+MD5 (rsyslog-3.22.2.tar.gz) = b6a3b591764b20679dfb142219c4a8b8
+SHA256 (rsyslog-3.22.2.tar.gz) = d7afc6cb0fead582a20a7aa1f1fed9ee0f6ed41c4fa930d4d16095edb8183db3
+SIZE (rsyslog-3.22.2.tar.gz) = 1315816
diff --git a/sysutils/rsyslog3/files/patch-tools__omusrmsg.c b/sysutils/rsyslog3/files/patch-tools__omusrmsg.c
new file mode 100644
index 000000000000..22235efe9b8c
--- /dev/null
+++ b/sysutils/rsyslog3/files/patch-tools__omusrmsg.c
@@ -0,0 +1,105 @@
+--- ./tools/omusrmsg.c.orig 2010-10-05 02:35:15.216392638 +0000
++++ ./tools/omusrmsg.c 2010-10-05 02:38:59.119754578 +0000
+@@ -50,7 +50,7 @@
+ #include <assert.h>
+ #include <signal.h>
+ #include <sys/param.h>
+-#include <utmp.h>
++#include <utmpx.h>
+ #include <unistd.h>
+ #include <sys/uio.h>
+ #include <sys/stat.h>
+@@ -117,41 +117,6 @@
+ ENDdbgPrintInstInfo
+
+
+-/**
+- * BSD setutent/getutent() replacement routines
+- * The following routines emulate setutent() and getutent() under
+- * BSD because they are not available there. We only emulate what we actually
+- * need! rgerhards 2005-03-18
+- */
+-#ifdef OS_BSD
+-static FILE *BSD_uf = NULL;
+-void setutent(void)
+-{
+- assert(BSD_uf == NULL);
+- if ((BSD_uf = fopen(_PATH_UTMP, "r")) == NULL) {
+- errmsg.LogError(NO_ERRCODE, "%s", _PATH_UTMP);
+- return;
+- }
+-}
+-
+-struct utmp* getutent(void)
+-{
+- static struct utmp st_utmp;
+-
+- if(fread((char *)&st_utmp, sizeof(st_utmp), 1, BSD_uf) != 1)
+- return NULL;
+-
+- return(&st_utmp);
+-}
+-
+-void endutent(void)
+-{
+- fclose(BSD_uf);
+- BSD_uf = NULL;
+-}
+-#endif /* #ifdef OS_BSD */
+-
+-
+ /* WALLMSG -- Write a message to the world at large
+ *
+ * Write the specified message to either the entire
+@@ -173,27 +138,25 @@
+ int errnoSave;
+ int ttyf;
+ int wrRet;
+- struct utmp ut;
+- struct utmp *uptr;
++ struct utmpx ut;
++ struct utmpx *uptr;
+ struct stat statb;
+ DEFiRet;
+
+ assert(pMsg != NULL);
+
+ /* open the user login file */
+- setutent();
++ setutxent();
+
+ /* scan the user login file */
+- while((uptr = getutent())) {
++ while((uptr = getutxent())) {
+ memcpy(&ut, uptr, sizeof(ut));
+ /* is this slot used? */
+- if(ut.ut_name[0] == '\0')
++ if(ut.ut_user[0] == '\0')
+ continue;
+-#ifndef OS_BSD
+ if(ut.ut_type != USER_PROCESS)
+ continue;
+-#endif
+- if(!(strncmp (ut.ut_name,"LOGIN", 6))) /* paranoia */
++ if(!(strncmp (ut.ut_user,"LOGIN", 6))) /* paranoia */
+ continue;
+
+ /* should we send the message to this user? */
+@@ -203,7 +166,7 @@
+ i = MAXUNAMES;
+ break;
+ }
+- if(strncmp(pData->uname[i], ut.ut_name, UNAMESZ) == 0)
++ if(strncmp(pData->uname[i], ut.ut_user, UNAMESZ) == 0)
+ break;
+ }
+ if(i == MAXUNAMES) /* user not found? */
+@@ -239,7 +202,7 @@
+ }
+
+ /* close the user login file */
+- endutent();
++ endutxent();
+ RETiRet;
+ }
+
diff --git a/sysutils/rsyslog3/pkg-plist b/sysutils/rsyslog3/pkg-plist
index c7df4431211d..5716b9c02ac4 100644
--- a/sysutils/rsyslog3/pkg-plist
+++ b/sysutils/rsyslog3/pkg-plist
@@ -65,7 +65,6 @@ sbin/rsyslogd
%%PORTDOCS%%%%DOCSDIR%%/ommysql.html
%%PORTDOCS%%%%DOCSDIR%%/omrelp.html
%%PORTDOCS%%%%DOCSDIR%%/omsnmp.html
-%%PORTDOCS%%%%DOCSDIR%%/professional_support.html
%%PORTDOCS%%%%DOCSDIR%%/property_replacer.html
%%PORTDOCS%%%%DOCSDIR%%/queues.html
%%PORTDOCS%%%%DOCSDIR%%/rainerscript.html