aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authorkris <kris@FreeBSD.org>2004-02-25 17:55:24 +0800
committerkris <kris@FreeBSD.org>2004-02-25 17:55:24 +0800
commitc926bcf5aa8b2648eb81bfd94e3e7abc5ad4f39e (patch)
tree4553ab15f2cc7fa58bc2c2ec62b11a2ab9edb8f9 /sysutils
parent214d0ef9e90eb37cc4cd03324bbc0d8a5da33b59 (diff)
downloadfreebsd-ports-gnome-c926bcf5aa8b2648eb81bfd94e3e7abc5ad4f39e.tar.gz
freebsd-ports-gnome-c926bcf5aa8b2648eb81bfd94e3e7abc5ad4f39e.tar.zst
freebsd-ports-gnome-c926bcf5aa8b2648eb81bfd94e3e7abc5ad4f39e.zip
BROKEN on !i386 and !amd64: Does not compile
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/mbmon/Makefile8
-rw-r--r--sysutils/xmbmon/Makefile8
2 files changed, 14 insertions, 2 deletions
diff --git a/sysutils/mbmon/Makefile b/sysutils/mbmon/Makefile
index d2c6d96f2cb2..04c3fe8f18ba 100644
--- a/sysutils/mbmon/Makefile
+++ b/sysutils/mbmon/Makefile
@@ -28,6 +28,12 @@ PLIST_SUB= X11_ONLY=""
MAKE_ARGS+= DOCSDIR='${DOCSDIR}' INSTALL_DATA='${INSTALL_DATA}'
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} != "i386" && ${ARCH} != "amd64"
+BROKEN= "Does not compile on !i386 and !amd64"
+.endif
+
pre-everything::
@${ECHO_CMD} ""
@${ECHO_CMD} "Definable build options"
@@ -41,4 +47,4 @@ post-install:
(cd ${WRKSRC}; ${MAKE} ${MAKE_ARGS} install-doc)
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/sysutils/xmbmon/Makefile b/sysutils/xmbmon/Makefile
index d2c6d96f2cb2..04c3fe8f18ba 100644
--- a/sysutils/xmbmon/Makefile
+++ b/sysutils/xmbmon/Makefile
@@ -28,6 +28,12 @@ PLIST_SUB= X11_ONLY=""
MAKE_ARGS+= DOCSDIR='${DOCSDIR}' INSTALL_DATA='${INSTALL_DATA}'
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} != "i386" && ${ARCH} != "amd64"
+BROKEN= "Does not compile on !i386 and !amd64"
+.endif
+
pre-everything::
@${ECHO_CMD} ""
@${ECHO_CMD} "Definable build options"
@@ -41,4 +47,4 @@ post-install:
(cd ${WRKSRC}; ${MAKE} ${MAKE_ARGS} install-doc)
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>