aboutsummaryrefslogtreecommitdiffstats
path: root/sysutils
diff options
context:
space:
mode:
authorlioux <lioux@FreeBSD.org>2006-02-02 08:30:38 +0800
committerlioux <lioux@FreeBSD.org>2006-02-02 08:30:38 +0800
commitd2e1356b59560ae88e2afc71bbbebc9012e9328d (patch)
treed4fc0991d6f7e6a2909e236108ef90ea9837b866 /sysutils
parent621068ef71bd4c94c77dc958b67ca3bc220f50b3 (diff)
downloadfreebsd-ports-gnome-d2e1356b59560ae88e2afc71bbbebc9012e9328d.tar.gz
freebsd-ports-gnome-d2e1356b59560ae88e2afc71bbbebc9012e9328d.tar.zst
freebsd-ports-gnome-d2e1356b59560ae88e2afc71bbbebc9012e9328d.zip
o vobcopy tries to determine the size of the VOBs to be copied by
checking for both video_ts/foo.vob and VIDEO_TS/FOO.VOB. However, due to the nature of the cd9660 driver, both files exist. Therefore, avoid checking for "video_ts/foo.vob". o Bump PORTREVISION PR: 92258 Submitted by: edwin
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/vobcopy/Makefile1
-rw-r--r--sysutils/vobcopy/files/patch-dvd.c31
2 files changed, 32 insertions, 0 deletions
diff --git a/sysutils/vobcopy/Makefile b/sysutils/vobcopy/Makefile
index 922b86a5efd5..77364b6e7fc1 100644
--- a/sysutils/vobcopy/Makefile
+++ b/sysutils/vobcopy/Makefile
@@ -7,6 +7,7 @@
PORTNAME= vobcopy
PORTVERSION= 0.5.16
+PORTREVISION= 1
CATEGORIES= sysutils
MASTER_SITES= http://lpn.rnbhq.org/download/
diff --git a/sysutils/vobcopy/files/patch-dvd.c b/sysutils/vobcopy/files/patch-dvd.c
new file mode 100644
index 000000000000..94bbfc9f0081
--- /dev/null
+++ b/sysutils/vobcopy/files/patch-dvd.c
@@ -0,0 +1,31 @@
+--- dvd.c.orig Wed Dec 7 21:31:56 2005
++++ dvd.c Wed Feb 1 22:23:15 2006
+@@ -692,28 +692,6 @@
+ /* fprintf(stderr,"debug: vob_size: %lli\n",buf.st_size); */
+ }
+ }
+- strcpy( stat_path, path_to_vobs3 );
+- strcat( stat_path, "_1.vob" );
+- if( ( tmp_streamin1 = fopen( stat_path, "r" ) ) != NULL ) /*check if this path is correct */
+- {
+- fclose ( tmp_streamin1 );
+- subvob = 1;
+- while( !stat( stat_path, &buf ) )
+- {
+- /* adjust path for next subvob */
+- subvob++;
+- strcpy( stat_path, path_to_vobs3 );
+- strcat( stat_path, "_" );
+- sprintf( temp1, "%d", subvob );
+- strcat( stat_path, temp1 );
+- strcat( stat_path, ".vob" );
+-
+- vob_size += buf.st_size;
+-/* fprintf(stderr,"debug: vob_size: %lli\n",vob_size); */
+-/* fprintf(stderr,"debug: vob_size: %lli\n",buf.st_size); */
+- }
+- }
+-
+ return ( off_t ) vob_size; /* think that (off_t) is not really needed here?
+ as it is defined as off_t and the function is
+ also defined as off_t */